WP Downgrade | Specific Core Version

Beschrijving

WordPress Core Downgrade/Update

NL: De plugin “WP Downgrade” dwingt de WordPress-updateroutine om de installatie van een gespecificeerde WordPress release uit te voeren. De Core Release die je opgeeft wordt dan gedownload van wordpress.org en geïnstalleerd zoals bij elke reguliere update. Je kunt permanent op een vorige versie van je keuze blijven of geselecteerde updaten.

De gebruiker Gahapati beschrijft het zo veel beter dan ik kan. (Bedankt!)

WP Downgrade | Specific Core Version heeft het potentieel om een van de meest geliefde plugins te worden onder degenen die simpelweg niet kunnen updaten naar de nieuwste WP release.

In het verleden was de nieuwste WP release het enige aanbod voor WP’s Automatic Update routine. Dit liet iedereen achter, die moet wachten met Core updates, totdat hun plugins compatibel worden met nieuwere WP releases. Wanneer dit eindelijk gebeurt, is er vaker wel dan niet al weer een Core update geweest. Uiteindelijk was een gevreesde, omslachtige, tijdrovende en foutgevoelige handmatige update de enige manier om te gaan.

Met WP Downgrade | Specifieke Core Versie dit behoort nu tot het verleden. Iedereen die achterloopt op de nieuwste WP release, kan nu automatische updates gebruiken, zelfs voor lagere WP versies. Wat WP Downgrade doet, is WP laten geloven dat de versie die je wilt bijwerken naar eigenlijk de nieuwste versie is. Hierdoor is er geen verschil met updaten naar de nieuwste versie.

Om veiligheidsredenen denk ik dat dit een onmisbare plugin is voor iedereen die een “doorgewinterde” WP installatie uitvoert, en het zou eigenlijk een Core functie moeten zijn om niet exclusief te kunnen updaten naar de nieuwste WP release, maar in plaats daarvan een keuze te hebben uit veilige releases.

Nieuwe geavanceerde optie: je kunt de downloadlink nu indien nodig handmatig bewerken. Dit maakt bijvoorbeeld een verandering van taal voor wp-core mogelijk. Of je kunt de release van een andere bron krijgen.

DE: Das Plugin “WP Downgrade” zwingt die WordPress-interne Update-Funktion, ein bestimmtes WordPress-Release zu installieren. Das definierte Core-Release wird wie ein reguläres Update von wordpress.org bezogen und direkt installiert.
Das klappt wie gewohnt per Update-Button im Admin-Bereich oder per Auto-Update. Die Versionsnummer kann sowohl höher als auch niedriger sein als die aktuell installierte Version. Somit ist also auch ein Rollback auf frühere Releases möglich. Dein WordPress wird solange auf dieser Version bleiben, bis du eine neue Versionsnummer in WP-Downgrade hinterlegst (oder bis du die Versionsnummer leerst oder das Plugin deaktivierst).

Achtung: Nutzung auf eigene Gefahr!

WP-Downgrade werkt meestal prima. Toch is een versiewijziging altijd een riskante ingreep! Maak zeker vooraf een back-up van je bestanden en de database! Ik neem geen verantwoordelijkheid voor je installatie en zal geen ondersteuning bieden.

Plugin hilfreich? Sag Danke!

Ich stelle das Plugin kostenlos zur Verfügung, freue mich aber sehr über Spenden oder einen Link auf meinen Reiseblog https://www.reisetiger.net! 🙂
Bitte bewerte WP Downgrade, wenn es für dich nützlich ist!

Schermafdrukken

  • Release-Nummer hinterlegen
  • Downgrade auf hinterlegte WordPress-Version aktivieren
  • WordPress bietet eine ältere Version als Update an

Installatie

De makkelijkste manier:

  1. Gehe in deinem WordPress Backend auf Plugins -> Installieren und suche dort nach “WP Downgrade”.
  2. Klicke in der Trefferliste bei “WP Downgrade” auf “Jetzt installieren”
  3. Activeer de plugin
  4. Nun findest du unter “Einstellungen” einen neuen Punkt namens “WP Downgrade”. Dort kannst du die gewünschte Core-Versionsnummer hinterlegen und anschließend das WordPress-Update vornehmen.

De handmatige manier:

  1. Lade das Plugin herunter
  2. Entpacke die ZIP-Datei
  3. Lade den gesamten Ordner wp-downgrade per FTP in das Verzeichnis /wp-content/plugins/ auf deinen Blog hoch
  4. Gehe in deinem WordPress Backend zu Plugins und aktiviere das Plugin
  5. Nun findest du unter “Einstellungen” einen neuen Punkt namens “WP Downgrade”. Dort kannst du die gewünschte Core-Versionsnummer hinterlegen und anschließend das WordPress-Update vornehmen.

FAQ

V: Knop voor update/herinstallatie is niet zichtbaar

A: Als er geen knop is voor update/herinstalleren van core op /wp-admin/update-core.php, wordt dit geblokkeerd door een aangepaste code. Kan een andere plugin of je thema zijn. Misschien probeer je zoiets als dit:

  1. Deactiveer alle andere plugins
  2. Overschakelen naar een standaardthema
  3. Verwijder dit uit wp-config: define( 'WP_AUTO_UPDATE_CORE', false );
  4. Verwijder zoiets uit wp-config: remove_action( 'init', 'wp_version_check');
  5. Verwijder zoiets uit wp-config: add_filter('pre_option_update_core','__return_null');
  6. Verwijder zoiets uit wp-config: add_filter('pre_site_transient_update_core','__return_null');
  7. Verwijder “gd-system-plugin” uit /wp-content/mu-plugins/
  8. Verwijder de verwijzing naar gd-config.php in wp-config.php.

Beoordelingen

24 juli 2022
Thanks for such a useful plugin. Solved a problem YooTheme conflict with WP 6. WP Downgrade quickly got the site to WP 5.9.3, and we're back to editing the site. I bet this plugin solves problems like this for a lot of people.
9 juli 2022
not much to say here, this plugin is awesome, not only you can downgrade but you can upgrade on specific version too
14 februari 2022
Works perfectly. Useful to discover if some parts are not working due to a plugin or due to a wp version.
Lees alle 154 beoordelingen

Bijdragers & ontwikkelaars

“WP Downgrade | Specific Core Version” is open source software. De volgende personen hebben bijgedragen aan deze plugin.

Bijdragers

“WP Downgrade | Specific Core Version” is vertaald in 15 talen. Dank voor de vertalers voor hun bijdragen.

Vertaal “WP Downgrade | Specific Core Version” naar jouw taal.

Interesse in ontwikkeling?

Bekijk de code, haal de SVN repository op, of abonneer je op het ontwikkellog via RSS.

Changelog

1.2.5

  • Small code improvement

1.2.4

  • Improved code quality

1.2.3

  • beveiligingsoplossing (bedankt voor het melden!)
  • getest tot en met WordPress 5.9
  • Donatielink in readme.txt updatet. Bedankt voor je steun!

1.2.2

  • compatibiliteit met WordPress 5.5.1
  • Donatielink toegevoegd. Ik ben erg blij met een kopje koffie of een biertje!

1.2.1

  • compatibiliteit met WordPress 5.3.2
  • Bugfix voor URL met taal EN

1.2.0

  • Geavanceerde optie: Je kunt de downloadlink nu indien nodig handmatig bewerken. Dit maakt bijvoorbeeld een verandering van taal mogelijk. Of je kunt de release van een andere bron krijgen.
  • Notities zijn iets verbeterd.
  • compatibiliteit met WordPress 5.0.2

1.1.4

  • Verbeterde toegang tot de instellingenpagina (link uit plugin overzicht)
  • compatibiliteit met WordPress 4.7.1

1.1.3

  • bugfix bij het downloaden van bepaalde talen
  • compatibiliteit met WordPress 4.7

1.1.2

  • opgeschoonde code
  • kleine ontwerpwijziging
  • controle op versienummer toegevoegd

1.1.1

  • Englische Sprachdateien hinzugefügt. Vielen Dank an Gahapati!!

1.1.0

  • Fehler bei Sprachen ungleich “de_DE” behoben. Danke an Gahapati!!

1.0.0

  • Erste stabile Beta-Version
  • WordPress Downgrade oder Update nach Wahl
  • Funktioniert für Deutsche Sprachversion