WordPress importeer-plugin

Omschrijving

De WordPress importeer-plugin zal de volgende content van een WordPress export-bestand importeren:

  • Berichten, pagina’s en andere aangepaste berichttypes.
  • Reacties
  • Custom fields en post meta
  • Categorieën, tags en termen voor aangepaste taxonomieën
  • Auteurs

Voor meer informatie kun je op de Codex pagina over het importeren van content kijken

FAQ

Installation Instructions

De snelste methode voor het installeren van de importeer-plugin is:

  1. Ga naar Bewerken -> Importeer in het WordPress dashboard
  2. Klik op de WordPress link in de lijst van importers
  3. Klik op “Nu Installeren”
  4. Klik als laatste op “Activeer Plugin & Run Importer”

Als je het liever handmatig doet, volg dan deze stappen:

  1. Upload de wordpress-importer folder naar de /wp-content/plugins/ directory
  2. De plugin activeren via het ‘Plugins’ menu in WordPress
  3. Ga naar het Tools -> Import scherm, klik op WordPress
Help. Ik krijg “out of memory”-fouten of een wit scherm.

Als je geëxporteerde bestand erg groot is kan je importscript tegen de geheugenlimiet voor PHP van je host aanlopen.

Een bericht als “Fatal error: Allowed memory size of 8388608 bytes exhausted” geeft aan dat het script je XML-bestand niet succesvol kan importeren onder het huidige PHP geheugenlimiet. Als je toegang hebt tot het php.ini bestand, kun je deze limiet handmatig ophogen; als je geen toegang hebt (bijvoorbeeld, je WordPress installatie is gehost op een shared server), moet je wellicht je geëxporteerde XML-bestand opdelen in kleinere stukken en het importscript een voor een runnen.

Voor diegenen met shared hosting is het waarschijnlijk het best om de hosting support te vragen vast te stellen wat de veiligste manier voor het importeren is. Een host is wellicht bereid tijdelijk de geheugenlimiet op te heffen en/of het gehele proces aan hun kant uit te voeren.

WordPress Codex: Importing Content

Beoordelingen

Media gallery import broken

When trying to import a WordPress export file that includes Media, you get the following error:

Notice: wp_get_http is deprecated since version 4.4.0! Use WP_Http instead.

Is this plugin broken since versions 4.4.0 of WP core or higher?!?

Unbelievably bad and broken

I’m using this just to try to import the official theme unit test, and it turns out that this plugin seems developed in 1964.

I’m replacing real path with MYPRAVETEURL:

_____________________________________________

Notice: wp_get_http is deprecated since version 4.4.0! Use WP_Http instead. in /MYPRIVATEURL/wp-includes/functions.php on line 3831

[Moderated to delete giant paste. Please use pastebin.com or gist.github.com for large pastes.]

Rarely works well, but forced to use to migrate from wordpress.com

Obviously Automattic want to keep people on wordpress.com, yet still be able to claim an ‘open’ platform (but where’s the full source code, not just Calypso?), so they provide a sh1t plugin for migration to self-hosted wordpress.org.

It rarely works, let alone well, but seems to be the only tool available. Never use this plugin except to migrate from wordpress.com to self-hosted wordpress.org. Any other tool will always be better for any other job.

wordpress.org is open. wordpress.com is not. Do not use wordpress.com in the first place if you want to save yourself hassle in the long run. (I make money out of people who do, but I shouldn’t have to.)

Lees alle 285 beoordelingen

Bijdragers & ontwikkelaars

“WordPress importeer-plugin” is open source software. De volgende personen hebben bijgedragen aan deze plugin.

Bijdragers

“WordPress importeer-plugin” is vertaald in 44 talen. Dank voor de vertalers voor hun bijdragen.

Vertaal “WordPress importeer-plugin” naar jouw taal.

Interesse in ontwikkeling?

Bekijk de code, haal de SVN repository op, of abonneer je op het ontwikkellog via RSS.

Changelog

0.6.3

  • Ondersteuning toegevoegd voor het importeren van term metadata.
  • Repareer een bug die slashes verwijderde uit geïmporteerde inhoud.
  • Repareer een bug die in sommige gevallen karakters verwijderde uit CDATA.
  • Repareer PHP notices

0.6.2

  • wp_import_existing_post filter toegevoegd. Zie: https://core.trac.wordpress.org/ticket/33721

0.6

  • Ondersteuning voor WXR 1.2 en meerdere CDATA secties
  • Berichten zijn geen duplicaten als hun berichttypes verschillend zijn

0.5.2

  • Dubbele controle dat het geüploade exportbestand bestaat voordat het verwerkt wordt. Dit voorkomt onjuiste foutmeldingen wanneer een exportbestand is geüpload naar een server met slechte permissies en WordPress 3.3 of 3.3.3 wordt gebruikt.

0.5

  • Importeer reactie meta (vereist export vanaf WordPress 3.2)
  • Kleine bugfixes en verbeteringen

0.4

  • Koppel reactie user_id indien mogelijk
  • Importeer bijlagen van wp:attachment_url
  • Upload bijlagen naar de juiste directory
  • Herkoppel verkleinde afbeeldingsurl’s op de juiste manier

0.3

  • Gebruik een XML Parser indien mogelijk
  • Fatsoenlijke support voor het importeren van navigatiemenu’s
  • … en nog veel meer, bekijk Trac ticket #15197

0.1

  • Eerste release