Updates uitschakelen voor WordPress core, plugins en thema’s

Beschrijving

Deze plugin schakelt alle WordPress updates uit (core, plugins en thema’s). Dit kan handig zijn als je meerdere omgevingen gebruikt, zoals een live- en stagingserver, en je niet wil dat gebruikers de updatefunctionaliteit gebruiken.

Deze plugin schakelt niet alleen het update mechanisme uit voor de core, plugins en thema’s, maar verwijdert ook het update menu-item uit het linker navigatiemenu in het beheerder dashboard.

Schermafdrukken

  • WordPress dashboard voordat je de plugin activeert.
  • Na het activeren van de plugin zijn alle updatemeldingen uitgeschakeld.

Installatie

  1. Download het .zip bestand en upload de uitgepakte map naar de /wp-content/plugins/ folder.
  2. Activeer de plugin via het ‘Plugins’ menu in WordPress.

FAQ

Ik weet niet zeker wat deze plugin doet, moet ik deze gebruiken?

Nee, het up-to-date houden van WordPress is om veiligheidsredenen erg belangrijk. Je moet WordPress updates alleen uitschakelen als je WordPress up-to-date houdt met behulp van een ander mechanisme, zoals een staging-server of svn.

Kan ik een functieaanvraag of bugrapport indienen?

Ja, gebruik het ondersteuningsforum om eventuele problemen te rapporteren. Je kunt codesuggesties indienen in de GitHub-repository.

Beoordelingen

14 januari 2021
Just wondering why this Dimond doesn't have even a single review. Love it 🙂
Lees alle 3 beoordelingen

Bijdragers & ontwikkelaars

“Updates uitschakelen voor WordPress core, plugins en thema’s” is open source software. De volgende personen hebben bijgedragen aan deze plugin.

Bijdragers

“Updates uitschakelen voor WordPress core, plugins en thema’s” is vertaald in 13 talen. Dank voor de vertalers voor hun bijdragen.

Vertaal “Updates uitschakelen voor WordPress core, plugins en thema’s” naar jouw taal.

Interesse in ontwikkeling?

Bekijk de code, haal de SVN repository op, of abonneer je op het ontwikkellog via RSS.

Changelog

1.3.7

WP 6.4 compatibiliteit getest

1.3.6

Door add_filter ( 'pre_site_transient_update_core', '__return_null' ); te gebruiken, werd het beheerder dashboard vertraagd omdat het de tijdelijke gegevens ongeldig maakte. Ik heb de functie du_last_checked toegevoegd om een neppe laatste updatecontrole uit te voeren, waardoor WordPress denkt dat de controle heeft plaatsgevonden en er niets hoeft te worden geüpdatet.

1.3.5

Minimaal vereiste WP versie verhoogd naar 4.6

1.3.4

Bestandsnamen van vertaalbestanden geüpdatet

1.3.2

Sitediagnose update uitgeschakelen

1.3.0

Ondersteuning voor vertalingen toegevoegd

1.2.9

WordPress 6.3 compatibiliteit getest

1.2.5

WordPress 5.8 compatibiliteit getest

1.2

PHP 7.2 compatibiliteitsverbeteringen

1.1

automatic_updater_disabled filter toegevoegd

1.0

Eerste release