• Opgelost koetje

    (@koetje)


    Zelf beheer ik de website landbouwfoto.nl

    Plotseling begon de website allemaal 404-foutmeldingen te vertonen, en ik kon mijn cms-systeem niet meer in. Er restte mij toen niks anders dan de boel verwijderen en wordpress opnieuw installeren. Gelukkig heb ik nog een back-up.

    Nu is echter het probleem, dat, wanneer ik de back-up installeer via phpmyadmin de website weer helemaal down gaat. Er komt weer een wit scherm. Terwijl ik zeker weet, dat toen ik de back-up maakte er nog niks met de site aan de hand was.

    Nu is mijn vraag: is het mogelijk om een back-up terug te zetten als je wordpress opnieuw hebt geinstalleerd? en hebben jullie mischien enige suggesties die ik zou kunnen gebruiken?

    mvg,
    Frederik

15 reacties aan het bekijken - 1 tot 15 (van in totaal 18)
  • Dag Frederik

    Het is zeker mogelijk, maar er kan zoals je ziet genoeg mis gaan.

    Een wit scherm duidt vaak op een php error die niet wordt weergegeven.
    Je zou eens moeten nagaan bij je hosting of ze die errors kunnen aanzetten om te zien wat het zegt.

    Vandaaruit kunnen we verder kijken.

    Thread starter koetje

    (@koetje)

    Als eerste bedankt voor de snelle reactie!

    Mijn hostingprovider zegt hierover het volgende: http://www.hosting2go.nl/?refid=200&s=klantenfaq&id=860&pkw=error

    Ik heb een php.ini aangemaakt, en via FTP geupload. Wat moet ik daar verder mee doen?

    Verder ben ik al een klein stapje verder, er is al iets meer content te zien. Alleen zodra ik op ‘lees meer’ klik gaat het mis. Ook is de opmaak niet wat het zou moeten zijn 😛

    De layout is niet in orde omdat de CSS niet gevonden wordt. Die staat volgens de site hier:

    http://www.landbouwfoto.nl/wordpress/wp-content/themes/Topaz_Mag_Orange/style.css

    Maar dat bestaat niet.

    Die not found error krijg je omdat je permalinks staan ingeschakeld maar er waarschijnlijk geen .htaccess is.

    Thread starter koetje

    (@koetje)

    Ik heb wel een .htaccess. Kan inmiddels ook al mijn posts zien in mijn dashboard.

    Echter zie ik nog steeds een wit scherm. Als ik naar landbouwfoto.nl/wordpress ga, zie ik wel hoe de website eruit zou moeten zien, alleen zodra je ergens op klikt gaat hij weer op wit.

    Thread starter koetje

    (@koetje)

    Iemand enig idee?

    http://www.landbouwfoto.nl/wordpress zie je het dus zoals het zou moeten zijn.
    http://www.landbouwfoto.nl/index.php geeft hij de melding:
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, frederik.roseboom@hotmail.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request

    Lijkt me dus een conflict tussen de database en wordpress zelf. Als ik in de database de tabellen leeghaal doet hij het wel gewoon.

    Ik wil alleen wel graag al mijn posts behouden. Iemand een oplossing? Alvast bedankt!

    mvg,
    Frederik

    Thread starter koetje

    (@koetje)

    Ik vrees toch dat er wat mis is met mijn .htaccess, ik weet alleen niet wat.

    Nadat ik de permalinks op default heb gezet, kan ik op mijn site komen door http://www.landbouwfoto.nl/wordpress. Ik kan alleen geen pagina’s/berichten lezen.

    Ik heb mijn .httaccess bestand in /httpdocs gezet. Mischien is hij fout geprogrammeerd? nu staat dit erin:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Als er iemand een oplossing heeft, graag!

    Moderator Remkus de Vries

    (@defries)

    Sleutelbeheer WordPress NL

    Ik zie een paar verschillen. Dit is de meest standaard en correcte versie die er in 99 van de 100 gevallen hoort:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    Thread starter koetje

    (@koetje)

    Mmh, dat helpt ook niet.

    Zou het ook mogelijk zijn om alleen de tabel wp_posts te beware, en de rest gewoon leeg te maken?

    Moderator Remkus de Vries

    (@defries)

    Sleutelbeheer WordPress NL

    Zou’k niet doen. Moet een rewrite issue zijn. Wat heeft je hoster hier over vertellen?

    Thread starter koetje

    (@koetje)

    Heb m’n hoster een mailtje gestuurd. Maar dat zal sowieso wel maandag worden voordat daar antwoord van komt 😉

    Dan zal ik daar eerst maar is op wachten. Iig bedankt!

    Thread starter koetje

    (@koetje)

    Van mijn zeer snelle klantenservice kreeg ik het volgende bericht:
    Hallo Frederik,

    De reden dat uw links niet werken op http://www.landbouwfoto.nl/wordpress is dat u ergens iets verkeerd ingesteld heeft staan in uw redirects, waardoor onderstaande foutmelding ontstaan. Die moet u eerst oplossen om het geheel werkend te krijgen. Wellicht dat u meer informatie vindt op de diverse fora betreffende wordpress.

    ————————————————-
    Onderstaande is een deel van uw error_log

    [Sat Jan 08 14:12:16 2011] [error] [client 82.173.99.67] Directory index forbidden by rule: /home/vhosts/landbouwfoto.nl/httpdocs/, referer: http://www.landbouwfoto.nl/wordpress/
    [Sat Jan 08 14:12:33 2011] [error] [client 82.173.99.67] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use ‘RewriteOptions MaxRedirects’ to increase the limit if neccessary., referer: http://www.landbouwfoto.nl/wordpress/
    [Sat Jan 08 14:12:33 2011] [error] [client 82.173.99.67] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace., referer: http://www.landbouwfoto.nl/wordpress/
    [Sat Jan 08 14:12:33 2011] [error] [client 82.173.99.67] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use ‘RewriteOptions MaxRedirects’ to increase the limit if neccessary., referer: http://www.landbouwfoto.nl/wordpress/
    [Sat Jan 08 14:12:33 2011] [error] [client 82.173.99.67] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace., referer: http://www.landbouwfoto.nl/wordpress/
    [Sat Jan 08 14:12:33 2011] [error] [client 82.173.99.67] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use ‘RewriteOptions MaxRedirects’ to increase the limit if neccessary., referer: http://www.landbouwfoto.nl/wordpress/

    Nu is het punt, waar gaat het mis? want ik kan hier niet echt veel uit wijs worden

    mvg,
    Frederik

    Moderator Remkus de Vries

    (@defries)

    Sleutelbeheer WordPress NL

    dit zegt mij niks.. althans, ik kan op basis van de informatie die ik heb niet beoordelen wat er aan de hand is…

    Thread starter koetje

    (@koetje)

    Tja, de problemen zijn vooral begonnen na een .htaccess bestand, vandaar dat ik het daar ook probeer te zoeken. Alleen die zou nu gewoon goed moeten zijn.

    Wat voor info zou ik nog meer moeten hebben Remkus om het probleem inzichtelijker te maken? Sowieso bedankt btw!

    Moderator Remkus de Vries

    (@defries)

    Sleutelbeheer WordPress NL

    pfff… ben wel nieuwsgierig wat deze plugin je vertelt: http://pluginbuddy.com/serverbuddy-check-hosting-quality-security-issues-more/

    Thread starter koetje

    (@koetje)

    Om precies te zijn zegt die dit: http://i271.photobucket.com/albums/jj143/Frederik_012/check.jpg.

    Wat daaronder nog stond was allemaal OK

    Over de beveiliging: http://i271.photobucket.com/albums/jj143/Frederik_012/check2.jpg

15 reacties aan het bekijken - 1 tot 15 (van in totaal 18)

Het onderwerp ‘Wit scherm na terugzetten back-up’ is gesloten voor nieuwe reacties.