Support » Code oplossingen gezocht » WP Loop probleem

  • Mijn website heeft altijd de links van ‘Older posts’ & ‘Newer posts’ weergeven. Sinds een tijd zijn deze echter altijd verdwenen.

    De code van mijn index.php:

    <?php get_header(); ?>
    
    <div id="content-wrapper">
    
    <div id="sidebar" class="right">
    </div>
    
    <div id="nieuws-wrapper" class="left">
    
    <h1 class="main-title"><?php _e('Laatste nieuws', 'asd'); ?></h1>
    	<div id="news-categories">
    	 	<span class="left"><?php _e('Categorie├źn','asd'); ?>: </span><ul><?php wp_list_categories( 'title_li=' ); ?></ul>
    	 	<br class="clear" />
    	</div>
    
    <?php if ( have_posts() ) : ?>
    
        <?php while ( have_posts() ) : the_post(); ?>
    
        <div id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
    
    		<div id="post-image">
    			<a href="<?php the_permalink(); ?>">
    			<?php
    				if ( has_post_thumbnail() )
    					the_post_thumbnail( 'blog-image' );
    				else
    					echo ' ';
    			?>
    			</a>
    		</div>
    
    		<?php the_title('<h2 class="blog-title"><a href="' . get_permalink() . '" title="' . the_title_attribute('echo=0') . '" rel="bookmark">', '</a></h2>'); ?>
    
    		<div class="entry-content">
    			<?php the_excerpt(); ?>
    		</div>
    
    		<div id="entry-meta">
    			<img src="<?php echo get_template_directory_uri(); ?>/images/calender-icon-32.jpg" /><?php the_time(__('F j, Y', 'asd')); ?>
    			<span class="line">|</span>
    			<?php _e('Categorie', 'asd'); ?>: <?php the_category(', '); ?>
    			<span class="line second-line">|</span>
    			<span class="share-text"><?php _e('Delen', 'asd'); ?>: </span><span title="Delen via Facebook" class='st_facebook' st_title='<?php the_title(); ?>' st_url='<?php the_permalink(); ?>'></span>
    			<span title="Delen via Linkedin" class='st_linkedin' st_title='<?php the_title(); ?>' st_url='<?php the_permalink(); ?>'></span>
    		</div>
            <div id="post-tags">
                <p><?php the_tags(); ?></p>
            </div>
    
    	</div>
    
    <?php if(function_exists('wp_paginate')) {
        wp_paginate();
    }
    else {
        pronomar_content_nav( 'nav-below' );
    }
    ?>
        <?php endwhile; ?>
    
    <!-- einde nieuws wrapper -->
    </div>
    
    <?php else : ?>
    
    	<p class="no-posts"><?php _e('Sorry, er zijn geen berichten gevonden.', 'asd'); ?></p>
    
    <?php endif; ?>
    
    <br class="clear" />
    <!-- end content wrapper -->
    </div>
    
    <?php get_footer(); ?>

    De berichten worden weergeven op de pagina ‘News’ met de Blog template zoals de index.php heeft. De pagina’s: asd.nl/news/page/2/ etc. bestaan wel gewoon. Alleen laat de loop nooit de link naar deze pagina’s zien.

    Is hier een fix voor of tips? Het heeft maandenlang prima gewerkt.

  • Het onderwerp ‘WP Loop probleem’ is gesloten voor nieuwe reacties.