Support » Installatie WordPress » WordPress één map hoger installeren probleem

  • Ik ben met een nieuwe site bezig en deze heb ik achter een bestande site neer gezet om te testen. nl. http://www.domeinnaam.nl/wordpress. Nu is de site klaar en wil ik hem dus uit de wordpress map halen en hem in de map van de site zetten(httpdocs). Nu opent hij alleen een witte pagina. Nu heb ik geprobeerd om alles in de map .\wordpress te laten staan en alleen de index.php naar de httpdocs map te halen. In dit bestand heb ik de verwijzing naar de te laden pagina met 1 map verhoogd. Nu opent hij wel de template met de home pagina. Maar als ik daarna op een pagina link klik krijg ik de meldin ‘u heeft geen recht deze pagina te openen.

    Wat doe ik nu verkeerd?

    Met vriendelijke groet.

    Boelie72

10 reacties aan het bekijken - 1 tot 10 (van in totaal 10)
  • In de database tabel wp-options moet je de juiste url invullen. Dat kun je doen via phpmyadmin.
    Pas op met het verplaatsen van losse bestanden als index.php.

    Thread starter Boelie72

    (@boelie72)

    Ok, dit ga ik proberen. Ik heb het wel werkend gekregen met een index.html bestand in de httpdocs map. Deze oplossing heb ik elders in dit forum gevonden. Maar dan is de url altijd http://www.mijndommein.nl\wordpress\.. Dit komt niet mooi over natuurlijk. Ik ga proberen dat via phpmyadmin te doen in de database.

    Ik laat het nog even weten of het gelukt is

    Thread starter Boelie72

    (@boelie72)

    Het is gelukt hoor, deze vraag is opgelost!

    Hallo,

    Omdat de Engelstalige handleidingen mij niet altijd duidelijk zijn, heb ik hier (min of meer) een vertaling en samenvatting van de feedback trachten te maken, over ‘hoe de site van de’wordpress map’ naar de root te verplaatsen.

    Ik heb echter nog een paar vragen, vooraleer ik eraan durf te beginnen.
    Hier komt het:

    Verplaatsen van de site http://www.eigendomein.be/wordpress naar http://www.eigendomein.be

    A. De huidige situatie van de WordPressmap onder de root:

    1. Mijn huidige instellingen zijn:
    > Algemeen.
    > Bij WordPress-adres (URL) staat de volledige url van de WordPressmap: http://www.eigendomein.be/wordpress.
    > Bij Blogadres (URL) staat ook deze URL neer: http://www.eigendomein.be/wordpress (IS DIT JUIST?)

    B. De site naar de root verplaatsen om op te leveren:

    1. Copieren van de index.php uit de map ‘wordpress’ naar de root.
    2. In de index.php dit wijzigen:

    <?php require(‘./wp-blog-header.php’); ?>
    Naar:
    <?php require(‘./wordpress/wp-blog-header.php’); ?> (IS DIT JUIST?)

    3. Is de WP backend nu nog gewoon bereibaar via http://www.eigendomein.be/wordpress/wp-admin?
    Is de website zelf nu al te bereiken via http://www.eigendomein.be?
    4. Als de permalinks zijn ingeschakeld, moet je die updaten via
    > Instellingen -> Permalinks (je hoeft alleen op Wijzigingen opslaan te klikken?).
    Als het bestand de juiste CHMOD heeft (bijv. 666) dan zal WordPress het automatisch aanpassen.
    Zoniet krijg je de nieuwe .htaccess regels te zien en moet je die handmatig in je .htaccess bestand plakken.
    (Maar ik vind nergens een .htaccess file. Waar moet ik die vinden?)

    C. Nog handmatig aan te passen:

    1. Onder wp-content/ themes/eigendomein/header.php

    <?php print ‘<span>Home</span>‘; ?>
    wordt
    <?php print ‘<span>Home</span>‘; ?>

    2. Als de link onder de header nog niet verwijst naar http://www.eigendomein.be
    > Algemene opties > ‘empty page cache’.
    3. Als de nieuwsberichten nog verkeerd verwijzen naar http://www.eigendomein.be/2010/05/sample-post/
    > Moet dus met de plugin ‘W3 Total cache’
    > alle cache deleten (als de standaard instellingen aan staan? Of moeten er instellingen hiervoor aangepast worden?)

    VRAAG:
    In Engelstalige handleidingen staat dus dat alle files onder de map ‘wordpress’ naar de root moeten gecopieerd worden.
    Maar er staat ook dat ‘VOORDAT deze geplaatst worden onder de root, MOETEN de URL en de URI (algemene settings) eerst aangepast worden naar http://www.eigendomein.be en http://www.eigendomein.be. (IS DIT JUIST?
    )
    En men vermeldt ook dat je de site nog NIET mag openen of bekijken in de browser (IS DIT JUIST?)

    En wat met de DATABASE: moet je daar dan niets aan veranderen?

    Het is wat langdradig, mijn excuses. Verder hoop ik dat iemand er ook wat aan heeft.

    Bedankt voor het advies

    Hallo Ballyhoo,

    Op dit moment ben ik met hetzelfde bezig, voor de eerste keer. Ik ben – dus – geen expert, maar kan wel mijn ervaringen zeggen.

    A – klopt
    B – 1 en 2 klopt.
    B3 – Ik weet niet of de website nu al bereikbaar is via http://www.eigendomein.be. Want ik heb eerst B4 gedaan, Permalinks updaten. Toen leek de site bij mij te werken. De standaard dingen van WordPress werken bij mij. Mijn gekochte Theme geeft problemen, maar dat hoort niet in deze thread.

    Een .htaccess file is onzichtbaar. Ik zie ‘m door in mijn ftp-program de optie ‘Show Invisible Files’ aan te klikken. Ik heb de .htaccess file gelijk met het index.php bestand gekopieerd van de map wordpress naar de root.

    C en verder – snap ik niet, sorry. Maar ik ben ook nog een leek op dit gebied 😉

    Dankjewel Henk!

    Voor de feedback.

    Nu ben ik toch al zeker van A en B 1&2.
    Ik ga B4 ook eerst doen.

    Vraagje: je hebt de .htaccess dus gewoon gecopiëerd en niet moeten aanpassen?

    C en verder snap ik ook niet 😉

    Hallo Henk en Boelie en/of Webheer,

    Dit zal wel een heel naïeve vraag zijn, maar:
    is het zichtbaar maken van de site onder de root (vb. domeinnaam.be i.p.v. vb.domeinnaam.be/wordpress) ook niet te doen door bij de hosting in het control pannel de domeinnaam gewoon te linken naar domeinnaam.be/wordpress.

    Ik vermoed van niet, anders zou het wel al gedaan zijn!
    Maar het is een vraag van de eigenaar van de site en ik kan daar eigenlijk geen sluitend antwoord op geven.

    Merci!

    Vraagje: je hebt de .htaccess dus gewoon gecopiëerd en niet moeten aanpassen?

    Ik heb de .htaccess gewoon gekopieerd, en daarna wordt dat bestand vanzelf aangepast. Ik heb dat bestand in ieder geval niet aangepast.

    Bedankt Henk!

    Alles is heel vlotjes gegaan, eigenlijk dankzij een heel eenvoudige en volledige tutorial, die ik vond.
    Deze: http://wpsitebouw.nl/wordpress-verplaatsen-van-map-naar-hoofdmap/#comment-417

    Absoluut de moeite waard om te lezen!

10 reacties aan het bekijken - 1 tot 10 (van in totaal 10)
  • Het onderwerp ‘WordPress één map hoger installeren probleem’ is gesloten voor nieuwe reacties.