Ondersteuning » Code oplossingen gezocht » Woocommerce ‘er is iets misgegaan met het verwerken van je bestelling’

  • Hi! Ik ben met woocommerce mijn eigen webshop aan het bouwen en eigenlijk is alles zo goed als af (dacht ik). Echter wanneer ik mijn betalingsomgeving wil testen, blijf ik de melding krijgen ‘Er is iets misgegaan met het verwerken van je bestelling’. In zowel de testmodus als gewone modus. Ik heb al geprobeerd via google een oplossing te vinden, maar ik kom er niet aan uit wat er fout gaat. Ik gebruik Mollie om betalingen te verwerken en daar staat alles goed ingesteld. Ik heb nu alleen Paypal en Ideal ingesteld. Mijn vermoedden is dat ik ergens met het maken van mijn website iets niet goed heb gedaan. Ik ben niet super technisch ingesteld. De website staat nu weer in testmodus.

    Ik heb al een aantal plugins gedeactiveerd die ik toch niet meer gebruikte, maar ook dat bied geen oplossing!

    Zouden jullie eens met mij mee willen kijken wat er fout gaat?

    Groetjes Laura

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)
  • Guido

    (@guido07111975)

    Hoi Laura,

    Als ik deze fout Google, kom ik onder meer dit artikel tegen. Misschien heb je er iets aan.

    Iets anders, je Cookie balk onderaan heeft geen “ok” knop, dus die blijft actief.

    Guido

    Thread starter paperwildflowers

    (@paperwildflowers)

    Dat artikel had ik inderdaad zelf ook gezien en ik heb Klarna niet ingesteld staan en dat vinkje waar ze in het artikel over hebben staat bij mij ook uit.

    Ik zie nu inderdaad dat na mijn laatste update mijn knoppen zijn verdwenen van de cookie balk, ga ik fiksen!

    Groetjes Laura

    Guido

    (@guido07111975)

    Hoi Laura,

    Gaat bestellen wel goed als je de Mollie plugin uitgezet hebt?
    Gebruik je behalve Mollie nog een andere plugin die inhaakt op WooCommerce?

    Guido

    Thread starter paperwildflowers

    (@paperwildflowers)

    Hi Guido,

    Ik heb geprobeerd om WooPayments te testen en heb de Mollie plugin uitgezet. Via WooPayments doet de creditcard functie inmiddels wel. Echter de Ideal functie doet het ook bij WooPayments niet. Dan krijg ik een zelfde soort melding en staat de bestelling op mislukt. Voor zover mijn technische kennis het toe laat zie ik zowel bij Mollie als bij WooPayments meerdere meldingen dat er iets niet goed gaat met een URL. Bij WooPayments staat er nu: Fout: Not a valid URL. Maar ik kan er niet achter komen wat ik dan moet aanpassen of wat er precies fout gaat.

    Groetjes Laura

    Guido

    (@guido07111975)

    Hoi,

    Als je iDeal wilt zou ik persoonlijk voor de Mollie plugin gaan, niet WooPayments. Mollie is Nederlands. De WooPayments plugin deactiveren, om onderling conflict te voorkomen.
    Maar heb je nu voor beide aanbieders een account aangemaakt? Want iDeal is immers niet gratis.

    Wat de fout betreft, misschien vind je bruikbare info op pagina WooCommerce > Status > (tab) Logs.

    Guido

    Thread starter paperwildflowers

    (@paperwildflowers)

    Hi Guido,

    Ik heb zelf ook de voorkeur voor Mollie. Maar omdat deze niet werkte, heb ik deze pluging even gedeactiveerd en WooPayments geïnstalleerd. Ik heb inderdaad nu voor beide een account aangemaakt. Ik heb ook in de logs gekeken, maar tot daar gaat mijn technische kennis. Ik weet niet wat ik hier uit moet halen. Dit is wat er steeds staat als de Mollie test betaling niet lukt:

    2024-01-04T18:04:26+00:00 DEBUG ideal: Failed to create Mollie payment object for order 1469: [2024-01-04T18:04:26+0000] Error executing API call (422: Unprocessable Entity): The redirect URL is invalid. Documentation: https://docs.mollie.com/overview/handling-errors. Request body: {“status”:422,”title”:”Unprocessable Entity”,”detail”:”The redirect URL is invalid”,”field”:”redirectUrl”,”_links”:{“documentation” {“href”:”https://docs.mollie.com/overview/handlingerrors”,”type”:”text/html”}}}. Field: redirectUrl

    Groetjes Laura

    Guido

    (@guido07111975)

    Hoi,

    Iets met een URL dus.. Misschien iets verkeerd bij hun ingesteld. Neem anders even contact met Mollie op.

    Guido

    Thread starter paperwildflowers

    (@paperwildflowers)

    Bij WooPayments krijg ik een melding met ‘unvalid URL’. Dus ook bij WooPayments lijkt er iets niet goed te gaan met hetzelfde probleem denk ik. Ik heb inmiddels ook een support ticket ingevuld bij Woocommerce. Dus ik hoop dat zij mij wel verder kunnen helpen.

    Guido

    (@guido07111975)

    Ik vond dit topic, deze gebruiker had hetzelfde probleem als jij.

    Guido

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)