Ondersteuning Volgende » Algemene WordPress vragen Volgende » Website verdwenen?

  • Opgelost Toine

    (@toine)


    Deze week was opeens mijn website verdwenen. Van mijn host kreeg ik te horen dat er iemand had proberen in mijn FTP-account te komen. Daar heb ik een nieuw wachtwoord voor gehad. Toen heb ik alle data opnieuw opgeload.
    Daarmee was het echter niet opgelost, want toen stond er opeens ‘Error establishing a database connection’. Blijkbaar was ook het wachtwoord van mijn mycql database verandert. Dus ook dat aangepast in wp-config.php en nu heb ik alleen een witte pagina!

    Ik kan wel inloggen via wp-admin.php en daar berichten schrijven etc, alleen is er niets zichtbaar als je gewoon naar het url-adres http://www.toinevandeven.nl gaat.

    Wat moet ik nog veranderen of aanpassen?

15 reacties aan het bekijken - 16 tot 30 (van in totaal 34)
  • Sorry Henk, ook dat is niet de oplossing…

    @henk, ook hier niet want deze stond al goed zoals jij aangeeft.

    Wat gebeurt er als ik de volledige installatie van wordpress opnieuw doe? Ik heb tot nu toe de bestanden van wordpress op mijn laptop opnieuw geupload, maar dat was de oplossing niet.

    Een vraag hierop in haakend, waarom kan ik in mijn FTP client niet gewoon de wordpress map verwijderen. Als ik dit doe blijven verschillende dingen gewoon staan. Dus ik kan het proces van installeren nooit opnieuw uitvoeren.

    Vroeger met WS-FTP kon ik ook geen gevulde mappen verwijderen. Met WIN-SCP lukt me dat wel.
    Opnieuw uploaden van alles is zeker het proberen waard en eerst leegmaken op de server is dan aan te raden. Desnoods door het wat omslachtige stuk voor stuk leegmaken van de mappen pers stuk.

    Toine, WordPress draait vanaf die server bij je hostingbedrijf dus je moet de nieuw op je laptop uitgpakte bestanden uploaden naar die server met een FTP programma. Daarbij moet je de mappenstructuur laten zoals die is.

    Let wel op dat je wp-config.php weer juist invult/edit.

    Yorsound: Ik zie nog wel een type-verschilletje:

    define('DB_NAME', 'yorsound_nl_yorsoun');
    
    /** MySQL database username */
    define('DB_USER', 'yorso_nl_yorsoun');

    maar dat zal wel goed zijn anders werkte je RSS ook niet, want die haalt de spullen ook uit de database.

    Dat laatste heb ik al gedaan. de uitgepakte wordpress mappen uploaden naar mijn server met ftp-programma. Dat heeft niet gewerkt, maar kan ik ook de volledige installatie helemaal opnieuw doen? En wat zijn daarvan de gevolgen? Dan doel ik op de zogenaamde 5 minuten installatie opnieuw uitvoeren

    mijn site voetbalzakelijk.nl is ineens ook weg en ik zit ineens ook in engelstalige WordPress, waarbij al mijn plugins niet meer te vinden zijn

    Ik ben dus alles file voor file en map voor map gaan verwijderen. Helemaal gelukt op 2 mappen na. Onder WP-Content Thumbnails en Uploads.

    Deze krijg ik op geen enkele manier verwijderd.
    Volgens mij zolang ik deze mappen niet kan verwijderen heeft het opnieuw installeren geen zin.

    Yorsound, wp-content/uploads kan je gewoon laten staan als die verder leeg is. thumbnails ken ik niet; is geen standaard wp map.
    Als de plugins map maar wel leeg is.

    Gewoon uploaden die hap.

    Michiel en de rest: bij welke host zitten jullie?

    @michiel: neem contact op met je host. Hebben die iets verhuisd of teruggezet?

    uploads is niet leeg. Hier staan nog de afbeeldingen in welke ik toen het allemaal nog wel werkte had geupload.

    Voor de info ik zit bij transip.Als host.

    Ik zal het dan toch nog een keer proberen het uploaden.

    EDIT: Weer hetzelfde 🙁 word er zo moedeloos van. Het lijkt wel of hij wat fout is onthoud, want waarom is me dashboard bereikbaar met de ‘oude’ inlog als je alles verwijderd en opnieuw upload.

    Yorsound: zo komen we er niet. Je mag me als je wilt je ftp gegevens mailen en de logon van het controlepaneel dan kijk ik even rechtsstreeks ( info at enduro dot nl )

    Mooi bij Jordi loopt het weer.
    Hij had ooit met reden alle toegangsrechten op 0777 gezet. Ik trof nu het volgende aan:
    alle files stonden op 0640 dus “anderen” geen leesrechten
    alle directories stonden op 0750 dus idem.

    Alle root files naar 0644 gezet en daarna was de site al zichtbaar.
    Vervolgens alles naar de mij bekende basis instellinge van WordPress gezet: files op 0644 en folders op 0755
    NB. bij sommige providers (en bij mij dus ook) moeten de theme files op 0666 staan voordat ik ze vanuit het Dashboard kan bewerken.

    Hoe het zo kwam? Gokje. Sommige hosters houden niet van 0777. Misschien draaien ze af en toe en script en knallen dan alles naar een lagere setting. Heeft iemand daar een idee over?

    @toine: kijk die settings even na en als het dat niet is mag je me ook mailen; adres zie hier boven.

    Ik zit bij Hostnet, maar ik denk niet dat het aan hen ligt. In de database die bij hun draait is niets veranderd (heb overigens nog geen reactie op mijn vraag per email binnen). In WordPress zijn wel wijzigingen; sinds vanmorgen is mijn hele theme Constructor onzichtbaar geworden/verwijderd. Het gekke is dat alles nog wel in de database bij Hostnet staat.

    Michiel, themes staan niet in de databse maar in wp-content/themes/

    Gewoon Theme opnieuw uploaden (de originele of de laatst werkende versie waarin je evt al wel werkende aanpassingen gedaan had).

    Algemeen: bijvoorkeur nooit op een live site dingen uitproberen maar op een test site.

    ga ik doen, hartelijk dank voor de hulp @henkholland

15 reacties aan het bekijken - 16 tot 30 (van in totaal 34)
  • Het onderwerp ‘Website verdwenen?’ is gesloten voor nieuwe reacties.