Support Volgende » Code oplossingen gezocht Volgende » Website redirected you too many times after installing SSL (for the second time)

  • Opgelost Mathijs Lemmers

    (@mathijs-lemmers)


    Hi everyone,

    So I have this website that was build on someone elses hosting. That person installed SSL on the website but let it expire which caused a lot of problems resulting in me hosting it myself and completely removing everything that had to do with SSL.

    Now, a year later, I installed SSL again, but I’m getting the error ‘Website redirected you too many times ‘. Which I can’t seem to fix.

    I’ve tried clearing browser cookies, checking if the general url settings are correct and a bunch of other things. I have absolutely no clue what to do now, so I’m hoping for some assistance…

    Thanks so much in advance!

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

6 reacties aan het bekijken - 1 tot 6 (van in totaal 6)
  • Moderator Jeroen Rotty

    (@jeroenrotty)

    Hi,

    How did you do the migration and all URLs in the database to HTTPS?
    If that’s still broken and you have mixed content, that issue can occur.

    Anyhow, this is a Dutch forum, so I’ll continue in Dutch.

    Mathijs,
    Heb je alles aangepast in je database zodat alles verwijst naar HTTPS? Staat in je wp_options tabel (database) ook de twee velden op het juiste URL?

    Jeroen

    Hi Jeroen!

    Allereerst bedankt voor je reactie en mijn excuses voor het Engelstalige bericht. Het was me totaal niet opgevallen dat ik op het Nederlandse forum zat 😉

    Ik heb even in de tabel gezocht die je benoemd en hier staan beide velden op de juiste url.

    Wél vind ik nog matches wanneer ik in alle tabellen zoek naar ‘http://marjoleinvanasperen’. Moet ik dit allemaal aanpassen?
    Bij de tutorials over het omzetten van je website naar https heb ik nergens iets over de database gelezen.

    Ik hoor het graag!

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Ja overal moet dat naar de https:// versie verwijzen.

    Maar dat moet je niet één voor één doen hé, daar bestaan gemakkelijke scripts voor, zoals die van Interconnect.it.

    https://interconnectit.com/products/search-and-replace-for-wordpress-databases/

    Succes.
    Jeroen

    Hi Jeroen,

    Ik heb de nodige aanpassingen in de database gedaan (op de GUID url’s) na. Maar dit heft het probleem helaas niet opgelost.

    Twee nieuwe bevindingen:

    • Ik kan wel gewoon het beheer in
    • Wanneer ik mijn zelfgemaakte thema (dat gebruik maakt van Timber) deactiveer is de website weer gewoon zichtbaar.

    Het zal dus iets te maken hebben met het thema, ik zou alleen niet weten wat…
    Heb jij misschien enig idee?

    Alvast bedankt!

    Groet,
    Mathijs

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Ik heb het vermoeden dat er misschien nog manuele verwijzingen in je thema staan? Misschien die manueel aanpassen met een zoek/vervang opdracht in je thema map?

    Jeroen

    Probleem opgelost! Ik had al eens gezocht op http://marjolein en vond geen resultaten. Nu bleek echter dat er in de functions.php een redirect stond. Nu ik deze heb verwijderd loopt alles weer helemaal goed.

    Bedankt voor de hulp!

6 reacties aan het bekijken - 1 tot 6 (van in totaal 6)