Support » Installatie WordPress » Website niet meer bereikbaar

  • Hallo mensen, Ik ben een simpele webmaster van onze fietsclub en ik heb slechts gebruikerskennis van WP. geen technische kennis over codes enzo. Nu is onze website niet meer bereikbaar. Na de update naar WP5 was er ook een storing. Een kennis heeft het toen opgelost, had iets met de editor te maken (Gutenberg)

    Daarna was de site weer online en heeft hij ruim een maand goed gewerkt. Nu wilde ik vandaag de site gaan bewerken, maar bij elke klik die ik deed viel er weer een stuk weg en nu is zelfs de site ook niet meer bereikbaar.

    Dit is de foutmelding:

    Parse error: syntax error, unexpected ‘[‘ in /var/www/domains/pedaleurs.nl/www/wordpress/wp-content/plugins/rsvpmaker/gutenberg/src/init.php on line 25

    edit: Ik heb eens gezocht in de catacomben van WP en de regel waarnaar deze foutmelding verwijst zit in een function:

    function rsvpmaker_server_block_render(){
    register_block_type(‘rsvpmaker/event’, [‘render_callback’ => ‘rsvpmaker_one’]);
    register_block_type(‘rsvpmaker/upcoming’, [‘render_callback’ => ‘rsvpmaker_upcoming’]);

    misschien maakt dit iets duidelijk?

    • Dit onderwerp is gewijzigd 7 maanden, 2 weken geleden door  Metssr. Reden: iets toegevoegd aan de tekst

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

12 reacties aan het bekijken - 1 tot 12 (van in totaal 12)
  • Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Hoi,

    In eerste instantie zie ik in ieder geval al een heel oude PHP versie op je hosting, vraag even na dat je hosting de php versie van 5.3.x verhoogt naar minstens PHP 7.1 maar liefst 7.2.

    De fout die jij krijgt is een conflict van de plugin RSVP maker, je zou eens kunnen proberen tijdelijk die plugin te deactiveren door de map te hernoemen via FTP of de bestandsbeheer tool als je hosting een controlepaneel aanbiedt. Of als je nog in je dashboard kunt gewoonv via de plugin pagina.

    Waar krijg je die fout trouwens? Kan je nog ergens in?

    Groet,
    Jeroen

    Hallo Jeroen. Ik ben met mijn GBV (GezondBoerenVerstand) met Cyberduck eens die foutmelding gaan nalopen en opzoeken. Toen kwam ik hier inderdaad ook achter.
    Ik heb die RSVmaker-plugin verwijderd en nu werkt alles weer.

    bedankt voor de tip van de oudere PHP versie , ik zal mijn providers eens contacten.

    Ik kon overigens nergens meer bij.

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Hoi,

    Goed dat het is opgelost, nu nog je PHP versie omhoog :-).
    Eventueel kijken of je dit zelf niet kunt, anders laten doen.

    Groet,
    Jeroen

    Ik heb al contact gehad met de provider. Ik kan kosteloos een 2e domein krijgen met PHP 7.x (nieuwste) en heb dan een maand de tijd om de site en data over te zetten naar de nieuwe omgeving. oftewel de migratie moet ik zelf doen 😉

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Als zij hun hostingserver(s) niet zelf kunnen upgraden en jou met het technische gedoe opzadelen zou ik snel wegstappen, dit is echt geen klantenservice.

    Groet,
    Jeroen

    lol, een nieuw domein gebruiken om php 7+ te kunnen gebruiken ?! Wat een gekke ganzen..

    • Deze reactie is gewijzigd 7 maanden, 2 weken geleden door  johnny538.

    Hm, ik geloof dat ik toch nog eens contact moet opnemen. Zou het misschien komen omdat het shared hosting is?

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Best wel ja, want dan durven zo’n partijen geen zo’n grote upgrade doen op hun webserver(s) omdat dan een heel groot aantal sites sneuvelen omdat ze PHP code bevatten die niet compatibel is en dus de site doet crashen.

    Groet,
    Jeroen

    Loop ik dat risico dan ook niet als ik het op de door hen aangeboden mannier doe? Is PHP dan niet downwards compatibel? dus dat de versie die nu draait niet per definitie op een nieuwere versie draait?

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Als jij je site dupliceert naar een andere server die een nieuwere PHP versie draait (7.1 maar liefst 7.2) dan zou het kunnen zijn dat je problemen ervaart. Meestal door het gebruik van oude thema’s of plugins die al zeer lang niet zijn bijgewerkt of geen ondersteuning meer krijgen.

    PHP is niet altijd backward compatibel inderdaad, meestal niet met echt brekende zaken (meestal warnings) maar soms wel, het is dan ook aan jou om alles grondig (te laten) testen.

    Groet,
    Jeroen

    OK, bedankt. Dat probleem ga ik natuurlijk ook lopen als ik van provider zou gaan wisselen.

    ps. Ik kwam in een uitleg over het migreren een plugin tegen, die het automatisch zou doen, is dat wellicht een optie voor mij?

    https://www.your-webhost.nl/blog/overig/handleiding-automatisch-verplaatsen-of-verhuizen-wordpress-website/

    • Deze reactie is gewijzigd 7 maanden, 2 weken geleden door  Metssr.
    • Deze reactie is gewijzigd 7 maanden, 2 weken geleden door  Metssr.
    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Klopt, gelijk naar welke host je overgezet worden moet de compatibiliteit getest worden.

    All-in-one migration is een oplossing, Duplicator ook, of manueel.

    Groet,
    Jeroen

12 reacties aan het bekijken - 1 tot 12 (van in totaal 12)
  • Het onderwerp ‘Website niet meer bereikbaar’ is gesloten voor nieuwe reacties.