Support » Overige » Website en Admin werkt niet meer. Help!

  • Ik heb blijkbaar een technisch probleem op mijn site. De hele site is weg en ik ik niet meer op Admin. Help!

    Er heeft zich een kritieke fout voorgedaan op je site. Controleer je inbox van je beheerder e-mailadres voor instructies.

    Als je hulp nodig hebt met dit probleem, kan je gevraagd worden om de volgende informatie:
    WordPress versie 5.5.3
    Huidig thema: Nirvana (versie 1.5.2)
    Huidige plugin: Use Any Font (versie 6.0.1) PHP versie 7.1.33

    Foutdetails
    ===========
    Een fout van het type E_ERROR werd veroorzaakt op regelnummer 62 van het bestand /home/qvisiona/public_html/wp-content/plugins/use-any-font/includes/functions/uaf_editor_functions.php. Foutmelding: Uncaught Error: Call to undefined function array_key_first() in /home/qvisiona/public_html/wp-content/plugins/use-any-font/includes/functions/uaf_editor_functions.php:62
    Stack trace:
    #0 /home/qvisiona/public_html/wp-content/plugins/use-any-font/use-any-font.php(17): include()
    #1 /home/qvisiona/public_html/wp-settings.php(377): include_once(‘/home/qvisiona/…’)
    #2 /home/qvisiona/public_html/wp-config.php(91): require_once(‘/home/qvisiona/…’)
    #3 /home/qvisiona/public_html/wp-load.php(37): require_once(‘/home/qvisiona/…’)
    #4 /home/qvisiona/public_html/wp-login.php(12): require(‘/home/qvisiona/…’)
    #5 {main}
    thrown

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

2 reacties aan het bekijken - 1 tot 2 (van in totaal 2)
  • Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Hoi,

    Er gaat duidelijk iets mis met de code van de Use Any Font plugin, ik vermoed dat de plugin of niet volledig is (er blijkt ee funtie aangeroepen te worden die er niet is) of de plugin veroorzaakt een conflict met een andere plugin of thema op je site.

    In dit geval, zou ik je aanraden om via het controlepaneel van je host te kijken of je aan bestandsbeheer kan om de use any font pluginmap te verwijderen uit de wp-content/plugins/ map. Als dit het enige is die foutloopt, dan zal je site het weer doen. Als er geen bestandsbeheer is, connecteer dan via FTP naar de server en dan kan je ook aan de bestanden.

    Dit was simpelweg een compatibiliteitsprobleem tussen de Use Any Font plugin versie 6.0.1 en PHP 7.1.33 ( < 7.3.x) …

    Volgens het Use Any Font plugin 6.0.2 Changelog:

    Support for older PHP versions.

    De 6.0.2 release werd 1 dag na de 6.0.1 release uitgebracht.
    (Er waren kennelijk meer gebruikers die tegen hetzelfde probleem aanliepen).

    Advies: Use Any Font plugin updaten naar de laatste versie.

    Het probleem is al opgelost? Markeer dit topic dan ff als opgelost. Dank voor de medewerking 😉

2 reacties aan het bekijken - 1 tot 2 (van in totaal 2)