Support Volgende » Plugin vragen Volgende » website down since update php 7.2 – urgent

  • sinds mijn host PHP heeft bijgewerkt naar versie 7.2, is mijn website down. In de foutenlogboeken vond ik deze fout: “FastCGI: server /var/run/php72-cgi/php-cgi stderr: PHP message: PHP Fatal error: continue not in the loop or switch context in shortcodes-woocommerce.php”

    dus de functie “continue” in de woocommerce-plugin werkt niet langer en moet op de een of andere manier worden vervangen.

    dit is de foutieve regel in het bestand shortcodes-woocommerce.php:
    if (! $ product-> is_visible ()) continue;

    Wanneer ik “continue” door “return” vervang, is de website weer up maar de shop (woocommerce) wordt niet weergegeven.

    Ik weet niets over php, dus alle hulp wordt zeer op prijs gesteld.
    Dank u bij voorbaat!!!

1 reactie aan het bekijken (van in totaal 1)
  • geertvanderheide

    (@geertvanderheide)

    Aangezien het probleem in een plugin zit, kun je het beste eerst denken in de richting van het updaten, vervangen of verwijderen van die plugin. Zelf de code van een plugin wijzigen is niet aan te raden.

    WooCommerce Shortcodes is de plugin waar het hier om gaat, dus kijk eerst even of er voor die plugin een update beschikbaar is. Misschien lost dat het gelijk op. Ook het updaten van WordPress zelf en de andere plugins kan een hoop doen om je site compatibel te krijgen met nieuwe PHP-versies.

    Heb je al de nieuwste versie, dan optie twee: Deze plugin verzorgt een knop boven de teksteditor voor het plaatsen van Woocommerce shortcodes. Als je deze knop niet echt nodig hebt, kun je de plugin uitschakelen. De shortcodes zelf zitten in Woocommerce, dus die blijven gewoon werken; alleen de knop voor het handig toevoegen van die shortcodes valt dan weg. Je kunt ‘m ook slechts tijdelijk uitschakelen, om de rest van de site weer online te krijgen, terwijl je een andere oplossing zoekt.

    Ten slotte kun je het probleem melden bij de makers van deze plugin, via WordPress.org (https://wordpress.org/support/plugin/woocommerce-shortcodes) en / of Github (https://github.com/woocommerce/woocommerce-shortcodes).

    Succes!

1 reactie aan het bekijken (van in totaal 1)