Ondersteuning » Algemeen WordPress » Vreemde editor en plugin.

  • Hallo, gebruik een Multi subdomain installatie met een 3.6.1 wp versie. Onlangs maar eens aan het updaten geslagen (thema’s, plugins en netwerk). Toen ook maar gelijk van 3.6.1 naar 3.9.1 gegaan en je raadt het al…probleempjes.

    Het allereerste waar ik tegenaan liep was een totale “verbouwing” van mijn editor…total ander (lastig) uiterlijk en een hoop html in beeld waar ik niet vanaf kom. Daarna enkele plugins die niet meer werken, waarvan Qtranslate toch wel een hele belangrijke voor mij was. Verder kan ik op de subdomeinen plotseling geen plugin meer installeren. Dit kan ik nu alleen nog onder “network admin”. Kan hier natuurlijk wel alle plugins activeren voor het hele netwerk, maar dan zie ik (en werken)ze nog steeds niet op de subdomeinen.

    Toen maar gaan downgraden naar 3.8 (bracht geen verbetering) naar 3.7 (bracht geen verbetering) en zit nu weer op mijn oude vertrouwde 3.6.1. Helaas blijven bovenstaande problemen bestaan.

    iemand enig idee hoe ik:

    a – mijn editor weer normal krijg en graag een uitgebreide versie.
    b – weer plugins kan installeren in mijn subdomain pagina’s

    Hier een voorbeeld hoe mijn editor er nu aan toe is 🙂

    http://www.2b-online.nl/editor.jpg

    Dank voor alle info !!!!

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)
  • == == == eerst een veiligheidsnet…

    Maak een back-up van de database
    Back-up Database:

    1. Dashboard > Extra > Exporteren
    2. Gehele Inhoud
    3. Desgevraagd: Installeer en Run Export plugin
    4. Sla exportbestand op de PC op

    Dan: maak een backup van de WP-installatie

    1. Download, Installeer / gebruik een FTP-programma bv. filezilla[gratis] – [zie onderaan] http://filezilla-project.org/download.php
      om bestanden op de server te beheren. De server is de plek waar de webhoster jouw site draait.
      [De beheerder heeft je vast een mail / bestand / papier gegeven met de nodige inlogggegevens.]
    2. FTP: sla een kopie van de WP-bestanden en mappen op, op je desktop-PC

    == == ==
    De melding bovenaan je schermafbeelding laat zien dat de q-translate plugin [nog] niet lekker samenwerkt met de meer recente versies van WP.

    de maker van de plugin zegt:

    Please be aware of slow updates currently. I will continue supporting qTranslate, but I wouldn’t mind some help. 😉

    Zorg er in elk geval voor dat je de allerlaatste versie van deze plugin hebt geinstalleerd.

    == == == stap 1

    Nu rijst de vraag… Is Q-Translate, WP, of bijvoorbeeld de samenwerking met andere plugins het probleem?

    Het kan goed zijn dat updates, of een plugin roet in ’t eten gooit…
    heb je dit al geprobeerd?

    1. Gebruik FTP om je site te benaderen
      bv. http://filezilla-project.org/download.php
    2. hernoem alle plugins -behalve q-translate – door een ‘0’ te plaatsen voor elke plugin -folder;
      ../wp-content/plugins
    3. == == == update naar de nieuwste WP versie

    4. gebruik het dashboard om naar de laatste versie van WP te updaten
    5. natuurlijk kan je ook handmatig updaten, mbv FTP door een nieuwe versie van WP te uploaden en te OVERSCHRIJVEN
    6. je hebt nu een site met een nieuwe WP en een ‘oude’ q-translate. De rest van de plugins is nog INactief
    7. Check of het probleem met WP en q-translate / de editor is opgelost
    8. JA:verwijder één-voor-één de ‘0’ van een van de andere plugin-mappen, controleer elke keer of het probleem terugkomt
    9. Zo vind je de bron van het probleem; Verwijder de probleem-plugin
    10. alternatief: zoek een alternatieve plugin en controleer.

    Blijkt dat Q-translate een probleem is en blijft, onderzoek dan de mogelijkheid van het gebruik van een andere – soortgelijke- plugin.
    Er zijn er vele!

    NB!
    Ik durf niet te voorspellen of / welke gevolgen deze overstap heeft.
    >>

    1. Maak VOOR ELKE verandering een BACKUP van zowel je database, als je WP-bestanden
    2. maak NA elke succesvolle stap [hoe klein ook] ook een backup!! Zo kan je terug naar een ‘succes’, als de volgende stap toevallig niet werkt…

    Het maken van backups is saai, niet sexy en vraagt [een heel klein beetje] tijd en ‘discipline’, maar raak je in de problemen… een werkende backup terugzetten, kost heel weinig tijd en gaat zonder frustratie; Het oplossen van -onverwachte – problemen VREET tijd en energie…

    Thread starter Frenklin

    (@frenklin)

    Dank Ginfo voor deze uitgebreide info. Zal hier zeker mee aan de slag gaan. Ik zit echter ook nog met die vreemde editor….heb al diverse “editor” plugins geprobeerd, maar wp weigert ook maar iets aan het uiterlijk te veranderen…..heb je wellicht ook hier een tip voor ?

    ps: De editor is onveranderd gebleven in 3.6 – 3.7 – 8 en 9

    Ik verwacht dat dat, met behulp van bovenstaande wordt opgelost / duidelijker wordt!!

    Ik vermoed dat de ‘verouderde’ vertaler, de werking van WP [waaronder de editor, andere plugins etc.] in de war gooit.

    == == == Problemen met het installeren op het subdomein

    Controleer of je bent ingelogd als ‘beheerder’ als je zaken wilt aanpassen op je [sub]domein.

    FTP: Controleer of je ‘voldoende rechten’ hebt om bestanden te lezen, schrijven en te veranderen in de mappen van de [sub]domein.

    Controleer of de map van je subdomein en de onderliggende submappen toegankelijk zijn voor lezen en schrijven.

    >>

    1. gebruik FTP om je site te benaderen
    2. ga naar de map van je subdomein[klik aan]
    3. re-klik map >> klik ‘bestandsrechten’
    4. voer in ‘numerieke waarde’:775
    5. vink aan: ’toepassen op alle submappen’ en sla de wijzigingen op
    6. browser: Druk <CTRL-F5> om je browser te verversen.
      of leeg je browser-cache:
      http://www.browserchecker.nl/cache-bestanden-verwijderen
    7. browser: controleer het resultaat
    Thread starter Frenklin

    (@frenklin)

    Ginfo, alle bovenstaande uitgevoerd en heb nu weer een nette nieuwe install van 3.9.1. Verder alle plugins ge-deactiveerd door er een 0 voor te plaatsen, ze zijn idd allen uitgeschakeld.

    Helaas is het nog steeds zo dat mijn editor in een soort van HTML mode staat en er dus nog steeds niet zo uitziet als de standard editor versie. http://www.2b-online.nl/wp2.jpg en http://www.2b-online.nl/wp3.jpg

    Ik heb verder alle rechten….

    OK, ik begrijp dat

    1. je nu de meest recente WP-versie hebt.
    2. Alle mappen van plugins zijn ‘hernoemd’/ UITgeschakeld.
    3. Zo te zien werkt de site en lijkt in orde, voor bezoekers; hetgeen opmerkelijk is na het uitschakelen van plugins….

    Aangezien de oorzaak / oplossing nu nog niet erg veel duidelijker is geworden, nog iets meer onderzoek…:

    1. dashboard > activeer tijdelijk een standaard theme, bijvoorbeeld twenty twelve
    2. Druk <Ctrl-F5> om de browser te verversen
    3. NB! De site ziet er nu -tijdelijk- heel anders uit!!
    4. Open het dashboard en zie of het probleem met de editor is opgelost
    5. Is dat het geval?? >> dan is het THEMA de oorzaak / oplossing
    6. >> download een ‘schone’ versie van je thema
    7. FTP upload de bestanden van je thema naar je site >> OVERSCHRIJF
    8. dashboard > weergave > thema> activeer het ‘oude’ thema, dat je net hebt ‘ververst
    9. Druk <Ctrl-F5> om de browser te verversen
    10. controleer het resultaat; het kan zijn dat je het menu / widgets even moet [her]activeren

    Levert bovenstaande niets op?
    Dan is niet het thema, maar iets anders de oorzaak van dit probleem.

    == == ==
    Plan ?F:

    Doet dit alles nog steeds niets?

    1. Download een nieuwe set van WP-bestanden
    2. ftp: upload deze bestanden naar de site > overschrijf! De bestaande inhoud blijft intact
    3. Druk <CTRL-F5> om je browser te verversen.
      EN leeg je browser-cache:
      http://www.browserchecker.nl/cache-bestanden-verwijderen
    4. controleer het resultaat
    5. Werkt dit WEL?

    6. doe hetzelfde voor de plugins, één voor één, controleer steeds
    7. Werkt ook dit NIET? laat het even weten?
    Thread starter Frenklin

    (@frenklin)

    Al het bovenstaande gedaan, maar helaas. Ik heb de map waarin mijn wp install staat hernoemd en via mijn provider een schone install gedaan…een nieuwe wp config.php ingesteld.

    Zelfs met die schone install zie ik geen verbetering in de editor….kan het zijn dat de fout in de database zit ?

    kan het zijn dat de fout in de database zit ?

    dat lijkt me een aardige hypothese.

    Wat bedoel je precies met

    een nieuwe wp config.php ingesteld

    Om dat te testen:

    1. gebruik de meest recente ‘nieuwe installatie’ die je hebt, of voer opnieuw een ‘verse installatie’ uit
    2. FTP: hernoem ‘wp-config.php’ naar bijv. ‘0wp-config.php’
    3. browser: type in de url van je site >> omdat wp-config.php ontbreekt wordt de installatie opnieuw uitgevoerd
    4. vul nu bijna dezelfde gegevens in als in ‘0wp-config.php’ >> geef de nieuwste versie alleen een andere ‘prefix’ in het wp-config.php bestand.
    5. voorbeeld: oud: ‘wp_’ nieuw: ‘nwwp_’ [underscore verplicht]
    6. je hebt nu een nieuwe database tabel [in dezelfde databasebestand]. Deze twee versies van wp kunnen probleemloos naast elkaar bestaan, zonder problemen.
    7. Is de installatie afgerond? Controleer ’t resultaat
    8. !!NB
      Toets vooral of het probleem zich [ook] voordoet bij NIEUWE pagina’s en berichten

    veel succes.

    Thread starter Frenklin

    (@frenklin)

    “Oude” WP map hernoemd en een totaal nieuwe install gedaan inclusief database, andere prefix en……YES….een normale editor 🙂 De fout zit hem dus toch in de database.

    Hoe nu verder………mijn originele install is een MULTI en dat heeft ook heel wat zweetdruppels gekost…en hoe krijg ik (eventueel)de data uit die originele (multi)map nu hierin of kunnen we nog wat sleutelen (opschonen) aan de database van de oude install zodat we daar verder mee kunnen ?

    Alvast weer dank voor je uitgebreidde hulp tot zover 🙂

    Fijn dat je nu tot hier bent gekomen…pffff.

    Van nu af aan wordt het experimenteren / proberen om te zien wat [nog] wel werkt, en wat niet [meer].

    We weten nu wel dat het probleem in de database zat, maar niet hoe dat daar gekomen is. Dat maakt de vervolgstappen wat bewerkelijker dan ‘gebruikelijk’.

    Mijn strategie in deze:

    1. maak een back-up van de ‘goed werkende’ database
    2. maak een FTP-kopie van de WP-bestanden
    3. zet beide samen in een map apart ‘BK000
    4. == == ==

    5. maak wijzigingen
    6. toets of de wijzigingen werken
    7. ja aanpassing OK >>
    • maak een FTP-kopie van de WP-bestanden
    • maak een back-up van de aangepaste ‘goed werkende’ database
    • zet beide samen in een NIEUWE map apart
    • BK001

    == == ==

    • aanpassingen NIET OK >>
    • ZET DE MEEST RECENTE FTP-kopie van de WP-bestanden TERUG
    • zet de meest recente werkende database terug
    • controleer of de boel weer werkt
    • probeer opnieuw…
    • Op die manier blijf je – zij het langzaam vooruitgang boeken – en kan je in geval van ’tegenvallers’ redelijk vlot oplossen: één stap terug en dan weer verder.

      == == ==
      Alternatief

      Je kan ook ff kijken of je mazzel hebt voordat je bovenstaande cyclus ingaat:

    1. maak een back-up van de ‘goed werkende’ database
    2. maak een FTP-kopie van de WP-bestanden
    3. zet beide samen in een map apart
    4. dan:

    5. IMporteer een backup van je ‘oude’ database in de nieuwe database. !! Kijk bij het importeren kritisch, wat je wel, en wat je niet importeert / of neem een gok en vertrouw op je backup van de nieuwe site…
    6. kijk of de boel werkt / de inhoud is overgezet…
    7. toets of het probleem terug is…
    8. heb je pech, zet de werkende versies terug…

    Nog een optie…
    De q-translate plugin kan heel goed de oorzaak zijn…
    Kijk naar een alternatief dat een grote gebruikersgroep heeft en geregeld wordt onderhouden…?

    == == ==
    Maak een back-up van de database
    Back-up Database:

    1. Dashboard > Extra > Exporteren
    2. Gehele Inhoud
    3. Desgevraagd: Installeer en Run Export plugin
    4. Sla exportbestand op de PC op

    == == ==
    Terugzetten database

    1. gebruik phpmyadmin [bijv. via je webhost dashbord] om de tabelen / regels MET DE NIEUWE PREFIX TE SELECTEREN
    2. KIES ALS ACTIE ‘LEGEN’ van die velden / tabellen.
    3. OPGELET de tabellen met de oude prefix moet je nog even bewaren!!
    4. browser: dashboard > Extra > Importeren
    5. volg de instructies op het scherm en zet een werkende versie terug
    6. enz. enz.

    Suggestie:
    Sluit deze vraag af.
    Heb je nieuwe ontwikkelingen, schets dan de situatie en dan kijken we hoe we je opnieuw een zetje kunnen geven.
    Veel succes.

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)
  • Het onderwerp ‘Vreemde editor en plugin.’ is gesloten voor nieuwe reacties.