Ondersteuning » Plugin vragen » Verouderde php plugin

  • Goedemiddag

    Rond de eeuwwisseling ben ik een vakantiehuisverhuursite gaan opzetten, daarbij alles volkomen mijzelf geleerd. Zo ook het coderen in php. Ik gebruik daarvoor de plugin PHP Execution. Deze is echter al heel veel jaren niet meer aangepast. En veroorzaakt nu mogelijk fouten, ik krijg bijvoorbeeld update naar WP 6 niet werkend.

    Ik zie vele andere php-plugin’s maar weet niet welke te kiezen. Mijn site vergt geen heel bijzondere dingen van php, anders dan dat een plugin wél van vrij recente datum is. Is er een plugin die – na de-activeren van de huidige – na activeren ervan weer een werkende site zal opleveren zonder dat ik ingewikkelde instellingen moet doen?

    Deze 70-ger heeft graag uw advies…

    Vriendelijke groet.
    Rudolph Smits

    PS de site heeft momenteel dus géén problemen, maar draait nog onder WP 5.9.4.

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

8 reacties aan het bekijken - 1 tot 8 (van in totaal 8)
  • Guido

    (@guido07111975)

    Hallo Rudolph,

    Begrijp ik het goed dat je die plugin gebruikt om op bepaalde plekken in je site PHP-code toe te kunnen voegen? Voeg je dat dan toe rechtstreeks in de standaard tekst editor?

    Ik kan geen vervanging vinden maar dat komt waarschijnlijk omdat dit niet heel veilig is.

    Met de Code Snippets plugin kun je wel op een veilige manier functies/code toevoegen maar werkt net even anders. Je voegt code toe via de eigen pagina van deze plugin.

    Guido

    Thread starter Rudolph Smits

    (@rudolph-smits)

    Klopt Guido, de site is te groot om naar die nieuwe editor om te bouwen. Er staat dus <?php ?> in de html. Ik zoek dus naar een minder oude php-plugin in de hoop dat die het leven van mijn site(s) verlengt.
    Ik gebruik overigens ook nog het thema Twenty-17 en ook daarvan is het de vraag hoelang die nog het leven heeft.

    Dank voor je reactie overigens.

    Rudolph Smits

    Guido

    (@guido07111975)

    Ik lees in het forum van “jouw” plugin dat hij niet werkt met PHP versie 7+. Als jouw site nog op 5.6+ draait is het inderdaad hoog tijd dat je update. Ik heb helaas nog geen andere plugin gevonden waarmee je rechtstreeks in de editor kunt coderen.

    Guido

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Het wordt inderdaad niet als best-practice aangehouden, vandaar dat je dat wellicht ook niet in recentere plugins zal vinden…

    Zou je de stukken PHP niet kunnen verplaatsen naar template files binnen een eigen childthema of in een eigen plugin verwerken en er shortcodes van maken, of in custom blokken. Het is in ieder geval tijd om na te gaan denken over veilige versies, zowel van PHP, WordPress en je plugins/thema’s.

    Thread starter Rudolph Smits

    (@rudolph-smits)

    @guido07111975
    Mijn beide sites draaien onder PHP 7.8 Versie 8 kunnen ze inderdaad niet aan. Maar het lastige is dat de ene site wél foutloos onder WP6 draait en de andere niet.

    @jeroenrotty
    Ik begrijp je suggestie maar dit wordt mij te ingewikkeld. Ik denk er aan de WP-site te verlaten en hem om te zetten naar een Rapidweaversite. Die heb ik ook maar daar gebruik ik bewust geen php. Dat ik daarmee nuttige functionaliteit kwijt ben neem ik dan maar voor lief. Het is nu wachten tot de WP-bom barst en een RW-site zal weer meer bij de tijd zijn.

    Beiden dank voor de reactie.
    Rudolph Smits

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Dat klinkt als nog meer werk, vooral het feit dat je dan je voordeel verliest van een CMS – maar ik snap dat je gewoon een flat file site wilt, dat heeft ook zn voordelen.

    Succes. Werkt het trouwens gewoon niet op de nieuwste versies en met de klassieke editor, of is het de plugin zelf die je nu gebruikt die niet langer bruikbaar lijkt? Op zich kan je altijd nog even mee op een iets oudere major versie van WordPress, want security updates krijg je nog een lange tijd op WordPress. Dit is op heden nog steeds gebackport tot WordPress 3.7, maar dat wordt binnenkort opgeschoven naar WordPress 4.0+ – zie
    https://make.wordpress.org/security/2022/09/07/dropping-security-updates-for-wordpress-versions-3-7-through-4-0/

    Thread starter Rudolph Smits

    (@rudolph-smits)

    @jeroenrotty

    Dank weer voor je reactie. Nee, het vele werk valt wel mee, ik heb al een backup site gemaakt met Rapidweaver (http://www.belard.nl) waarvan ik denk dat ik die kan kopiëren en dan overal de url’s moet aanpassen. Dan verwijder ik alle WP en laad dit site op diens plek.

    Maar begrijp ik je goed en is mijn angst voor uitval door te stoppen met WP- en plugin updates weliswaar gegrond maar niet meteen morgen te verwachten? Dat zou een geruststellende gedachte zijn en mij tijd geven die alternatieve site (www.belard.nl) eerst nog verder uit te bouwen.

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Dat kan je niet inschatten uiteraard, met een plugin van 13 jaar oud en mogelijks nog plugins op je site die achterlopen, is dat maar de vraag. Maar puur op WordPress core niveau kan je nog even verder ja. Als je verder ook alles die kan geüpdatet worden ook update – en veilige accounts en wachtwoorden hebt doe je al goeie dingen, maar alsnog zou het beter zijn dat je natuurlijk alles op het nieuwste hebt, van serveromgeving tot WordPress.

8 reacties aan het bekijken - 1 tot 8 (van in totaal 8)