Ondersteuning » Installatie WordPress » URL probleem, ik kan niet aanpassen naar https

  • Beste mensen,

    – Ik heb een wordpress on mijn eigen Apache2 server. De domeinnaam is ondergebracht is bij Strato. Hun SSL installeren, ook op de Apache, vond ik een hel, vandaar dat ik CloudFlare heb genomen.
    – De url’s zijn hard gecodeerd in wp-config als http. Als ik daar https invul gaat de site offline, evenals wanneer ik geen urls invul op de wp-config.
    – Fotos worden ook opgeslagen met http…En ik kan ook geen posts aanmaken. De indexpagina doet het wel met SSL en ik kan ook in de admin.
    Heeft iemand een idee hoe ik dit kan oplossen? Moet ik CloudFlare uitschakelen en dan aanpassen? Lekker complex ik weet het!
    Groetjes, Bert
    https://bertkrus.nl

    • Dit onderwerp is gewijzigd 1 jaar, 2 maanden geleden door Jeroen Rotty.
    • Dit onderwerp is gewijzigd 1 jaar, 2 maanden geleden door Jeroen Rotty.

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

5 reacties aan het bekijken - 1 tot 5 (van in totaal 5)
  • Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Je kan in het eerste screenshot die velden niet aanpassen omdat of a) de host/tool waarmee je dit installeert dit verhinderd en/of b) het manueel staat ingesteld in je wp-config.php bestand. Haal daar die 2 lijnen weg en die invulvelden in je dashboard gaan bewerkbaar worden.

    Maar … hou er rekening mee dat enkel die 2 velden aanpassen voor problemen zal zorgen, je doet best het volgende:

    1. Maak een back-up van je site/database
    2. Installeer een plugin zoals bv. https://wordpress.org/plugins/better-search-replace/ (hier werk ik wel graag mee als ik niet met een eigen script werk of in rechtstreeks in de database)
    3. Via die plugin kan je dan een zoekopracht doen naar “http://bertkrus.nl” en vervangen door “https://bertkrus.nl” in de database, zo veranderd direct alle verwijzingen ook van media, links, …
    4. Test goed na het uitvoeren van de zoek/vervangopdracht.

    Ik had er een lange tijd geleden nog een tutorial over geschreven met een ander script, maar met de plugin hierboven werkt het even goed: https://wpinfo.be/wordpress-site-migreren-naar-https/

    Thread starter bertkrus

    (@bertkrus)

    Dankjewel Jeroen, ik ben een stap verder gekomen, met de plugin Search and Replace. De Beter Search And Replace gaf telkens een memory limit error. Ik heb je 2 urls gebruikt voor zoek en vervang.

    De huidige situatie is >>

    Met onderstaande in de wp-config:
    define( ‘WP_HOME’, ‘https://bertkrus.nl’ );
    define( ‘WP_SITEURL’, ‘https://bertkrus.nl’ );
    kan ik niet in de admin


    Met:
    define( ‘WP_HOME’, ‘http://bertkrus.nl’ );
    define( ‘WP_SITEURL’, ‘http://bertkrus.nl’ );
    kan ik wel in de admin maar zijn de fotos niet zichtbaar…


    Zonder bovenstaande krijg ik een eternal loop bij de admin.

    Ik moet dus nog wel wat aanpassen….maar wat?
    • Deze reactie is gewijzigd 1 jaar, 2 maanden geleden door bertkrus.
    Thread starter bertkrus

    (@bertkrus)

    Inmiddels heb ik wp opnieuw geinstalleerd, en DNS en SSL uitgeschakeld. Hij draait nu op http://86.87.227.112/?p=7
    Ik kan de wordpress URLs instellen bij algememen instellingen…maar ik ben al zo vaak alles (het is een experiment en ik weet nog niet wat ik ermee wil) kwijtgeraakt…
    Het lijkt me dat ik https://bertkrus.nl invul, opslaan, en dan DND en SSL weer inschakelen, ja toch?

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Als momenteel je WordPress installatie geïnstalleerd staat op IP en dat werkt, en je domein A record verwijst naar dat IP – dan zou je op DNS niveau goed moeten zitten en zou een zoek/vervang over de volledige database gewoon goed moeten gaan om de site onder je domeinnaam te laten draaien. Maar ik heb geen inzicht in hoe je hostingaccount is opgesteld, of daar alle benodigde zaken aanwezig zijn – dus kan je ook weinig garanderen dat een zoek/vervang volledig is om alles te laten draaien op jouw hosting.

    Sowieso, zoals eerder verteld, is enkel de 2 velden aanpassen bij Instellingen > Algemeen niet voldoende om de volledige site over te migreren. Best via zo’n zoek/vervang plugin of extern script laten doen. Of als je nu toch alles van scratch doet, direct installeren op domeinnaam.

    Thread starter bertkrus

    (@bertkrus)

    Oplossing gevonden 🙂 Er is een CloudFlare wp plugin die redirects en loops repareert: https://wordpress.org/plugins/cloudflare/
    Tussen haakjes, nadat ik mezelf wéér had buitengesloten lukte het me om de URL instellingen in de database aan te passen, en zodoende weer toegang kreeg tot de admin.
    Hier vind je de handleidingen:
    https://www.digitalocean.com/community/tutorials/how-to-use-wp-cli-v2-to-manage-your-wordpress-site-from-the-command-line

    https://stackoverflow.com/questions/68442668/cant-update-table-wp-options-for-wordpress-in-mariadb

5 reacties aan het bekijken - 1 tot 5 (van in totaal 5)
  • Het onderwerp ‘URL probleem, ik kan niet aanpassen naar https’ is gesloten voor nieuwe reacties.