Ondersteuning » Algemeen WordPress » Uploaden site mislukt

  • Opgelost Klaarbenje

    (@klaarbenje)


    Ik had een site op een localhost gemaakt en wilde deze uploaden naar de juiste url zodat deze wp-site de oude site (gemaakt met een ander programma) zou vervangen.

    Wat heb ik gedaan:
    backup gemaakt van de site
    config.php aangepast
    url’s in wp aangepast
    de heleboel geupload met ftp en in de root gezet

    Het resultaat:
    de oude site is nog zichtbaar (maar door de foutmelding is dat juist wel fijn)
    /wp-admin is niet oproepbaar: 500 internal server error

    Wat is er mis gegaan en/of wat moet de volgende stap zijn?

15 reacties aan het bekijken - 1 tot 15 (van in totaal 21)
  • Goeie kans dat de index.html van je oude site nog actief is. Hernoem deze.

    Thread starter Klaarbenje

    (@klaarbenje)

    Ik heb de index.html benoemd naar blabla.html maar nog steeds is de oude site zichtbaar en /wp-admin is ook nog steeds niet oproepbaar (500 melding).

    staat het wel in de goede map?
    en ondersteund je server wel php?

    Thread starter Klaarbenje

    (@klaarbenje)

    Ik heb een andere site gebouwd waarbij alles wel werkte (alleen had ik die direct op de juiste plek geïnstalleerd en niet eerst local gemaakt). Zelfde provider en hostingspakket en bij beide staat het in dezelfde map.

    Zoek even op dit forum, het verhuizen van een site is al diverse malen uitgelegd.

    Thread starter Klaarbenje

    (@klaarbenje)

    Dat had ik (uiteraard) gedaan en ondanks dat ik dacht dat ik me goed had ingelezen, is het me toch niet gelukt. Vandaar dat ik ook om hulp vraag…

    Roy

    (@gangleri)

    Vraagje, alle bestanden van je oude site staan nog in de root en de WP bestandjes staan daar tussen? Dan lijkt mij niet zo’n strak plan.

    Thread starter Klaarbenje

    (@klaarbenje)

    Ik heb intussen de bestanden opgeschoond: alles (nou ja, de oude site dan) eraf gegooid, de nieuwe bestanden ook en vervolgens de nieuwe bestanden weer opnieuw geupload. Zelfde resultaat: direct de 500-melding.

    BTW: dit is de url:

    Thread starter Klaarbenje

    (@klaarbenje)

    Dat ging blijkbaar niet goed: http://www.ba-zes.nl

    Roy

    (@gangleri)

    Als alles mislukt, kun je ook nog een nieuwe WP installeren, dat is vijf minuten werk. Vervolgens maak je een export van je lokale versie, die importeer je in de internetversie, kopieer het theme van de lokale naar je server en het resultaat is vrijwel hetzelfde.

    Thread starter Klaarbenje

    (@klaarbenje)

    Staat dat ook nog ergens stap voor stap beschreven? 😉

    Roy

    (@gangleri)

    WP installeren stelt geen klap voor, toch? Haal dat truukje eens uit op je server op het internet en je hebt een prachtige, lege, “Hello world” WP installatie met Twentyten als theme.

    Vervolgs meld je je aan bij je lokaal draaiende WP. Ga naar “tools”->”export” en maak een export.
    Meld je aan bij de frisse, nieuwe WP op het www en ga naar “tools”->”import” en trek de inhoud van je oude installatie naar binnen. Afhankelijk van hoe groot de inhoud is, gaat dit snel of minder snel, maar ik neem aan dat je lokaal geen 15000 berichten en evenzoveel commentaren had.
    Nu moet je nog je theme hebben, maar die heb je ook al: lokaal. Haal de map wp-content/themes/jouwtheme naar een plek waarvan je ‘m via FTP naar je server kunt kopieëren en klaar ben je.

    Thread starter Klaarbenje

    (@klaarbenje)

    De boel leeg gehaald, verse wp geupload (na config veranderd te hebben), naar wp-admin jadajada gegaan en wat denk je: 500…

    Zucht…

    Roy

    (@gangleri)

    Dat kan eigenlijk niet meer aan WP liggen. De oude pagina werkte wel? Vraag eens bij je host of PHP niet perongeluk is gecrasht of zo of dat er andere serverproblemen zijn.

    [edit] wacht ik heb nog een idee. Heb je een htaccess bestand in de root staan? Kieper die eens weg als dat zo is.
    Trouwens, dit is ook wel apart webmaster@localhost als dit inderderdaad een nieuwe installatie op een webserver moet zijn!

    Thread starter Klaarbenje

    (@klaarbenje)

    Nogmaals alles maar eens gedaan, inclusief een hele verse download.
    Nee, ik heb geen htaccess in de root staan.

    @lh is inderdaad apart. Heb het config-bestand goed gecheckt, maar heb alle vier de gegevens vervangen. Dus beats me…

    Ik word er zo langzamerhand een beetje moedeloos van…

15 reacties aan het bekijken - 1 tot 15 (van in totaal 21)
  • Het onderwerp ‘Uploaden site mislukt’ is gesloten voor nieuwe reacties.