Support » Overige » Uploaden media gaat fout

  • Opgelost Pecht

    (@pecht)


    Hallo,

    Ik ben een webwinkel aan het vullen met producten en dus ook een hoop foto’s.
    De eerste 40 gingen prima maar ineens lukt het niet meer om meer afbeeldingen te uploaden.
    Ze uploaden wel tot 100% maar daarna blijft er in het balkje waar je het percentage ziet staan als je aan het uploaden bent de opmerking “een ogenblik geduld…”.

    Na een tijdje wachten nog geen verandering behalve dat nu alle foto’s hetzelfde bericht hebben.

    Als ik daarna naar mijn media ga dan zie ik de foto’s er wel tussen staan. Maar als ik ze vervolgens probeer te bewerken dan krijg ik de volgende melding “Afbeeldinggegevens bestaan niet. Probeer de afbeelding opnieuw te uploaden.”.

    Iemand enig idee waaraan dit kan liggen??.

    Alvast bedankt.

15 reacties aan het bekijken - 1 tot 15 (van in totaal 19)
  • Hoi,

    Hoe groot waren de voorgaande 40 afbeeldingen? En hoeveel is toegestaan op de webserver van je hostingpartner?

    Groet, Bennie

    Thread starter Pecht

    (@pecht)

    Hoi,

    De foto’s die al goed zijn zijn er 45 en de totale groote is 153 MB.
    Per foto zo’n 3 a 4 MB.

    Hoeveel er toegestaan is??.Voor media alleen bedoel je?
    Ehh, geen idee.
    Dit is wat het abonnement heeft:

    Webruimte 4 GB
    E-mailruimte 3 GB
    MySQL-ruimte 2 GB
    Totale schijfruimte 9 GB

    Dataverkeer 15 GB
    E-mailboxen 60
    MySQL-databases 3
    Max. aantal domeinnamen 5000

    Moet toch voldoende zijn.

    Ja, dat is ruim voldoende.. 🙂

    Aan de grootte mag het dus niet liggen van de reeds geüploade bestanden.

    Wat gebeurt er als je een enkel plaatje upload? En wat heb je staan bij de instellingen-media?

    Groet, Bennie

    Thread starter Pecht

    (@pecht)

    Hoi,

    Als ik 1 plaatje upload dan blijft alleen dat plaatje staan op
    “een ogenblik geduld…”.
    Zelfde verhaal dus.

    Welke instellingen bedoel je?. Bij media heb ik geen aparte instellingen. (Althans, zover ik kan vinden).

    Hoi,

    Welke versie van WordPress gebruik je?
    En is er een pad opgegeven bij de media instellingen en staat er een vinkje bij het onderste hokje (uploads bewaren etc)?

    Groet,

    Thread starter Pecht

    (@pecht)

    Hoi,

    Ik gebruik Versie 3.6.1

    Ik kan de media instellingen niet vinden.
    Heb net een foto geprobeerd die ik al had (en met succes) en die doet het nu ook niet.
    Wel raar dit.

    Maar kun je me vertellen waar ik de instellingen kan vinden wat betreft de media?.

    Thread starter Pecht

    (@pecht)

    Heb het nu op een andere Pc geprobeerd en daar werkt het ook niet.
    Ik weet het nu echt niet meer.

    Hoi,

    De instellingen die ik bedoel zie je terug in je wordpress admin omgeving. Instellingen – Media.

    Vervolgens zie je aan de rechterkant bij Media staan;
    Bestanden uploaden
    – Uploads opslaan in map
    – Volledige url pad naar bestanden
    checkbox – Uploads bewaren enz.

    Zie je dit staan?

    Groet,

    Thread starter Pecht

    (@pecht)

    Nee, Bij mij ziet het ver niet zo uit.
    Ik heb wel een checkbox met de vraag of ik uploads wil bewaren in een map met jaar en maand of zoiets.

    Ik heb inmiddels een ondekking gedaan. Helaas nog niks opgelost.
    In de map waar de uploads worden opgeslagen namelijk:
    …../wp-content/uploads/2013/10.

    Het rare is dat alle foto’s die goed gingen het volgende effect hadden tijdens de upload.
    Als ik een foto upload deed van bijv fotonaam-1 dan zie ik in de doelmap dat er 5 nieuwe files werden aangemaakt, namelijk:

    fotonaam-1-150×150.jpg 27kb
    fotonaam-1-200×200.jpg 30kb
    fotonaam-1-200×300.jpg 33kb
    fotonaam-1-682×1024.jpg 106kb
    fotonaam-1.jpg 3746kb

    Sinds het niet meer werkt zie ik na het upoloaden van een nieuwe foto alleen de foto in originele formaat staan.

    Bijv: fotonaam-2.jpg 3746kb

    Het probleem blijkt dus te zijn dat hij niet meer automatisch de 4 files daarboven maakt.
    Vandaar waarschijnlijk dat hij blijft zeggen “een ogenblik aub”.
    Toen het goedging duurde dat 2 seconden nadat hij de 100 % upload had bereikt. Dus de volgende foto was net begonnen met uploaden en klaar was ie. Nu blijven alle foto’s op “een ogenblik”staan en ik denk dat dit dus komt omdat hij de kleinere files dus niet meer maakt.

    De vraag is natuurlijk waarom niet en hoe los ik dit op.

    Enig idee??.

    Hoi,

    Ik zou nog even experimenteren met de “bestandsattributen”.
    Dus de rechten van de map die je aangeeft (/wp-content/uploads/2013/10). Hoewel het vreemd blijft dat het voorheen wel goed ging.

    Hoop dat dit helpt. 🙂

    Succes!

    Groet, Bennie

    Thread starter Pecht

    (@pecht)

    Dit ga je niet geloven.

    Ik heb mijn hele wordpress site volledig verwijderd en van de server afgegooid tot er niks meer van over was en ik helemaal opnieuw moest beginnen.

    Ik dacht, dat is mijn enige mogelijkheid.

    Nu weer geinstalleerd, thema en woocommerce geinstalleerd en dus zal het wel weer werken.

    Maar helaas.

    Wat kan het nu nog zijn dan??.

    Hoi,

    Wat vervelend zeg. En toen je alles opnieuw had geinstalleerd, had je toen hetzelfde weer met de plaatjes dat het eerste gedeelte wel lukte? Of nu helemaal niet meer.

    Heb je nog gekeken naar de rechten/bestandsattributen van je upload map met behulp van FTP? WEet niet of je hiermee bekend bent?

    Groet, Bennie

    Thread starter Pecht

    (@pecht)

    Hoi,

    Ik heb nu helemaal geen succes meer met uploaden.
    Ik kan nu geen enkele afbeelding meer bewerken.

    Ik weet niet wat te doen.

    Ik heb gekeken naar de rechten maar die stonden goed.

    Ik zit echt met mijn handen in mijn haar.

    Thread starter Pecht

    (@pecht)

    De rechten van de map waar de uploads ingaan zijn:

    Groep: lezen schrijven en uitvoeren
    Publiek: Lezen en uitvoeren. Schrijven dus niet
    De lege: Lezen en uitvoeren. Schrijven dus niet

    Hoi,

    Ik kan me voorstellen dat je met je handen in het haar zit. Ik lees overigens net op een forum, dat het nog uit zou kunnen maken dat je het vinkje juist weg haalt bij uploads. Met rechten experimenteren kan natuurlijk gevaarlijk zijn, gezien je hiermee soms ook toegang geeft aan kwaadwillenden.

    Op internet kwam ik dit forum nog tegen, hopelijk heb je daar nog iets aan; http://www.robbertoverwordpress.nl/help-ik-kan-geen-afbeeldingen-toevoegen-aan-wordpress/

    Ik krijg het ook niet opgelost. Sorry. Had je graag geholpen. Misschien is het nog een idee om even te overleggen met je hostingprovider of zij dit vaker zijn tegengekomen.

    Succes!

15 reacties aan het bekijken - 1 tot 15 (van in totaal 19)
  • Het onderwerp ‘Uploaden media gaat fout’ is gesloten voor nieuwe reacties.