Support Volgende » Overige Volgende » siteadres (URL) aanpassen

  • Ik heb een site aan moeten passen. Dit was http://www.vcepsv.nl
    Nu heb ik bij een andere host een pakket genomen om de site te maken.
    Omdat de domeinnaam niet werd gelinkt naar het nieuwe pakket is er een fictieve url aangemaakt, vcepsv.goedgehost.nl

    Nu is de site klaar en willen we de A record en later het DNS adres naar het andere pakket linken. Nu moet ik ook de .goedgehost weghalen.. Moet ik deze alleen bij in de algemene instellingen bij Siteadres(URL) aanpassen, ook de .htaccess en de php myadmin?Ik denk dat ik de vorige keer iets over het hoofd heb gezien want toen werkte er helemaal niets meer. Denk ik zo goed of moet ik nog iets meer doen, de bestanden staan in de rootdirectory.

    Ook de WordPress-adres (URL) is http://www.vcepsv.goedgehost.nl
    Als de .goedgehost weg gaat moet ook die aangepast worden volgens mij want anders kan ik niet meer inloggen?

    Hoe kan ik dit snel en makkelijk oplossen? Wellicht eerst een test naar bv. mark.vcepsv.nl?? Is dat ook mogelijk?

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

13 reacties aan het bekijken - 1 tot 13 (van in totaal 13)
  • Moderator Jeroen Rotty

    (@jeroenrotty)

    Je moet alles in de DB veranderen, je kunt dat m.b.v. een plugin doen zoals Duplicator of All In One Migration. De twee opties in wp_options is niet voldoende om alles te doen werken. Ook je permalinks moet je daarna even opnieuw opslaan.

    Manueel kun je dat ook doen en dan met een zoek/vervang script werken. Ik heb goede ervaringen met het script van Interconnect.

    Jeroen

    De Duplicator of de All in One migration maakt een “backup” van mijn database etc.
    Moet ik daarna zelf alles aanpassen? Ik dacht dat die plugins ook de omzetting deden.

    Er staat wel: Zoek <tekst> Vervang met <andere-tekst> in de database maar als ik daar invul dat de .goedgehost.nl vervangen moet worden door vcepsv.nl dan doet hij dat niet, klopt dit of moet ik daar nog wat anders voor doen.

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Met Duplicator in ieder geval ben je sneller af, omdat die inderdaad ook de omzetting doet bij terugzetten.

    Jeroen

    Hoi Jeroen,

    Ik snap hem nog niet helemaal eigenlijk.
    Ik heb nu met Duplicator een backup gemaakt en de file installer.php gedownload en met html kit bekeken.
    Moet ik daar nu de old en new invullen, ook de ftp en sftp gedeeltes?

    Moet er daarna nog meer gebeuren met de file?
    Dit is de eerste keer dat ik dingen moet overzetten en ik wil eigenlijk dat het goed gaat. ­čÖé

    Wat moet er daarna gebeuren wanneer dit is aangepast?

    Ik wil je in ieder geval nog heel erg bedanken voor je hulp.

    Mark

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Gewoon de installer.php en het zipbestand op de nieuwe host/locatie zetten en daar naar toe surfen en alles invullen en je database gegevens invullen en de WordPress staat dan daar geïnstalleerd.

    Jeroen

    Dat is gelukt en als ik dan alles ga volgen krijg ik bij de laatste scherm niet het inlogscherm te zien. Hij geeft dan de melding dat hij het niet kan vinden, kan zo de permalinks niet updaten dus werkt de site ook niet.

    Ik heb ook geprobeerd hem van de ene host naar de andere te verplaatsen maar dat ging niet. Zie ik iets over het hoofd qua installatie?

    Mark

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Dat zou nochtans het enige moeten zijn die je moet doen, als je bij het terugzetten alles goed doet qua URL en dan naar die URL/wp-admin surft zou je er op moeten kunnen, tenzij je laatste stap niet goed lukt (de URLs omzetten).

    Jeroen

    En als dat niet goed zou gaan wat kun je dan doen?
    Kun je bij het thema in de functions.php dan nog de domeinnaam aanpassen of moet je dan helemaal opnieuw beginnen.

    Mark

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Heb je nog steeds de originele website live staan? Maak ‘m eens opnieuw die zip en installer en probeer nog eens?

    Je kunt enkel in wp-config.php je siteadres en urladres inzetten met deze twee regels

    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    Niet in je functions.php dus, want dat zit zich pas in als je thema wordt geladen … ­čśë

    Jeroen

    Hij geeft wel de volgende melding aan als ik de Duplicator start:
    PHP Open Base Dir: ‘ON’

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Dat zou geen problemen mogen geven, dat is iets waar Duplicator geen gebruik van maakt.

    Als ik bij stap 4 kom krijg ik de volgende “General notice”

    NOTICE: The wp-config.php has the following values set [WP_TEMP_DIR]. Please validate these values are correct in your wp-config.php file. See the codex link for more details: https://codex.wordpress.org/Editing_wp-config.php
    NOTICE: The media settings values in the table ‘ywegd_options’ has at least one the following values [‘upload_url_path’,’upload_path’] set. Please validate these settings by logging into your wp-admin and going to Settings->Media area and validating the ‘Uploading Files’ section

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Die 2 instellingen kan je/moet je misschien nog manueel veranderen inderdaad. Eerste is de tijdelijke map waar downloads/updates worden weggeschreven van WP en de 2de is je media_upload_path – het gemakkelijkste is die gewoon te legen in de options tabel.

    Jeroen

13 reacties aan het bekijken - 1 tot 13 (van in totaal 13)