Support » Thema en CSS/opmaak » Site titel niet responsive

  • Hallo,
    Heb net mijn thema veranderd in Natural Lite.
    Het lukt mij niet om de site titel en kopafbeelding responsive te krijgen, de menu´s, widgets e.d. staan wel goed.
    Iemand een oplossing?

14 reacties aan het bekijken - 1 tot 14 (van in totaal 14)
  • Hi,

    Heb je hier al aan gedacht??

    Veel mensen zijn gewend om lettergrootte in PX op te geven. Dat is een maat die niet responsive is, en dus voor problemen KAN zorgen!

    Vervang lettergrootte in ‘em’ of ‘rem’, beide WEL responsive maten voor lettergrootte en je probleem zou verleden tijd moeten zijn…

    BTW… geheel ten overvloede, deze zaken pas je aan in CSS; te weten ‘style.css’ van je [child-]theme, of de ‘customizer’.

    == == ==
    Heb je vragen, of loop je vast?
    Vraag gerust!

    Thread starter V.Knol

    (@vknol)

    Hallo,
    Dank je wel voor je reactie.Zo te zien is de grootte al ingesteld op em:

    #header .site-title {
    display: block;
    font-family: ‘Montserrat’;
    font-size: 3em;
    font-weight: 600;
    text-transform: uppercase;
    text-shadow: 4px 4px 0px rgba(0, 0, 0, .1);
    letter-spacing: -1px;
    line-height: 1.2;
    padding: 24px 0px;
    margin: 0px;.

    Hi,

    Dank voor de aanvullende info.
    In het onderstaande voorbeeld heb ik de genoemde elementen voorzien van een ‘relatieve waarde’.
    Ik verwacht dat dit beter werkt.

    div#header,
    .header-img,
    .natural-header-active #header .site-title a,
    .natural-header-active #header .site-title a:link,
    .natural-header-active #header .site-title a:visited {
    	max-width:100% !important;
        }

    == == == WAT NU TE DOEN MET DEZE CODE…

    Als je theme een optie heeft om de CSS aan te passen, bijvoorbeeld in een ‘custom css’-veld, plaats dan de aanpassing[en] aan je css hierin.
    Ontbreekt een dergelijke optie in je theme? Volg dan de instructies hieronder.

    Alternatief: Voeg bovenstaande code toe aan style.css van je CHILDtheme.
    Zo voorkom je dat al je aanpassingen worden overschreven als de makers van je theme een update installeren.
    Verder heeft het als voordeel dat alle aanpassingen overzichtelijk bij elkaar staan. Dat is makkelijk, overzichtelijk en eenvoudiger te onderhouden.

    Kies je ooit een ander theme, dan dien je een nieuw childtheme te maken.

    == == == ik wil echt GEEN childtheme [en begrijp het probleem van het aanpassen van het originele theme…]
    Zet de bovenstaande code dan ONDERAAN het bestand ‘style.css’ van je thema. Ververs je browser <CTRL-F5>.
    == == ==

    == == == Heb je nog geen childtheme?

    1. installeer en activeer ‘one click childtheme’-plug-in
    2. activeer de originele theme
    3. Dashboard > weergave > child theme
    4. beantwoordt de vragen op het scherm
      >> er wordt een child theme aangemaakt in een map met bestanden zoals style.css;
    5. Activeer het childtheme.
    6. ==

    7. om je site aan te passen, maak je nu alle wijzigingen in de map en bestanden van je child theme.
      – Maak je aanpassingen in style.css van het childtheme;
    • Gebruik een FTP-programma bijvoorbeeld filezilla om je site te benaderen
    • open de map van je childtheme
    • gebruik een code-editor bijv. ‘NOTEPAD++’ [gratis] om het bestand ‘style.css’ van je childtheme te bewerken
    • voeg bovenstaande code toe aan ‘style.css’ van je childtheme > sla alle wijzigingen op
    • UPload de aangepaste ‘style.css’ naar de map van je childtheme [en overschrijf]
    • browser: druk <CTRL-F5> om je browser te verversen
    • bekijk het resultaat

    – mocht je aanpassingen willen maken in de originele php-bestanden, kopieer de betreffende php-file uit het originele theme naar de map van het childtheme. Maak hierin dan de gewenste aanpassingen.

    Loop je vast? Vraag gerust.

    Thread starter V.Knol

    (@vknol)

    Hallo,
    Ik heb jouw mogelijke oplossing onderaan de style.css gezet maar nog verbetering helaas.
    Daarna in de customer.php gezet maar deze melding verschijnt nu:

    Parse error: syntax error, unexpected ‘,’ in /public/sites/www.eifelpension.com/wp-content/themes/natural-lite/includes/customizer.php on line 271

    Thread starter V.Knol

    (@vknol)

    Ben nu in de phpmyadmin, moet ik evt. mijn thema verwijderen en opnieuw installeren?

    Hi,

    NEE, laat de php-bestanden met rust! Dat kan je site flink verklooien!!

    Plaats het originele php-bestand waarin je dingen hebt gewijzigd, weer terug. Heb je geen back-up gemaakt? Gebruik dan de versie uit het originele thema [alleen het betreffende bestand zou genoeg moeten zijn…]
    — — —
    !!CSS-aanpassingen zoals hierboven pas je aan in ‘styles.css’, zoals hierboven beschreven!!

    == == ==
    Geef even de url van je site bijv. http://www.mijndomenin.nl; Zo kunnen we zien waar ’t probleem zit….

    Thread starter V.Knol

    (@vknol)

    http://www.eifelpension.com is mijn site.
    Ik heb per ongeluk mijn (huidige) thema gewist in phpmyadmin………..
    De foutmelding blijft helaas nog wel staan.

    Thread starter V.Knol

    (@vknol)

    Ik heb via mijndomein zojust een backup teruggezet echter ook weer zonder resultaat….

    OK, da’s onhandig, maar geen ramp…

    — — — herstellen controle over je site

    Eerst maar eens kijken of we de boel weer aan de praat krijgen;

    == == == optie 1
    Mocht je jouw site nog wel via het dashboard kunnen benaderen, doe dan het volgende:

    1. log in > dashboard > weergave > thema’s
    2. zoek en activeer een van de standaardthema’s van WP, bijvoorbeeld ‘Twenty Sixteen’
    3. sla alle wijzigingen op
    4. <CTRL-F5> en bekijk het resultaat
    5. Als je nu weer een werkende website ziet, heb je de controle over je site terug en kan je je oude thema opnieuw downloaden en installeren.

    == == == Optie 2
    Je hebt GEEN mogelijkheid om in het dashboard in te loggen.

    — — — voorbereiding

    1. download een schone set van wp-bestanden
    2. unzip de wp-bestanden
    3. — — — herstel
      TIPS:

    • werk langzaam en nauwkeurig.
    • Ga pas verder met een volgende stap, als de vorige stap succesvol is verlopen.
    • loop je vast? Vraag gerust!!
    • gebruik een FTP-programma om je site te benaderen
    • UPload de set van schone WP-bestanden en OVERSCHRIJF.
    • je site, inhoud etc. blijft bewaard, no worries…
      — — —

    • Log in en controleer of de boel weer toegankelijk is.
    • NEE?? Beschrijf je acties en waar je vastloopt
    • Ja >> download een schone versie van je THEMA
    • FTP: upload en OVERSCHRIJF
    • Dashboard > weergave > thema’s
    • her-activeer je thema
    • <CTRL-F5> ververs je browser
    • Je site is nu weer op orde.

      Loop je vast? Niet ‘klooien’, maar vraag gerust!

    … oh ja…

    Je hebt het vast ook al gemerkt, het bewerken van / werken aan php-bestanden, is een klusje voor gevorderden en experts.

    PHP-bestanden zijn kritisch voor je site. een fout kan de boel flink verstieren… ;-(

    Alle door jou gewenste aanpassingen kunnen mbv CSS worden gedaan.
    Da’s een stuk minder ‘gevaarlijk’.

    Thread starter V.Knol

    (@vknol)

    Optie 1 is geen optie, dashboard kom ik niet in.
    Zie net dat mijn thema wel weer zichtbaar is bij phpmyadmin.
    Mijndomein.nl heeft het thema vandaag herbenoemd,toen kwam ik weer in het dashboard. Maar toen ik het thema wilde verwijderen/aanpassen verscheen dezelfde foutmelding weer.
    Is er in de phpmyadmin niet iets mogelijk om het thema weer werkend te krijgen?

    Thread starter V.Knol

    (@vknol)

    Krijg deze melding bij filezilla.

    You appear to be behind a NAT router. Please configure the passive mode settings and forward a range of ports in your router.
    Warning: FTP over TLS is not enabled, users cannot securely log in.

    Daar ben ik waarschijnlijk wel weer even druk mee….(duitse router)

    Thread starter V.Knol

    (@vknol)

    Ben iets verder gekomen:
    In de phpmyadmin heb ik de template en stylesheet herbenoemd:naturel-lite heb ik veranderd in twentyfifteen.Vervolgens kwam ik weer in mijn dashboard.
    Na veel moeite heb ik naturel lite verwijderd en opnieuw geinstalleerd en jawel, godzijdank, de website is weer zichtbaar en het thema lijkt te functioneren.
    Ben wel de aanpassingen van de afgelopen 1/2 dag kwijt.
    Blijft natuurlijk nog de vraag hoe de site titel responsive te maken……..

    Fijn dat je weer verder kunt.
    Zoals gezegd, phpmyadmin en dergelijke instrumenten zijn NIET geschikt voor wat je wilt bereiken, en risicovol bij ondeskundig gebruik.
    Herstel de boel eerst zo veel mogelijk, dan kijken we verder…

14 reacties aan het bekijken - 1 tot 14 (van in totaal 14)
  • Het onderwerp ‘Site titel niet responsive’ is gesloten voor nieuwe reacties.