Support » Code oplossingen gezocht » Site gehacked en nu werkt gekocht thema niet goed meer

  • Beste mensen,

    Na gehackt te zijn, werkte het thema nog niet. Het gekochte thema (rttheme15) verwijderd en vanuit een backup geupload via ftp.
    Inmiddels is de site weer zichtbaar zoals vroeger: http://www.creative-incense.nl . Het enige probleem: verschillende foutmeldingen omdat het theme nu verouderd is vergeleken met de wordpressinstallatie. Zoveel dat ik ook niet meer in kan loggen op wp-admin. Foutmeldingen zal ik onderaan dit bericht vermelden.

    Ik denk dat het wel mogelijk is om via php het thema tijdelijk te de-activeren zodat ik weer in mijn wordpress-admin kan, maar wil dat pas doen als ik een oplossing weet voor het probleem, zodat de site goed zichtbaar blijft tot die tijd.

    Alvast bedankt voor jullie reacties!


    Notice: add_custom_background is niet meer in gebruik sinds versie3.4! Gebruik in plaats daarvan add_theme_support( ‘custom-background’, $args ). in /customers/5/1/f/creative-incense.nl/httpd.www/wp-includes/functions.php on line 2841 Warning: Cannot modify header information – headers already sent by (output started at /customers/5/1/f/creative-incense.nl/httpd.www/wp-includes/functions.php:2841) in /customers/5/1/f/creative-incense.nl/httpd.www/wp-includes/pluggable.php on line 876

7 reacties aan het bekijken - 1 tot 7 (van in totaal 7)
  • Hallo Carry,

    Ziet er naar uit dat je website gemaakt is door ene ‘martijnroskam’. Heb je hem al eens om hulp gevraagd?

    Uit je vraagstelling kan ik weinig opmaken behalve dat je een behoorlijke oude versie gebruikt van WordPress. Over het algemeen neemt risico op hacks aanzienlijk toe wanneer de website in de loop der tijd verouderd en er geen updates worden geïnstalleerd. Een nadeel van Open Source. Iedereen kan in de broncode kijken.

    Ik zou je aanraden om de voormalige webbouwer hierover te benaderen. Dit is namelijk iets wat wel wat uitgebreider bekeken moet worden daar gezien WP ge-update moet worden en de plugins worden herzien. Sommige plugins worden na een tijd niet meer doorontwikkeld waardoor ze op een later moment niet meer compatible zijn met een nieuwere versie van WP.

    Mocht de voormalige webbouwer niet bereid zijn je te helpen dan kan ik dat wel. Echter wel tegen een kleine vergoeding daar gezien dit niet zo op te lossen is.

    Je kunt me eventueel mailen op geoclaps [@] hotmail.com

    Vriendelijke groet, Ruurd

    Hallo,

    Ik zie dat je dit thema gebruikt en het lijkt erop dat de bouwer em niet echt heeft aangepast:
    http://themeforest.net/item/rttheme-15-premium-wordpress-theme/781397

    Als je daarvoor betaald hebt heb je recht om de meest recente versie te downloaden en te installeren. Ga ervan uit dat je foutmeldingen dan verleden tijd zijn.

    Guido

    Thread starter CarryMaria

    (@carrymaria)

    Hallo Guido,

    Dank voor je reactie. Het probleem is dat we de site hebben gekocht samen met het bedrijf twee jaar geleden. De bouwer heeft me wel geholpen om het over te zetten op het domein dat we wilden, maar ik krijg nu geen contact met hem. Hij is degene die het thema indertijd gekocht heeft.

    Ik heb jou, Ruurd gemaild, voor eventuele bijstand om het in orde te krijgen. Ik ga eens kijken: ik kan namelijk wordpress wel updaten, want ik heb verder geen plugins geinstalleerd. Alleen dus het thema.
    Dus wellicht is updaten van de site genoeg? (mits ik natuurlijk toegang krijg tot de meest recente versie van het thema).

    Hartelijke dank voor jullie meedenken. Ik ga het een en ander proberen en kom erop terug als er iets niet lukt. Ik hoor het graag als jullie nog iets weten waar ik zelf nu even niet aan denk.

    Carry

    Op zich is dit wel zo op te lossen door het thema alsnog te kopen via themeforest (ik heb een account) en het te herinstalleren.
    Of door iemand je huidige versie door te laten lopen op verouderde functies zoals add_custom_background en die te vervangen. Kan zo klaar zijn of even duren, afhankelijk van hoe uitgebreid je thema qua aantal bestanden is.

    Guido

    Thread starter CarryMaria

    (@carrymaria)

    Hallo Guido,

    Ik heb ineens tóch een mailtje gekregen van de bouwer. Hij gaat kijken of hij de nieuwe versie van het thema voor me kan downloaden. Echt super.

    Ik wil jou en Ruurd erg bedanken. Door jullie weet ik dat het inderdaad vooral het thema is dat verouderd is (en niet iets anders) en dat ik moet zorgen dat ik zo snel mogelijk de nieuwste versie van WordPress installeer, omdat ik anders weer gemakkelijk gehackt kan worden.

    Dank jullie wel!

    Geen dank. Veel succes!

    Wellicht ook handig om te weten:

    Als je debug mode aanstaat in WordPress krijg je errors zoals add_custom_background is niet meer in gebruik sinds versie3.4! te zien. Het is natuurlijk het beste om deze te verhelpen, maar mocht het lang duren voordat de programmeur reageerd kun je ook kiezen om de debug modus uit te zetten.

    Dit doe je in je wp-config, debug mode op false te zetten.

7 reacties aan het bekijken - 1 tot 7 (van in totaal 7)
  • Het onderwerp ‘Site gehacked en nu werkt gekocht thema niet goed meer’ is gesloten voor nieuwe reacties.