Support » Plugin vragen » Samsite attribute

  • Beste,
    Bij toeval kwam ik er achter, na uitzoeken waarom site zo traag was via F12 in Google, dat er nogal wat “Samsite coockie problemen zijn.
    Ik maak niet gebruik van een of andere “coockie plugin” .
    Wat kan / moet ik doen om deze warnings op te heffen?
    Het speelt bij al mijn pagina’s
    Voorbeeld van de melding:

    Indicate whether to send a cookie in a cross-site request by specifying its SameSite attribute

    Ron

    Windows 10
    Wordpress 5.7
    “Probleem” wordt zowel getoond in Firefox en Chrome

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

12 reacties aan het bekijken - 1 tot 12 (van in totaal 12)
  • Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Waar zie je specifiek die ‘fout’ of waarschuwing? Ik heb je site geopend en de browser-console bekeken, maar zie die melding nergens in Firefox of Chrome. Misschien bedoel je iets specifieks?

    Thread starter ronhe

    (@ronhe)

    Hi Jeroen,
    Dank voor je reactie.
    Ik zie momenteel via browser-console bij mijn Homepage 49 issues.
    Als ik aan vink:

    Include third-party issues

    En als ik vervolgens klick op:

    Indicate whether to send a cookie in a cross-site request by specifying its SameSite attribute

    Dan krijg ik het volgende te zien

    Because a cookie’s SameSite attribute was not set or is invalid, it defaults to SameSite=Lax, which prevents the cookie from being sent in a cross-site request. This behavior protects user data from accidentally leaking to third parties and cross-site request forgery.
    Resolve this issue by updating the attributes of the cookie:
    Specify SameSite=None and Secure if the cookie should be sent in cross-site requests. This enables third-party use.
    Specify SameSite=Strict or SameSite=Lax if the cookie should not be sent in cross-site requests.
    7 cookies
    7 requests

    Ron

    Thread starter ronhe

    (@ronhe)

    Kan iemand nog wat bedenken om van de “Issues” af te komen?
    Ron

    Guido

    (@guido07111975)

    Hallo Ron,

    Ook ik vind geen fouten in de console van mijn browser. Ook is je site vrij snel. En een test via Pingdom levert ook geen afwijkende zaken op.

    Heb je misschien cookies geblokkeerd in je browsers?

    Guido

    Guido

    (@guido07111975)

    Nogmaals hallo,

    Ik zie nu wat je bedoelt. Nog nooit naar gekeken omdat die optie nogal verborgen zit. Ik kijk nooit verder dan het hoofdscherm van de console tab 😉 Heb ook de kennis niet om een goed oordeel te geven over de waarde hiervan. Wel zie ik dat een OGPC cookie van Google genoemd wordt, en ik zie dat je reCaptcha gebruikt (is van Google). Ik lees overigens dat die cookie met Google Maps te maken heeft.

    Guido

    Thread starter ronhe

    (@ronhe)

    Hoi Guido,
    Dank dat je wat dieper bent ingedoken, jammer dat ik het niet duidelijk genoeg onder woorden kon brengen (Screenshot zou geholpen kunnen hebben, maar dat kun dus niet in dit forum).
    Dus eigenlijk moet ik er een Cookie plug-in bij plaatsen. Ik neem aan dat deze warnings geen kwalijke gevolgen heeft voor de werking van mijn site.
    Ron

    Guido

    (@guido07111975)

    Dus eigenlijk moet ik er een Cookie plug-in bij plaatsen

    Sowieso een Cookie/AVG banner want je hebt ook een contactformulier, dus je ontvangt/verwerkt gegevens van bezoekers van je site.

    Ik gebruik deze, maar ik zie dat de beoordelingen tegenwoordig minder zijn (na een update).

    Guido

    Thread starter ronhe

    (@ronhe)

    Guido,
    Ja, ik ben me al aan het oriënteren, dank voor je hulp.
    Ik zal je “verwijzing oppakken.
    Groet,
    Ron

    Thread starter ronhe

    (@ronhe)

    Guido,
    Ik kom even bij je terug als je niet erg vindt.
    Ik heb je “Cookie plug-in” geïnstalleerd maar krijg NA acceptatie van de de instellingen toch nog, via F12, te zien dat nog steeds 12 issues zijn n.a.v.:

    Indicate whether to send a cookie in a cross-site request by specifying its SameSite attribute

    Ik kom er niet uit waar ik dan de “vermeende “code:
    Set-Cookie: SameSite=None; Secure
    Zou moeten plaatsen en hoe.
    Heb jij nog suggesties?

    Een andere vraag: Nadat ik de instellingen van de plug-in heb opgeslagen word ik bij de “admin” uitgelogd, het ziet er naar uit dat de “time instelling” gerest wordt.
    Heb jij daar ook “last” van?
    Ik heb e.e.a. nu op mijn “test omgeving” geïnstalleerd
    https://www.sunpage.nl/he
    Bij voorbaat dank,
    Ron

    • Deze reactie is gewijzigd 1 maand geleden door ronhe.
    • Deze reactie is gewijzigd 1 maand geleden door ronhe.
    Thread starter ronhe

    (@ronhe)

    De link naar mijn testsite kwam in vorige post niet door.
    Hierbij alsnog:

    https://www.sunpage.nl/he/

    Guido

    (@guido07111975)

    Hoi,

    Ik heb zelf weinig ervaring met die extra schermen van Console, wat je zou kunnen doen is je Google gerelateerde plugins de-activeren om te bepalen of een plugin dit veroorzaakt, en zo ja welke. En dan op het forum van die plugin deze vraag stellen.

    Over het ineens uitloggen.. Ik weet niet of dat bij mij ook gebeurt is, maar ik heb er geen duidelijke verklaring voor. Want plugin is immers werkzaam aan de voorkant van je site, niet aan de achterkant. Misschien dat een cookie overschreven is. Maar als het eenmalig is zou ik me er niet druk over maken. Zo wel, dan een andere plugin kiezen, temeer omdat support en beoordelingen momenteel niet goed zijn.

    Guido

    Thread starter ronhe

    (@ronhe)

    Hoi Guido,
    Dank voor het meedenken.
    Ik zoek nog even verder.
    Ron

12 reacties aan het bekijken - 1 tot 12 (van in totaal 12)