Ondersteuning » Algemeen WordPress » Pulldown menu direct zichtbaar op Homepage

  • Opgelost vrachelen

    (@vrachelen)


    Bij het oproepen van mijn site op een smartphone en vervolgens het opvragen van het menu, worden de menu-items prima zichtbaar. Echter, de lezer ziet niet dat er nog sub-items onder dat menu hangen. Dat ziet hij/zij pas als er een menukeuze is gemaakt, dan pas zie je de pulldowns-tekens in het menu. Dit speelt dus alleen op een klein beeldscherm. Hoe kan ik het pulldown-teken direct zichtbaar maken, tijdens het tonen van de homepage?

    • Dit onderwerp is gewijzigd 1 maand, 4 weken geleden door vrachelen.

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

15 reacties aan het bekijken - 1 tot 15 (van in totaal 26)
  • Guido

    (@guido07111975)

    Hoi,

    De zogenaamde “toggle” ontbreekt om submenu te openen. Deze is echter wel zichtbaar op andere pagina’s dan de homepage. Gebruik je misschien een ander menu op de homepage? Of heb je voor de homepage iets anders ingesteld qua menu-instellingen?

    Guido

    Thread starter vrachelen

    (@vrachelen)

    Dag Guido,

    Bedankt voor je reactie. Nee ik gebruik voor de homepage geen ander menu, gewoon alle pagina’s toegevoegd aan het (standaard)menu, inclusief de homepage. En, voor zover ik kan beoordelen, zijn alle instellingen hetzelfde. Het enige dat afwijkt is dat ik van mijn homepage een statische pagina heb gemaakt, zodat bezoekers direct op de homepage komen. Maar als ik een andere pagina statisch maak, zien bezoekers die pagina als eerste, maar de zogeheten toggle komt niet tevoorschijn.

    Paul

    Guido

    (@guido07111975)

    Hoi Paul,

    Erg vreemd dit. Kun je ook even een vervangend menu maken (met paar submenu items) en dan kijken of dat menu wel naar behoren werkt in mobiel? Dit keer niet submenu item aan homepage koppelen.

    Guido

    Thread starter vrachelen

    (@vrachelen)

    Dag Guido,

    Heb een vervangend menu gemaakt en alle mogelijkheden uitgeprobeerd, telkens zonder het gewenste resultaat. Ga nu maar eens kijken of een extra plugin gaat werken. Bedankt tot zover.

    Groet van Paul

    Guido

    (@guido07111975)

    Hoi Paul,

    Je gebruikt een zeer populair thema, ik kan me niet voorstellen dat er een fout in het menu van dit thema zit. Dus je kunt beter nóg iets verder doorzoeken in plaats van een extra menu-plugin installeren. Probeer anders eens je plugins 1 voor 1 te deactiveren, misschien is er een conflict met een plugin. En het betreft dus alleen de homepage.

    Ik zal later vandaag of morgen Astra even installeren op mijn test domein en kijken of ik tegen hetzelfde aanloop.

    Guido

    Guido

    (@guido07111975)

    Hoi,

    Heb net de gratis versie van het Astra thema geïnstalleerd en submenu werkt overal.

    Guido

    Thread starter vrachelen

    (@vrachelen)

    Dat is fantastisch, ik ga eerst de plugins deactiveren en stuk voor stuk weer activeren. Ik laat het resultaat weten…

    Thread starter vrachelen

    (@vrachelen)

    Stuk voor stuk de 7 gebruikte plugins gedeactiveerd en telkens gekeken of het pulldown menu zichtbaar werd op m’n homepage. Helaas, dat was niet het geval. Alle plugins dus maar weer geactiveerd. Mijn vraag is nu: kan ik het Astrathema straffeloos verwijderen en weer her-installeren?

    Ik draai de site op mijn eigen (Asustor) server en heb daartoe de WordPress app geïnstalleerd. Er wordt elke dag een back-up gemaakt via de UpdraftPlus plugin. Kan ik nu ook die WordPress app verwijderen, opnieuw installeren en een restore terugplaatsen, zodat mijn pagina’s weer netjes zichtbaar worden?

    Fijn dat je me wilt helpen Guido, ik word er heel veel wijzer van!

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Als je back-up goed werkt, dan moet je niets vrezen want je kan altijd een dagje terug van voor je aanpassingen.

    Astra draai ik ook op veel sites van klanten, en daar heb ik dit probleem niet. Heb je iets specifiek gekopieerd en geplakt van CSS code bij Weergave > Customizer > Extra CSS in het verleden?

    Thema deïnstalleren en terug installeren mag je proberen, benieuwd of dat het oplost.

    Guido

    (@guido07111975)

    Hoi,

    Ik zie dat op de homepage andere inline CSS door Astra wordt geladen dan op de overige pagina’s. Op de homepage ontbreekt sowieso de CSS die nodig is voor de submenu “toggle”. Behalve op mobiel is deze toggle overigens ook niet zichtbaar in groter scherm. Ontbreekt dus in ieder scherm, op de homepage.

    Guido

    Thread starter vrachelen

    (@vrachelen)

    Nooit bewust de ‘inline CSS’ aangepast, geen idee trouwens hoe dat moet en welk doel dat dient. Ik ga dus eerst maar eens studeren hoe en wat. Thanks voor het advies.

    Guido

    (@guido07111975)

    Ik zie nu ook dat je een oude versie van Astra hebt (2.5.4), dus update sowieso tot meest recent versie (3.9.1).

    Guido

    Thread starter vrachelen

    (@vrachelen)

    Nee dat klopt niet, alle gebruikte onderdelen zijn up-to-date, inclusief het Astra thema 3.9.1.
    Ik ga nog wel zoeken naar die CSS code op de homepage. Ik laat het weten (weekje vakantie, dus plannen is lastig).
    Groet van Paul.

    Guido

    (@guido07111975)

    Hoi Paul,

    Nee dat klopt niet, alle gebruikte onderdelen zijn up-to-date, inclusief het Astra thema 3.9.1.

    Misschien zit daar het probleem..

    In je eerste bericht heb je een link vermeld die eindigt op /ploco/. Als ik daarachter “wp-content/themes/astra/style.css” zet, wordt het stylesheet van Astra geladen. Met daarin versie 2.5.4!

    Als ik je site verder inspecteer zie ik dat er vanuit 2 locaties bestanden geladen worden: jouw-domein/wordpress/ en jouw-domein/ploco/.

    Dus ik zou daar nog eens goed naar kijken.

    Guido

    Thread starter vrachelen

    (@vrachelen)

    Als ik je site verder inspecteer zie ik dat er vanuit 2 locaties bestanden geladen worden: jouw-domein/wordpress/ en jouw-domein/ploco/.

    Dat klopt helemaal Guido, bij Algemene instellingen biedt WordPress de mogelijkheid om het WordPress-adres aan te passen in een Site-adres en daar heb ik gebruik van gemaakt door daar <ploco> in te vullen.

    Het klopt ook dat er (als gevolg daarvan?) een map ploco is aangemaakt naast die wordpress map op mijn server. Ben weer heel veel verder geholpen, ga hiermee kijken of het probleem daar zit (vermoedelijk wel, want in die plocomap staat een oude versie van het Astrathema). Bedankt tot zover. Groet van Paul

15 reacties aan het bekijken - 1 tot 15 (van in totaal 26)