• Sim

    (@theurbanista072)


    Sinds kort kan ik dus niet makkelijk een product foto toevoegen uit mijn Mediabibliotheek. Het kost mij veel meer stappen en onnodig veel tijd om een foto te selecteren.

    Als ik een foto wil uitkiezen voor mijn Productgallerij, dan lukt dit wel op de oude manier?!

    Kan iemand mij adviseren hierover!

6 reacties aan het bekijken - 1 tot 6 (van in totaal 6)
  • Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Heb je dit sinds WordPress 5.5 toevallig? Het zou zo maar eens een incompatibiliteit met je thema of een plugin op je site zijn die voor problemen zorgt. 5.5 bracht veel Javascript vernieuwingen. Je zou eens kunnen onderzoeken of het probleem zich ook stelt met een standaard thema of met minder plugins actief.

    Je kunt dit makkelijk doen met de Health Check plugin troubleshooting modus.

    Thread starter Sim

    (@theurbanista072)

    Hi @jeroenrotty

    Dank voor je bericht.
    Het klopt idd dat dit sinds de nieuwe WordPress 5.5 update is veroorzaakt, ik ga ermee aan de slag.

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Is goed. Het eerste dat ik denk is dat een plugin of thema op je site problemen heeft met de laten vallen van het jQuery Migrate script in WP 5.5. Je zou het snel kunnen testen door deze plugin te installeren en activeren: https://wordpress.org/plugins/enable-jquery-migrate-helper/.

    Als dat alles oplost, dan weet je dat dat het probleem is en onderzoek je best welke plugin of thema dat is om te kijken of 1) het nog onderhouden wordt door de ontwikkelaars en 2) of het al 5.5 compatibel is. Eens je de oorzaak kent kan je de juiste ontwikkelaars vragen of ze al aan het werk zijn aan een update die wel compatibel is.

    Thread starter Sim

    (@theurbanista072)

    Hi @jeroenrotty

    Ik heb het probleem gevonden!

    Deze pagina heeft de volgende waarschuwingen gegenereerd:

    1. wp-content/plugins/unlimited-addons-for-wpbakery-page-builder/js/admin.js: jQuery.fn.load() is deprecated

    2. wp-content/plugins/essential-grid/admin/assets/js/admin.js: jQuery.parseJSON requires a valid JSON string

    Weet jij het verschil tussen deprecated en JSON string?

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Deprecated is dat de plugin (unlimited addons for wpbakery) een oude functie gebruikt die niet meer aanbevolen is, dat zou een waarschuwing moeten zijn.

    De andere fout van Essential Grid (ook een plugin) kan mogelijks een oorzaak zijn ja. Je kijkt best of je in beide gevallen de laatste versie draait. Essential Grid is een premium plugin dus als je de nieuwste versie hebt en problemen houden aan, neem dan contact op met de makers daarvan.

    De eerste plugin is wel een plugin die op WordPress.org te vinden is, maar erg professioneel ziet die er niet uit. In de Changelog staat enkel iets te vinden van versie 1.0 … kijk eens of je echt gebruik maakt van die plugin.

    Thread starter Sim

    (@theurbanista072)

    Hi @jeroenrotty

    Ik heb dus de twee plugins, Essential Grid & Wpbakery, gedeactiveerd. Dit heeft het probleem met de product foto’s opgelost, maar heb nu een volgende foutmelding op mijn dashboard van WordPress:

    Deze pagina heeft de volgende waarschuwingen gegenereerd:
    jQuery.parseJSON requires a valid JSON string

    Wat nu??

    • Deze reactie is gewijzigd 3 jaren, 7 maanden geleden door Sim.
6 reacties aan het bekijken - 1 tot 6 (van in totaal 6)
  • Het onderwerp ‘Product foto’ is gesloten voor nieuwe reacties.