Ondersteuning » Code oplossingen gezocht » Problemen met Gutenberg en widgets

7 reacties aan het bekijken - 1 tot 7 (van in totaal 7)
  • Guido

    (@guido07111975)

    Hoi Thessa,

    Uit je eerste link maak ik op dat je iThemes Security gebruikt. Ik denk dat het door die plugin veroorzaakt wordt. Dus kun je die eens de-activeren?

    Aanvulling: als je de plugin Gutenberg gebruikt, die plugin is voor gebruikers die de nieuwe functies van de editor willen testen. Niet stabiel. Dus misschien ligt het ook wel daar aan.

    Guido

    Thread starter Thessa Verbruggen

    (@thessav)

    Hoi Guido,

    Ik heb al geprobeerd alle plugins uit te schakelen en te wisselen naar een standaard-thema, maar dan krijg ik het probleem nog steeds. Ik heb de Gutenberg-plugin eens kort getest, maar snel weer verwijderd omdat het niet deed wat ik zocht. Zou het kunnen dat er hierdoor een fout in de site of database geraakt is?

    Guido

    (@guido07111975)

    Hoi,

    Lijkt me niet.
    Als je dezelfde problemen krijg zonder actieve plugins, dan is er iets anders aan de hand. Ik zie dat het allemaal “500” errors zijn, te maken met de server. Heb je toegang tot de bestanden die op de server staan (via FTP of bestandsmanager van je hosting account)? Zo ja, open dan eens het htaccess bestand (staat in de hoofdmap van je site) en plaats de inhoud eens hier. Svp vóór en ná je code op de “code” knop drukken.

    Guido

    Thread starter Thessa Verbruggen

    (@thessav)

    Hoi Guido,

    Dit staat in de htaccess:

    # BEGIN iThemes Security - Deze regel niet wijzigen of verwijderen
    # iThemes Security Config Details: 2
    	# Systeembestanden beschermen - Beveiliging > Instellingen > Systeem tweaks > Systeembestanden
    	<files .htaccess>
    		<IfModule mod_authz_core.c>
    			Require all denied
    		</IfModule>
    		<IfModule !mod_authz_core.c>
    			Order allow,deny
    			Deny from all
    		</IfModule>
    	</files>
    	<files readme.html>
    		<IfModule mod_authz_core.c>
    			Require all denied
    		</IfModule>
    		<IfModule !mod_authz_core.c>
    			Order allow,deny
    			Deny from all
    		</IfModule>
    	</files>
    	<files readme.txt>
    		<IfModule mod_authz_core.c>
    			Require all denied
    		</IfModule>
    		<IfModule !mod_authz_core.c>
    			Order allow,deny
    			Deny from all
    		</IfModule>
    	</files>
    	<files wp-config.php>
    		<IfModule mod_authz_core.c>
    			Require all denied
    		</IfModule>
    		<IfModule !mod_authz_core.c>
    			Order allow,deny
    			Deny from all
    		</IfModule>
    	</files>
    
    	# Bladeren in mappen uitschakelen - Beveiliging > Instellingen > Systeem tweaks > Bladeren in mappen
    	Options -Indexes
    
    	<IfModule mod_rewrite.c>
    		RewriteEngine On
    
    		# Systeembestanden beschermen - Beveiliging > Instellingen > Systeem tweaks > Systeembestanden
    		RewriteRule ^wp-admin/install\.php$ - [F]
    		RewriteRule ^wp-admin/includes/ - [F]
    		RewriteRule !^wp-includes/ - [S=3]
    		RewriteRule ^wp-includes/[^/]+\.php$ - [F]
    		RewriteRule ^wp-includes/js/tinymce/langs/.+\.php - [F]
    		RewriteRule ^wp-includes/theme-compat/ - [F]
    		RewriteCond %{REQUEST_FILENAME} -f
    		RewriteRule (^|.*/)\.(git|svn)/.* - [F]
    
    		# PHP in uploads uitschakelen - Beveiliging > Instellingen > Systeem tweaks > PHP in uploads
    		RewriteRule ^wp\-content/uploads/.*\.(?:php[1-7]?|pht|phtml?|phps)\.?$ - [NC,F]
    
    		# PHP in plugins uitschakelen - Beveiliging > Instellingen > Systeem tweaks > PHP in plugins
    		RewriteRule ^wp\-content/plugins/.*\.(?:php[1-7]?|pht|phtml?|phps)\.?$ - [NC,F]
    
    		# PHP in themes uitschakelen - Beveiliging > Instellingen > Systeem tweaks > PHP in themes
    		RewriteRule ^wp\-content/themes/.*\.(?:php[1-7]?|pht|phtml?|phps)\.?$ - [NC,F]
    	</IfModule>
    # END iThemes Security - Deze regel niet wijzigen of verwijderen
    
    # BEGIN WordPress
    # De richtlijnen (regels) tussen "BEGIN WordPress" en "END WordPress" worden
    # dynamisch gegenereerd en zouden alleen aangepast mogen worden via WordPress filters.
    # Alle wijzigingen aan de richtlijnen tussen deze markeringen worden overschreven.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    Guido

    (@guido07111975)

    Dit is standaard van WordPress:

    
    # BEGIN WordPress
    # De richtlijnen (regels) tussen "BEGIN WordPress" en "END WordPress" worden
    # dynamisch gegenereerd en zouden alleen aangepast mogen worden via WordPress filters.
    # Alle wijzigingen aan de richtlijnen tussen deze markeringen worden overschreven.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    

    Alles daarboven even verwijderen, hoort bij de iThemes Security plugin.

    Guido

    Thread starter Thessa Verbruggen

    (@thessav)

    Ik heb de plugin uitgeschakeld en de permalinks gereset zodat de htaccess er goed uitziet, maar het probleem blijft nog steeds.

    Ik kan dus nog steeds geen posts/pagina’s bewerken met Gutenberg, widgets bewerken of widgets bekijken op de website. De rest van de website lijkt wel nog perfect te werken, ook pagina’s die met Beaver Builder opgebouwd werden.

    Guido

    (@guido07111975)

    Hoi,

    Gutenberg = een plugin. Je bedoelt waarschijnlijk de standaard blok editor?

    Heb je na het wijzigen vh htaccess bestand opnieuw alle plugins 1 voor 1 gedeactiveerd? Als dan nog steeds dezelfde foutmeldingen blijft krijgen, wordt het tijd je hosting provider eens te benaderen. Misschien kunnen zij achterhalen waarom deze “500” fouten er zijn.

    Guido

7 reacties aan het bekijken - 1 tot 7 (van in totaal 7)