Support Volgende » Code oplossingen gezocht Volgende » php 7.2

  • Op dit moment gebruik ik het thema sparkling en php 5.6

    Ik wil echter upgraden naar php 7.2 maar dan moet ik een en ander aanpassen om gebruik te maken van mysqli.

    Op veel plaatsen vind ik informatie wat ik moet aanpassen maar nergens staat waar de informatie staat die aangepast moet worden. Kunnen jullie mij een hint geven? Is dit opgenomen bij het gebruikte thema? Zit het in wordpress zelf maar waar dan?

6 reacties aan het bekijken - 1 tot 6 (van in totaal 6)
  • De laatste versies van WordPress werken prima met PHP 7.2. In het thema worden normaliter geen nieuwe verbindingen met de database opgestart (dat gebeurt al in WordPress zelf) en je zou daar in principe dus niks voor hoeven te wijzigen.

    Als het thema resulteert in foutmeldingen, dan kun je de ontwikkelaars van het thema het beste vragen om dat op te lossen. Andere gebruikers van dat thema hebben er op die manier ook baat bij.

    Zodra ik de php versie wijzig naar 7.2 (via cpanel) krijg ik de foutboodschap in mijn website “Het lijkt erop dat je PHP-installatie geen MySQL-extensie heeft en die is vereist om WordPress te kunnen gebruiken.”

    Blijkbaar moet ik ergens myqsl calls omzetten naar mysqli maar waar ik dit zou moeten aanpassen kan ik nergens vinden. Enig idee wat ik waar zou moeten aanpassen?

    Aha, dat klinkt meer alsof je juist in cPanel moet zijn en daar de mysqli extensie voor PHP dient in te schakelen. Indien je dat niet zelf kunt doen, kun je de hostingprovider om dat voor je te doen.

    Ik krijg de foutmelding (na via cpanel de php versie gewijzigd te hebben naar 7.2): Het lijkt erop dat je PHP-installatie geen MySQL-extensie heeft en die is vereist om WordPress te kunnen gebruiken.

    Ik probeer al dagen om erachter te komen hoe en waar dit op te lossen. Ik ben weliswaar geen PHP expert maar enige basisikennis heb ik wel.

    Ik kom veel opmerkingen tegen dat je de mysql calls moet wijzigen naar mysqli calls maar waarin dan, waar en hoe?

    Is er iemand die mij verder kan helpen?

    Zie laatste reactie vóór je bericht voor het antwoord.

    Sorry for these questions. I forgot to put my reader glasses on! I was thinking that it could not find the mysqli extension but it was the mysql extension. And of course in php 7.2 this extension had been removed.

6 reacties aan het bekijken - 1 tot 6 (van in totaal 6)