Support » Algemeen WordPress » Permalinks gaan van tijd tot tijd kapot

  • Hallo Allen,

    Ik heb een vreemd probleem waar ik inmiddels geen oplossing meer voor weet. Ik ben aardig ervaren met WordPress maar dit gaat mijn pet te boven.

    Ik heb op een hostingaccount van Antagonist een website gemaakt voor onze vereniging van koks. Het is een website met buddypress zodat leden kunnen inloggen om een agenda te zien, foto’s te bekijken en de ledenlijst. So far so good.

    Na oplevering op de definitieve host (ook Antagonist, site verhuisd met all in one wp migration) gaan op onverklaarbare wijze de permalinks kapot. Maar alleen van pagina’s (die geven dan een 404 error), posts en archieven zijn gewoon bereikbaar. Omdat het template (Woffice, aangekocht via themeforest) een andere inlog-url aanbiedt dan /wp-admin kan ik door de broken permalinks ook niet meer inloggen, hij komt in een loop. Ik los dit op door in de DB, tabel wp_options het template even aan te passen naar twentytwentyone. Ik kan dan weer inloggen (pagina’s geven nog steeds een 404), ga naar de permalinks sectie, sla deze twee keer op en de pagina’s doen het weer. Nog even het template weer goed zetten en de site draait weer.

    Het rare is dat dit op de meest onverklaarbare momenten gebeurt. De site wordt niet aangepast, er zijn geen grote updates van plugins of iets dergelijks en ook WordPress is niet aan het updaten. Soms zit er enkele uren tussen dat ik moet repareren, soms enkele dagen. Kan het te maken hebben met een cronjob? Kan het hosting gerelateerd zijn?

    Is er iemand die dit ook wel eens heeft meegemaakt en een oplossing heeft gevonden?

    De volgende plugins staan aan (overigens als ik alle plugins uitschakel, zijn de pagina’s nog steeds 404):

    BP Non Editable Profile Fields
    BuddyPress
    CB Change Mail Sender
    Classic Editor
    Email Gebruikers
    Eonet Manual User Approve
    EventON
    EventON – RSVP Events
    Feedzy RSS Feeds Lite
    FooBox afbeelding lightbox
    Gravity Forms
    Gravity Forms (nl)
    Multiple Roles
    Nav Menu Roles
    NextGEN Gallery
    Unyson
    User Role Editor
    Username Changer
    Woffice Core
    Yoast Duplicate Post`

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

1 reactie aan het bekijken (van in totaal 1)
  • Guido

    (@guido07111975)

    Hoi Luc,

    Maar alleen van pagina’s (die geven dan een 404 error), posts en archieven zijn gewoon bereikbaar.

    Dit is erg vreemd, omdat dit alle drie standaard onderdelen van WordPress zijn. Zouden moeten werken met alle permalink versies die bij Instellingen > Permalinks aanwezig zijn. Dit probleem komt voor zover ik weet alleen voor bij custom post types en dan moet je de Permalink opnieuw opslaan, klaar. En soms moet je de hosting provider vragen om de ondersteuning van permalinks te activeren. Dat is hier niet het geval.

    Je zou eens kunnen kijken of er iets wijzigt in de htaccess die in de root staat, direct nadat het probleem zich voorgedaan heeft.

    Zal mij niet verbazen dat jouw thema iets met de permalink doet, heb je daar ook al een support ticket gemaakt?

    Guido

1 reactie aan het bekijken (van in totaal 1)