Ondersteuning » Algemeen WordPress » Permalink wilt maar niet werken.

  • Hallo Allemaal,

    Ik ben bezig om mijn permalink aan te passen.
    Nu doet deze het op standaard goed, maar zodra ik hem aanpas naar berichtnaam of aangepast structuur werkt het niet.

    Hierna krijg ik dan een foutmelding 404.
    Ik heb het htacess bestand aangepast — > helpt niet
    Ik heb een nieuwe pagina aangemaakt —- > helpt niet

    Ik ben letterlijk al een halve dag aan het zoeken naar een oplossing en word echt gek hier, wat ik ook doe ik blijf de foutmelding krijgen.

    Ps. de site waar het om gaat is http://www.snagels.nl

6 reacties aan het bekijken - 1 tot 6 (van in totaal 6)
  • wpprogrammeurs.nl

    (@wordpressprogrammeursnl)

    staat mod_rewrite wel aan op je server ? (Controleer evt. met <?php phpinfo(); ?> )

    wat heb je in .htaccess gedaan ?

    Thread starter playboyzalm

    (@playboyzalm)

    Ik weet nog niet waar ik dit kan vinden dus ik heb de vraag even neergelegd bij de Hoster.

    in mijn .htaccess staat het volgende:

    IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Daarnaast krijg ik trouwens bij iedere pagina die ik aanmaak en zie ook mijn huidige pagina’s de permanent link op mijn pagina.
    Dus onder menu kopje behandeling krijg ik ook nogmaals op de pagina behandeling.

    alvast bedankt.

    Je kan een eigen menu aanmaken voor via Weergave > Menu’s een eigen Menu aan te maken en dan zelf onderdelen (pagina’s) toe te voegen.

    Op die manier heb je 100% controle over welke pagina’s er in de menu-balk komen te staan.

    Thread starter playboyzalm

    (@playboyzalm)

    Dank je wel voor je antwoord.

    De menubalk zelf gaat wel goed.
    Maar als je in de menubalk op 1 van de balken klikt, krijg je de pagina tervoorschijn, nu begint de pagina als eerst met de koptekst wat het zelfde is als in het menubalk en krijg dat maar niet weg.

    Tevens antwoord op mijn eerste vraag van mijn Hoster:
    mod_rewrite staat gewoon standaard bij ons aan. Vermoedelijk staat er iets in je htacces niet goed, maar als ik mijn htacces bestand vergelijkt met andere dan heb ik deze volgens mij goed staan.
    Zolang ik mijn permalink op standaard zet is er niks aan de hand, maar zodra ik deze verander naar bijv. berichtnaam dan krijg ik wel de goede permalink in het adresbalk maar op de pagina verschijnt dan 404 kan bestand niet vinden.

    wpprogrammeurs.nl

    (@wordpressprogrammeursnl)

    IfModule mod_rewrite.c>
    RewriteEngine On

    Ik mis zondermeer een openingshaak op de 1e regel, maar gooi de 1e en laatste regel van je .htaccess er eens uit, doet dat wat ?

    eventueel kun je deze proberen :

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    mbt ‘dubbele’ titels : de pagina laat gewoon de titel van de pagina zien. Die wil je eigenlijk helemaal niet weghalen ivm SEO, maar als het echt weg moet zoek dan in je thema eens naar : the_title en zet daar twee slashes voor om de functie uit te zetten : //

    Thread starter playboyzalm

    (@playboyzalm)

    Ik heb nog even gekeken maar de openingshaak stond er wel in, alleen kennelijk niet mee gekopieerd.
    Helaas toen ik de eerste en laatste regel weghaalde kreeg ik weer de foutmelding, niet als ik hem weer op standaard zet.

    Nu ook jouw code erin gezet maar krijg nog steeds dezelfde foutmelding.
    Krijg deze foutmelding: Error 404 – Not Found
    Maar dit is alleen als ik naar kopje van mijn menubalk ga, de pagina zie ik dan niet maar wel gewoon mijn website. Als ik gewoon op http://www.snagels.nl blijf dan blijft die mijn website wel weergeven.
    Daarom ik snap het echt niet meer, ook nu nog nieuwe pagina’s aangemaakt maar ook hier doet die niks mee.

6 reacties aan het bekijken - 1 tot 6 (van in totaal 6)
  • Het onderwerp ‘Permalink wilt maar niet werken.’ is gesloten voor nieuwe reacties.