Ondersteuning » Installatie WordPress » overzetten van 1 server naar de andere

  • Misschien is dit topic al eens behandeld, maar ik kon zo snel niets vinden dat er op lijkt, dus alvast excuses als ik naar de bekende weg vraag.
    Ik heb een WP site gemaakt en deze draait op een test-server. Nu is deze goedgekeurd en kan hij over naar de domeinnaam van degene voor wie ik de site heb gemaakt. Hoewel alle pagina’s, teksten, etc keurig zijn meegekomen, ben ik na het overzetten een aantal functionaliteiten kwijtgeraakt. O.a. ik kan mijn schermindeling niet zien (die springt als het ware), ik kan het menu niet kan aanpassen (de volgorde daarvan), de widgets staan allemaal onder elkaar en dat is onvoorstelbaar onhandig om aan te passen. Uiteraard zijn de links naar de plaatjes ook niet goed, maar die pas ik wel aan, alleen wat me opvalt is dat ik geen links meer kan aanmaken (wel in html modus maar niet in de visual door op het link icoontje te klikken). Ik gebruik WP 3.3.1, en het InStyle thema van ElegantThemes.

    Iemand suggesties?

    orignele link: http://www.helenbakker.nl/test/WP_test, en dit is waar hij heen is verplaatst (nog op test omdat ik de link naar de site die er nu draait nog niet wil verbreken): http://www.dewaddenparel.nl/test

14 reacties aan het bekijken - 1 tot 14 (van in totaal 14)
  • Hoe heb je het handeltje verplaatst? Nieuwe installatie op dewaddenparel, export bij helenbakker en import bij dewaddenparel? Het klinkt alsof de nieuwe WP niet goed is geïnstalleerd. Die kun je natuurlijk zonder problemen vervangen.

    Thread starter helenbakker

    (@helenbakker)

    Hallo Roy,
    Ja, inderdaad, zo heb ik het gedaan. Ik heb op dewaddenparel een nieuwe WP versie neergezet, dus ik ging ervan uit dat dat goed zou zijn. Nu is het wel zo dat de test-versie op een Engelse WP 3.3.1 draaide, en ik op de nieuwe plek een Nederlandse versie heb geplaatst. Zou dat het probleem kunnen zijn?

    Dat kan ik me niet voorstellen, want het enige dat er bij een NL versie anders is (volgens mij) is een extra bestandje dat alles vertaalt.

    Ook niet perongeluk twee verschillende versies van WP gebruikt? Dat zou ook niet uit moeten maken, maar gewoon om eens te informeren? Zijn de servers verder wel hetzelfde?

    Het waarschijnlijkst is een plugin die niet goed is geïnstalleerd of niet goed werkt. Anders even de WP bestandjes vervangen.

    Thread starter helenbakker

    (@helenbakker)

    Ik heb gekeken, en ik het enige verschil tussen de versies is idd NL en Eng. De servers, tja.. dat is de vraag. Mijn eigen provider draait een Linux server, die speciaal voor mij is ingericht, en de Waddenparel server is van bedrijvenweb (nog nooit eerder mee gewerkt, dus geen idee verder).
    Ik werk zelf veel met MijnDomein, en dat is supersimpel, dus ik ga ook daar nog een testje draaien. Als dat beter werkt zal ik mijn klantje vragen om over te stappen.

    Thread starter helenbakker

    (@helenbakker)

    Plugins heb ik voor de transfer allemaal uitgezet, maar wellicht is het een idee om ze te verwijderen en opnieuw te installeren?

    Weet je of de nieuwe installatie nog wel werkte toen hij nog ‘kaal’ was? Dus voordat de ging importeren, plugins erbij zetten en zo?

    Anders even standaard ’troubleshooten’. Alle plugins uit, kijken of het helpt. Als dat zo is, een of een aan en steeds even kijken of het probleem terug komt.
    Thema op default en kijken of het helpt.
    Anders toch even de WP bestandjes vervangen (alles behalve WP-config en de map wp-content).

    Thread starter helenbakker

    (@helenbakker)

    Ik ga aan de slag :). Dank voor je bijstand!

    Thread starter helenbakker

    (@helenbakker)

    Roy, wat mij trouwens opvalt nu ik er naar kijk: op mijn testserver staat een .htcacces bestand en dat wordt niet meegenomen naar de nieuwe upload (al een paar keer ook afzonderlijk geprobeerd). Wat is dat voor bestand en is het noodzakelijk?

    Dat is een verborgen bestand dat tegen servers zegt als ze iets afwijkends moeten doen. Hierkomt komt bijvoorbeeld een stukje te staan als je “pretty permalinks” gebruikt of als je bepaalde bestanden of mappen achter een wachtwoord wil hebben. WP maakt dat vanzelf aan als het nodig is, maar misschien heb je in de oude installatie wel iets in htaccess staan dat nu nog niet in de nieuwe staat. Dat verklaart trouwens niet waarom WP niet goed zou werken.

    Maar ik vermoed nu dat je de bestandjes van de ene server naar de andere aan het toeteren bent? Het lijkt mij slimmer om een nieuwe download van WP te doen en die te gebruiken op de nieuwe server.

    Trouwens, de reden dat je htaccess niet mee komt, kan zijn dat je FTP programma het niet ziet als het op de computer staat. Als je handmatig een htaccess bestand op de server wil zetten, noem je het eerst iets van htaccess.txt en als het op de server staat hernoem je het naar .htacess (inclusief punt). Afhankelijk van de instellingen zie je het daarna niet meer of toch wel.

    Thread starter helenbakker

    (@helenbakker)

    htaccess heb ik over kunnen zetten, en er staat een hele verse WP-versie op, maar ik blijf de problemen houden met widgets die onder elkaar staan, menus die ik niet qua volgorde kan aanpassen en de onmogelijkheid om mijn screenoptions te kunnen zien.
    Ik vrees dat ik opnieuw moet gaan bouwen (niet zo’n heel groot probleem, ik heb alle bestanden klaar staan).
    Echter, ik bouw dan nu in de /test van DeWaddenparel. Als ik straks wil gaan overzetten naar het domein zelf, krijg ik dan dezelfde problemen? Ik moet eerlijk zeggen, ik ben overgestapt van Joomla naar WordPress omdat ik het veiliger vond en voor mijn klanten eenvoudiger om bij te houden, maar dit is een minpuntje. Joomla zet je zonder problemen over (althans dat is mijn ervaring).

    Maar ik vermoed nu dat je de bestandjes van de ene server naar de andere aan het toeteren bent? Het lijkt mij slimmer om een nieuwe download van WP te doen en die te gebruiken op de nieuwe server.

    Releases

    Dat het niet meteen goed gaat, hoeft niet aan WP te liggen. Ik heb er nog nooit moeite mee gehad.

    Thread starter helenbakker

    (@helenbakker)

    Hoi Roy,
    O, maar zo bedoel ik het absoluut niet, hoor. Het ligt ook niet aan WordPress, want ik ben niet voor niets overgestapt.
    Dat het niet goed gaat ligt volgens mij aan de combinatie van het thema (hoewel dat een premium thema is waar ik ook de laatste en geupdate versie van gebruik), en wellicht een stukje onwetendheid aan mijn kant.
    Gelukkig heb ik de tijd momenteel, dus ik ga de boel gewoon 1 op 1 overzetten, met een nieuwe, versgedownloade versie van WP 3.3.1 NL en dan per stuk (thema, plugins) kijken waar het fout gaat (of juist goed).

    Denk jij dat ik nog problemen krijg als ik van dewaddenparel.nl/test over ga zetten naar dewaddenparel.nl?

    Begin eens met gewoon alle bestandjes van WP van de nieuwe website weg te gooien (behalve wp-config.php en eventueel /wp-content) en dan een nieuwe download op de server te zetten. Het kan ook zomaar zijn dat bij het downloaden van de bestandjes van de oude server of het uploaden op de nieuwe een bestandje is beschadigd, ontbreekt of weet ik wat. Met een nieuwe download van WP weet je in elk geval dat het niet aan zoiets ligt.

    Aan de database kan het bijna niet liggen, het is puur iets in WP wat niet goed werkt.

    Het enige risico dat bestaat is dat de server van de nieuwe website WP niet aardig vindt en dat het daar aan ligt, maar dat is ook maar een kleine kans. De kans is groter dat je manier van verhuizen niet vlekkeloos is verlopen.

    Thread starter helenbakker

    (@helenbakker)

    Roy, ik heb je advies opgevolgd. Dus, nieuwe WP NL versie gedownload, deze op de nieuwe server gezet, en de wp-config en wp-content laten staan. Dat werkte niet. Toen ook die laatste bestandjes verwijderd, WP opnieuw geïnstalleerd, en toen, per module gaan terugzetten.
    Als eerste het thema (ging goed), thema aangepast, dat ging nog steeds goed, maar toen ik een menu item aanklikte om te kijken of dat werkte kreeg ik een “500 Internal Server Error”. Het lijkt wel alsof het niet mag, haha.
    Ik heb een ticket geopend bij de hostingpartij, en wacht even af wat zij zeggen (ik begreep op de meeste fora dat zo’n fout vaak bij de host ligt). Dus ik ga nu maar ff verder met een statische site (jaja, die bestaan ook nog).
    Dank voor al je ondersteuning, en ik hou je op de hoogte :).

    Groet, Helen

14 reacties aan het bekijken - 1 tot 14 (van in totaal 14)
  • Het onderwerp ‘overzetten van 1 server naar de andere’ is gesloten voor nieuwe reacties.