Support » Algemene WordPress vragen » Niet meer inloggen in admin

  • Opgelost els007

    (@els007)


    Ik kan niet meer inloggen in de admin, krijg deze melding: Error thrown

    Cannot create references to/from string offsets

    Ik heb al zitten kijken op de fora en het de webhost gevraagd. Die zegt dat door de nieuwe php versie sommige plugins dit kunnen veroorzaken. Op het wordpress forum lees ik ergens dat de NextGen gallery plugin misschien de schuldige is.

    Ik kan niet in de admin om een plugin te deactiveren. Is er een manier met FTP dat ik dat wel kan doen?

15 reacties aan het bekijken - 1 tot 15 (van in totaal 25)
  • Goedemorgen Els,

    Vervelend dat je niet meer in de backend kunt komen.

    Dit zou inderdaad kunnen dat een of meerdere plugins en thema´s nog niet echt compatibel zijn met de nieuwe PHP versie.

    Als het goed is heeft jouw webhoster alle (controle paneel en ftp) inloggegevens naar je toegestuurd. Via de FTP kan je deze verwijderen van de FTP server.
    Met FTP programma FileZilla kan je inloggen op FTP (bestanden uploaden en downloaden).

    De map van de plugins is te vinden onder wp-content. Op deze manier kan je NextGen plugin verwijderen.

    Succes!

    Vriendelijke groet,
    Bas

    Ja, gedaan. Heb een back-up gemaakt en daarnu het mapje NextGen verwijderd uit de map Plugin. Nu krijg ik helaas een vreemde redirect als ik wil inloggen: http://www.schildersbedrijf-dekker-en-nieuwenhuizen.nl/wp-login.php?redirect_to=http%3A%2F%2Fwww.schildersbedrijf-dekker-en-nieuwenhuizen.nl%2Fwp-admin%2F&reauth=1

    Site werkt gelukkig nog wel…

    Ik heb de back-up teruggezet. Het verwijderen van de NextGen plugin heeft niet geholpen. Iemand nog een idee?

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Kun je eens gewoon de volledige plugin map hernoemen om er zo geen enkele actief te laten zijn en zo te proberen?

    Groet,
    Jeroen

    Hoe ziet je .htaccess bestand er uit ? En heb je code geplaatst in het wp-config.php bestand ?

    htacces:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    en ik geen code geplaatst in wp-config.php (denk ik). Heb de site 4 jaar geleden gemaakt, maar ik zie niets staan wat er niet thuishoort.

    Ik heb wel eens vergelijkbare issues gezien bij anderen. Die werden veroorzaakt door code in het wp-config.php bestand die toegevoegd waren na de regel “That’s it stop editing here”. Maar goed, het lijkt me sterk dat dit ook het geval is bij jou.

    Wat je nog zou kunnen proberen is het volgende.

    Voeg deze regels toe aan je wp-config.php bestand:

    // Turn debugging on
    define('WP_DEBUG', true);
    
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);

    /* That’s all, stop editing! Happy blogging. */ <<< Vóór deze regel dus

    ———————-

    Hierna probeer je weer in te loggen. En dan kun je eventuele foutmeldingen in http://www.schildersbedrijf-dekker-en-nieuwenhuizen.nl/wp-content/debug.log vinden. Post deze hier zodat we je beter kunnen helpen.

    • Deze reactie is gewijzigd 1 jaar, 7 maanden geleden door johnny538.

    Na de regel ‘stop editing’ staat er bij mij:

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

    !!

    Kan dat het zijn dan? Zou ik dat dan gewoon moeten/kunnen verwijderen? Of verplaatsen?

    • Deze reactie is gewijzigd 1 jaar, 7 maanden geleden door els007.
    • Deze reactie is gewijzigd 1 jaar, 7 maanden geleden door els007.
    • Deze reactie is gewijzigd 1 jaar, 7 maanden geleden door els007.

    Nee, dat stukje hoort zo. Alleen regels die door de gebruiker toegevoegd worden horen vóór die ene regel te staan. Het zal overigens niet altijd problemen veroorzaken, maar het kan wel (afhankelijk van wat er precies toegevoegd word).

    Jou wp-config.php bestand is dus prima. ALs je de code van mijn vorige bericht even toevoegt op de juiste plek dan word debug logging ingeschakeld, en eventuele foutmeldingen worden naar /wp-content/debug.log geschreven. Deze kunnen mogelijk een indicatie geven over de oorzaak van je probleem.

    Ik moet er nog even aan toevoegen dan je mogelijk zelf even het bestand ‘debug.log’ in the /wp-content/ folder moet aanmaken als dit niet automatisch gebeurd. Dit kan via de File Manager van je webhost, of via een FTP programma.

    Ik heb de genoemde regels toegevoegd;

    // Turn debugging on
    define(‘WP_DEBUG’, true);

    // Tell WordPress to log everything to /wp-content/debug.log
    define(‘WP_DEBUG_LOG’, true);

    // Turn off the display of error messages on your site
    define(‘WP_DEBUG_DISPLAY’, false);

    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set(‘display_errors’, 0);

    /* That’s all, stop editing! Happy blogging. */

    Heb het bestand debug.log aangemaakt en in de map wp-content gezet. Maar http://www.schildersbedrijf-dekker-en-nieuwenhuizen.nl/wp-content/debug.log blijft leeg.

    he, wat rot 🙁

    Het is raar dat de site wel werkt, maar alleen /wp-admin/ niet.

    Ik heb nog eens de broncode van de site bekeken. Het valt me op dat sommige elementen via http://schilder&#8230;.. worden geladen, en andere vanuit http://www.schilder&#8230;.

    Misschien is er een site/home url conflict.

    Kun je misschien de volgende code in je wp-config.php toevoegen:

    define( 'WP_HOME', 'http://www.schildersbedrijf-dekker-en-nieuwenhuizen.nl' );
    define( 'WP_SITEURL', 'http://www.schildersbedrijf-dekker-en-nieuwenhuizen.nl' );

    Vóór die ene regel natuurlijk

    Werkt het nog niet ? Probeer dan:

    define( 'WP_HOME', 'http://schildersbedrijf-dekker-en-nieuwenhuizen.nl' );
    define( 'WP_SITEURL', 'http://schildersbedrijf-dekker-en-nieuwenhuizen.nl' );

    Je kan ook andere variaties proberen zoals de home url met/zonder www, en de site url met/zonder www. Tussen elke wijziging zou ik wel even de cache & cookies van je browser leeg maken.

    Dankje! Ga ik proberen. Wat bedoel je met

    ‘Vóór die ene regel natuurlijk’?

15 reacties aan het bekijken - 1 tot 15 (van in totaal 25)
  • Het onderwerp ‘Niet meer inloggen in admin’ is gesloten voor nieuwe reacties.