Ondersteuning » Algemeen WordPress » Multisite werkt niet

  • Opgelost antaqua

    (@antaqua)


    Hallo,

    Ik heb een multisite gemaakt met http://www.antaqua.net als hoofdsite en daar heb ik nu 2 werkende sub sites op http://www.lerenduikeninantwerpen.be en http://www.duikeninantwerpen.be.

    Nu wil ik een derde site toevoegen.
    Ik heb een clone genomen van duikeninantwerpen via de build in tools.
    Maar ik krijg continu “Server niet gevonden”

    Mijn htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    
    RewriteCond %{HTTPS} !=on
    RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]
    
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . /index.php [L]
    
    </IfModule>
    # END WordPress

    Mijn wp-config

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '-redacted-');
    
    /** MySQL database username */
    define('DB_USER', '-redacted-');
    
    /** MySQL database password */
    define('DB_PASSWORD', '-redacted-');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8mb4');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '-redacted-');
    define('SECURE_AUTH_KEY',  '-redacted-');
    define('LOGGED_IN_KEY',    '-redacted-');
    define('NONCE_KEY',        '-redacted-');
    define('AUTH_SALT',        '-redacted-');
    define('SECURE_AUTH_SALT', '-redacted-');
    define('LOGGED_IN_SALT',   '-redacted-');
    define('NONCE_SALT',       '-redacted-');
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wppb_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', true);
    
    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    define( 'DOMAIN_CURRENT_SITE', 'www.antaqua.net' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    define( 'COOKIE_DOMAIN', '' );
    define( 'ADMIN_COOKIE_PATH', '/' );
    define( 'COOKIEPATH', '/' );
    define( 'SITECOOKIEPATH', '/' );   
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Iemand enig idee hoe ik dit probleem kan verhelpen?
    Alvast bedankt!

    • Dit onderwerp is gewijzigd 2 jaren, 11 maanden geleden door Richard van Denderen. Reden: wachtwoorden uit bericht gehaald

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)
  • Beste Antaqua,

    Je geeft aan dat het gaat om diveinantwerp.be

    Het domeinnaam is nog vrij. Je zou deze eerst moeten vastleggen bij een registrar en vervolgens binnen jouw hostingaccount moeten pointen naar de Multisite omgeving.

    @antaqua Ik heb je bericht aangepast en je database gebruikersnaam en wachtwoorden uit je bericht gehaald.

    Login gegevens op een openbaar forum plaatsen geeft je haast een garantie om gehacked te worden.

    Aan te raden om je database wachtwoord dan ook te wijzigen én dit aan ta passen in
    je wp-config.php

    Daarnaast zou je dit waarschijnlijk moeten melden als datalek/incident bij de Gegevensbeschermingsautoriteit.

    Thread starter antaqua

    (@antaqua)

    Bedankt!
    Blijkbaar had de IT dienst een typfout gemaakt bij de registratie waardoor wij in de waan waren dat de correcte URL geregistreerd was.
    Fout is nu rechtgezet

    Goed om te horen. Had je het bericht van Richard ook gelezen? Vergeet je database credentials en salt keys niet te wijzigen.

    Fijne dag!

    Thread starter antaqua

    (@antaqua)

    Ik heb geprobeerd het paswoord aan te passen, maar dit lukte niet (mss al gehacked??)

    Maar nu krijg ik wel:

    Warning: mysqli_real_connect(): (28000/1045): Access denied for user ‘antaqsh334_wp659’@’localhost’ (using password: YES) in /home/antaqsh334/domains/antaqua.net/public_html/wp-includes/wp-db.php on line 1633

    Access denied for user ‘[user]’@’localhost’ (using password: YES)

    Iemand enig idee hoe je bij softaculous dit kan oplossen?

    Heb je zowel het wachtwoord gewijzigd in de wp-config.php als op de server van de database zelf? Als deze niet overeenkomen dan krijg je het probleem dat er geen database connectie gemaakt kan worden.

    • Deze reactie is gewijzigd 2 jaren, 11 maanden geleden door WP Provider.
    Thread starter antaqua

    (@antaqua)

    Ik wou dit eerst via softaculous aanpassen, maar dan krijg ik de melding
    The following errors were found :

    The MySQL Username or Password or Database host is wrong as a connection could not be established.

    Dus ik heb niets aangepast in wp-config.

    Het beste om te doen is om het wachtwoord van jouw database binnen het controlpanel te wijzigen. De methode hiervoor is afhankelijk van jouw hostingprovider. Als je DirectAdmin / C-Panel / Plesk gebruikt dan is er een overzicht van de aangemaakte databases met daarbij de optie om het wachtwoord ook te wijzigen.

    Als je dit wachtwoord hebt gewijzigd dan dien je ditzelfde wachtwoord ook te gebruiken in jouw wp-config.php

    Vervolgens kun je dit nieuwe database wachtwoord ook weer ingeven binnen Softaculous zodat hij deze als actieve installatie ziet.

    • Deze reactie is gewijzigd 2 jaren, 11 maanden geleden door WP Provider.
    Thread starter antaqua

    (@antaqua)

    Bedankt!
    Weer heel wat bijgeleerd!

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)
  • Het onderwerp ‘Multisite werkt niet’ is gesloten voor nieuwe reacties.