Support » Installatie WordPress » Multisite domein problemen

  • Beste,

    Recent ben ik aan de gang gegaan met multisite na 2/3 jaar ervaring met normale WordPress installaties. Alles werkt naar behoren behalve het volgende probleem. http://www.kevinvonk.nl doet het prima maar op het moment dat je kevinvonk.nl intyp kom je op de registratie pagina uit. Ik zou graag zowel http://www.kevinvonk.nl als kevinvonk.nl normaal willen laten functioneren. Nu ben ik ook al in het Engels bezig geweest op dit forum alleen regeert amper iemand. Nu probeer ik het hier.

    www.kevinvonk.nl  <-- Laad goed 
    kevinvonk.nl      <-- stuurt door naar sign-up page

    Ik heb NOBLOGREDERECT geprobeerd helaas lost dit het probleem niet op. Mijn dns instellingen staan allemaal prima. In mijn .htaccess bestand heb ik het volgende aangepast (helaas zonder succes).

    RewriteCond %{HTTP_HOST} ^kevinvonk.nl$ [NC]
    RewriteRule ^(.*)$ http://www.kevinvonk.nl/$1 [R=301,L]

    De volgende stappen heb ik ook al gevolgd:https://wordpress.stackexchange.com/questions/14383/multisite-non-www-domain-redirects-to-sign-up

    Ik heb de map mu-plugin gemaakt -> en het bestand domain_mapping.php in de map gezet -> sunrise.php geupload -> define( 'SUNRISE', 'on' ); toegevoegd aan de wp-config.php toen kreeg ik het bericht:
    The constant "COOKIE_DOMAIN" is defined (probably in wp-config.php). Please remove or comment out that define() line.
    Het gevraagde stukje verwijderd en toen stond de melding er nog dus daarna geprobeerd de hele command line te verwijderen alleen dan kreeg ik deze melding:
    ERROR couldn't make a database connection

    Na deze melding heb ik gedaan wat er gevraagd werd helaas loste dit niks op. De melding bleef actief totdat ik de app verwijderde. Ik hoorde van verschillende mensen dat dit momenteel is toegevoegd aan WordPress en dat dus de plugin overbodig maakt.

    Na gesproken te hebben met iemand van dit forum begon de gene die mij hielp te vermoeden dat mijn .htaccess bestand wellicht niet geheel klopte.
    dit is mijn .htaccess bestand:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) kevinvonk/$1 [L]
    RewriteRule ^(.*\.php)$ kevinvonk/$1 [L]
    RewriteRule . index.php [L]
    </IfModule>
    php_value upload_max_filesize 300M
    php_value post_max_size 300M
    php_value memory_limit 100M
    # END WordPress

    Weet iemand hoe ik mijn domein problemen kan oplossen? Ik heb namelijk geen opties om dat binnen WordPress te doen en ik heb helaas nog niet genoeg ervaring om zelf tot de oplossing te komen.

    Alvast bedankt,

    Kevin Vonk

    • Dit onderwerp is gewijzigd 1 maand, 1 week geleden door kevinvonk.
    • Dit onderwerp is gewijzigd 1 maand, 1 week geleden door kevinvonk.

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

6 reacties aan het bekijken - 1 tot 6 (van in totaal 6)
  • Beste @jeroenrotty @ronaldvw,

    Zouden jullie hier is naar willen kijken?

    Alvast bedankt,

    Kevin Vonk

    Hi Kevin,

    je .htaccess lijkt me het probleem, tenzij je WordPress < 3.5 hebt geïnstalleerd. Voor de huidige WordPress versies (en 3.5+) ziet de basis .htaccess er zo uit:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Je kunt deze code (en de code die je aan wp-config.php moet toevoegen) ook vinden in de “network setup” settings. (Ik heb geen NL network ge├»nstalleerd, maar in het Engels ziet dat er zo uit):

    http://vanweerd.com/screenshots/s20191104172511.jpg

    kevinvonk

    (@kevinvonk)

    Beste @ronaldvw,

    Hartelijk dank voor de reactie, ik heb uw advies opgevolgd en het .htaccess bestand aangepast naar:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    # END WordPress
    </IfModule>
    php_value upload_max_filesize 300M
    php_value post_max_size 300M
    php_value memory_limit 100M
    # END WordPress

    Helaas word je nog steeds doorgestuurd naar: https://www.kevinvonk.nl/wp-signup.php?new=kevinvonk.nl als je kevinvonk.nl intypt.

    Mijn wp-config.php:

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME', 'kevinvonk032_wp2' );
    /** MySQL database username */
    define( 'DB_USER', 'kevinvonk032_wp2' );
    /** MySQL database password */
    define( 'DB_PASSWORD', '-----' );
    /** MySQL hostname */
    define( 'DB_HOST', 'localhost' );
    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '----');
    define('SECURE_AUTH_KEY',  '----');
    define('LOGGED_IN_KEY',    '----');
    define('NONCE_KEY',        '----');
    define('AUTH_SALT',        '----');
    define('SECURE_AUTH_SALT', '----');
    define('LOGGED_IN_SALT',   '----');
    define('NONCE_SALT',       '----');
    /**
     * Other customizations.
     */
    define('FS_METHOD','direct');
    define('FS_CHMOD_DIR',0755);
    define('FS_CHMOD_FILE',0644);
    define('WP_TEMP_DIR',dirname(__FILE__).'/wp-content/uploads');
    /**
     * Turn off automatic updates since these are managed externally by Installatron.
     * If you remove this define() to re-enable WordPress's automatic background updating
     * then it's advised to disable auto-updating in Installatron.
     */
    define('AUTOMATIC_UPDATER_DISABLED', true);
    /**#@-*/
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 'wp_';
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define( 'WP_DEBUG', false );
    /* Activeren van Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'www.kevinvonk.nl');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    define('COOKIE_DOMAIN', $_SERVER[ '' ] );
    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', '');
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');
    define( 'SUNRISE', 'off' );
    /* That's all, stop editing! Happy publishing. */
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    }
    /** Sets up WordPress vars and included files. */
    require_once( ABSPATH . 'wp-settings.php' );
    
    • Deze reactie is gewijzigd 1 maand geleden door kevinvonk.

    Hallo,

    heb je de wp-config.php exact volgens de aanwijzingen aangepast? En geen verdere aanpassingen (of MU plugins)?

    Volgens mij zou de toevoeging niet meer dan het volgende moeten zijn:

    
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true); 
    define('DOMAIN_CURRENT_SITE', 'kevinvonk.nl');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    

    Tenslotte kun je je hosting provider om assistentie kunnen vragen, of er misschien re-directs op server niveau zijn gedefinieerd, of wellicht kunnen ze de logs bekijken.

    kevinvonk

    (@kevinvonk)

    Beste @ronaldvw,

    Het enige wat ik heb toegevoegd is define( 'SUNRISE', 'off' ); mu plugin is verwijderd (incl alle bestanden).
    De rest is standaard @jeroenrotty weet jij wellicht wat de oorzaak zou kunnen zijn?
    @ronaldvw nog andere ideeen?

    Alvast bedankt,

    Kevin Vonk

    • Deze reactie is gewijzigd 1 maand geleden door kevinvonk.

    Nou gezien niemand eruit komt hier de oplossing.

    # Redirect non-www to www
    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^www\. [NC]
    RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=301,L]
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    </IfModule>
    
    # END WordPress
6 reacties aan het bekijken - 1 tot 6 (van in totaal 6)