Support Volgende » Algemene WordPress vragen Volgende » Moeilijkheden met registratie.

  • Opgelost mrfdes

    (@mrfdes)



    Hallo,
    Ik heb een (klein) probleem:
    Ik gebruik WP versie 4.9.8 met MUSOTHEME als thema.
    Tevens is ook de plugin WP Cerber Security, Antispam & Malware Scan geïnstallerd (misschien veroorzaakt die mijn probleem).

    Het probleem is: op mijn eigen computer staat er rechts boven een koppeling “Hallo admin” waar ik kan aan- en afmelden en mijn profiel wijzigen.

    Wanneer ik op een andere computer kijk is er niets te zien van registratie of aanmelden, enkel wanneer je naar een post gaat en op “LEES MEER” klikt staat er onderaan het reactie veld “Je moet inloggen om te kunnen reageren”, pas als je daarop klikt komt dan het scherm waar je kunt registreren of aanmelden.

    Dat is uiteraard verwarrend voor mensen die willen registreren op de blog.
    Is het mogelijk om op de hoofdbladzijde een koppeling te zetten in de aard van “Meld aan/Registreer”, en, zo ja, hoe moet ik dat doen?
    Ik heb al door alle instellingen, inclusief menu’s gebladerd, doch ik vind daar niets wat tot een oplossing kan leiden.

    Alle hulp zou ten zeerste op prijs gesteld worden.
    Alvast bedankt.

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

3 reacties aan het bekijken - 1 tot 3 (van in totaal 3)
  • Hey @mrfdes,

    Het probleem klinkt inderdaad erg ingewikkeld. Het kan namelijk aan meerdere dingen liggen, je Thema, je plugins, je cache etc.

    Als eerst raad ik je aan je cache te resetten, mocht je een cache plugin aan hebben staan.

    Lost dat niet het probleem op? Geen punt! Nu begint het debuggen.

    Als eerst deactiveer al je plugins. Activeer daarna 1 voor 1 je plugins. Nadat je een plugin hebt geactiveerd kijk of je de Aanmelden / Registratie knop kunt vinden. Op deze manier kan je achterhalen welke plugin het probleem veroorzaakt.

    Ik hoop dat dit je verder helpt! Mocht je nog vragen hebben hoor ik het graag.

    Hey Kalovi,
    beste dank voor je reactie.
    Ik heb eerst de cache geleegd (ik heb daarvoor wel moeten WP Super Cache installeren).

    Dat maakte echter geen verschil.

    Dan heb ik, zoals je me aangeraden had, al mijn plugins gedeactiveerd (gelukkige heb ik er niet teveel) en van dan af begon het te werken.
    Toen ik ze dan één voor één weer activeerde bleek WP Users de schuldige te zijn.
    Eigenaardig genoeg: WP Users is een plugin met het doel een inlogscherm te maken, ik had dat namelijk in wanhoop geïnsatlleerd om het te proberen aan de gang te krijgen, misschien heeft de combinatie van het legen van de cache en de plugin deactiveren/verwijderen de oplossing bereikt.

    Hoe dan ook, nogmaals allerbeste dank voor je bijstand.

    Oeps, ik heb te vroeg victorie gekraaid.

    Nadat ik je raad opgevolgd had dacht ik dat de kogel door de kerk was, maar nu ik eens met CCleaner alles schoongemaakt heb sta ik weer aan het begin.

    Ik heb dus waarschijnlijk iets te haastig gekeken, want op de blog, waarop ik niet inglogd ben staat er een hopeloze lege ruimte.

    Wat ik echter wel raar vind is dat spammers (hoogstwaarschijnlijk bots) wel de weg vinden om te registreren, gelukkig is de WP Cerber daar een grote hulp bij.

    Enige verdere raad waar je kunt aan denken aub?

    Alvast bedankt.

3 reacties aan het bekijken - 1 tot 3 (van in totaal 3)