Ondersteuning » Algemeen WordPress » Melding: Je hebt geen toestemming dit bericht te bewerken

  • Hallo,

    Sinds vanmorgen kan ik geen nieuwe paginas meer activeren, melding: “Je hebt geen toestemming dit bericht te bewerken”.

    Op de bewerkpagina zie ik ook geen tags of categoriën meer.

    Ik gebruik pagebuilder en het lijkt hier mee mis te gaan.

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

15 reacties aan het bekijken - 1 tot 15 (van in totaal 16)
  • Guido

    (@guido07111975)

    Hallo,

    Alle plugins zijn up-to-date?

    Zo ja, de-activeer allereerst je plugins 1 voor 1 om te bepalen of een plugin dit veroorzaakt of niet.

    Guido

    Thread starter cdscore

    (@cdscore)

    Helaas geen resultaat. En nu?

    Guido

    (@guido07111975)

    Als je dezelfde fout krijgt terwijl je alle plugins gedeactiveerd hebt, dan moet er iets anders aan de hand zijn. Dus dan kan het ook niet aan de Pagebuilder plugin liggen. Je gebruikt als thema Twenty Fourteen, daar ligt het vast ook niet aan.

    Ik neem aan dat je de Gutenberg plugin niet gebruikt? Zou je eens de Classic Editor willen installeren om te kijken of het dan opgelost is?

    Guido

    Thread starter cdscore

    (@cdscore)

    Hallo Guido,

    Ik gebruikte de classic editor en ben overgegaan naar Gutenberg, de plugin “Disable Gutenberg” om de classic te blijven gebruiken heb ik gedelete. Maar er gebeurt niets.

    Ik kan een pagina allen indienen ter beoordeling en niet publiceren. Ik kan geen nieuwe pagina publiceren, mis gewoon de knop. Ik wou dat ik een schermafdruk kon laten zien.

    En er zijn geen categorien of tags meer om te kiezen.

    Wordpress is opeens ook ontzettend traag.

    Er is overnight iets vreemd s gebeurd.

    Groeten,

    Adrie.

    Guido

    (@guido07111975)

    Hoi Adrie,

    Je kunt een afbeelding via ImgBB delen, zonder account aan te hoeven maken.

    Als je de klassieke editor wilt blijven gebruiken hoef je alleen de Classic Editor plugin te activeren, meer niet. En voor widgets de Classic Widgets plugin.

    Heeft jouw account (nog) wel beheerdersrechten?

    Guido

    Guido

    (@guido07111975)

    Ik gebruikte de classic editor en ben overgegaan naar Gutenberg

    Met Gutenberg bedoel je de standaard blok editor of de plugin Gutenberg? De plugin niet gebruiken, die is eigenlijk alleen om nieuwe features vd blok editor te testen.

    Guido

    Thread starter cdscore

    (@cdscore)

    Hallo Guido,

    Inmiddels kan ik niet meer inloggen op m’n site.

    Enig idee hoe dit aan te pakken?

    Groeten,
    Adrie Laan

    Guido

    (@guido07111975)

    Hallo,

    Wat gebeurt er als je inlogt?

    Wat me opvalt in de broncode van je site is dat je een boel “origin trials” van Chrome/Google in de head sectie van je site hebt staan. Ik heb daar zelf geen ervaring mee, maar misschien zorgt dat voor een conflict.

    Guido

    Thread starter cdscore

    (@cdscore)

    Eerst deed captcha moeilijk, toen heb ik captcha verwijderd, met FTP, maar geen soelaas.
    Nu is captcha niet actief, maar als ik een nieuw password aanmaak kan ik daarmee niet inloggen. Er gebeurt niets.

    Guido

    (@guido07111975)

    Hallo,

    Als ik het goed begrijp heb je dus al een keer alle plugins gedeactiveerd, maar zonder resultaat. vaak is een plugin de oorzaak.

    Als je op je server PHP versie 8+ hebt draaien, zet dat eens terug naar PHP 7.4 via je hosting account (indien mogelijk).

    Levert dat ook niets op, open dan eens het htaccess bestand wat in de hoofdmap van WordPress staat, en kopieer/plak de inhoud eens hier in een nieuw bericht.

    Guido

    Thread starter cdscore

    (@cdscore)

    Hallo Guido,

    Ik heb PHP 8 geprobeerd, maar dat werkte niet, dus nu is het 7.4.

    De inhoud van het bestand is:

    # BEGIN WordPress
    # De richtlijnen (regels) tussen “BEGIN WordPress” en “END WordPress” worden # dynamisch gegenereerd en zouden alleen aangepast mogen worden via WordPress filters.
    # Alle wijzigingen aan de richtlijnen tussen deze markeringen worden overschreven.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    # BEGIN Audiobar
    # END Audiobar

    # Wordfence WAF

    <Files “.user.ini”>
    <IfModule mod_authz_core.c>
    Require all denied
    </IfModule>
    <IfModule !mod_authz_core.c>
    Order deny,allow
    Deny from all
    </IfModule>
    </Files>

    # END Wordfence WAF

    Groeten,
    Adrie

    Guido

    (@guido07111975)

    Hoi Adrie,

    PHP 8 geeft tegenwoordig nog wel eens problemen omdat niet alle thema’s en plugins dat al ondersteunen. PHP 7.4 moet geen problemen geven.

    Jouw htaccess ziet er niet vreemd uit. Eerste deel is standaard WordPress en onderste deel is Wordfence. Daar kan het ook niet aan liggen.

    Aangezien je blijkbaar geen toegang meer hebt tot het dashboard vd site, weet ik het verder ook niet meer. Vraag je hosting provider eens, of zij misschien kunnen achterhalen wat er aan de hand kan zijn.

    Guido
    (als je code plaatst druk dan vóór en ná de code op de code knop in de tekst opmaak balk)

    Guido

    (@guido07111975)

    Het is me trouwens nog steeds niet geheel duidelijk of je al een keer alle plugins gedeactiveerd had?

    Zo niet, wijzig dan eens via FTP de naam vd plugin mappen (1 letter is voldoende) zodat de plugins gedeactiveerd worden. Mogelijk krijg je dan weer toegang. Daarna de naam vd mappen natuurlijk weer herstellen.

    Guido

    Thread starter cdscore

    (@cdscore)

    Ik heb de plugin map hernoemd en ze een voor een teruggezet en het resultaat bekeken.

    Thread starter cdscore

    (@cdscore)

    Ik ga Strato maar eens raadplegen. Dank voor je support!

15 reacties aan het bekijken - 1 tot 15 (van in totaal 16)