Support » Overige » mediabestanden worden niet getoond maar zijn er wel

  • Opgelost josjaja

    (@josjaja)


    Nadat ik gisteren Wordfence heb geïnstalleerd worden geen afbeelden meer getoond op de WordPress 5.5.1–nl website. De favicon wordt wel getoond maar afbeeldingen in de website niet.

    Als ik naar de mediabibliotheek ga, worden daar geen afbeeldingen getoond (alleen grijze blokjes). Als ik vervolgens op ‘bewerken’ en vervolgens ‘afbeelding bewerken’ klik, zie ik de juiste foto. Ik kan deze bv. draaien en opslaan. Dat gaat goed maar de gedraaide foto wordt niet in de mediabibliotheek getoond. Ik kan ook nieuwe foto’s zonder problemen uploaden. Maar ook deze worden niet getoond. De rechten van de uploads map (en submappen) staan op 744 en van de afbeeldingen op 644 (incl. .htaccess (in de uploads map).

    De meest voorgeslagen methodieken die op internet worden aangeboden om dit probleem te tackelen heb ik geprobeerd. Ik heb alle plugings uitgeschakeld. Nog steeds geen afbeeldingen in de mediabibliotheek. Alle thumbnails laten hergenereren, geen steeds resultaat.

    Wat ik vreemd vind is dat het favicon wel wordt getoond en de foto’s in de mediabibliotheek en de (thema Bento) pagina’s niet. De favicon-afbeelding is ook niet zichtbaar in de mediabibliotheek.

    Via de WordPress gereedschap/sitediagnose constateer ik dat de site grotendeels Ok is. Er zijn geen kritische problemen, wel enkele aanbevelingen. Zo wordt geadviseerd o PHP te upgraden naar 7.4. Maar de provider heeft deze versie nog niet als keuze optie.
    Omdat de afbeeldingen in het verleden werden getoond, verwacht ik daarmee ook geen probleem.

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

3 reacties aan het bekijken - 1 tot 3 (van in totaal 3)
  • Guido

    (@guido07111975)

    Hallo,

    Als ik een afbeelding van je site rechtstreeks benader (voorbeeld), dan zie je dat er een 403 fout weergegeven wordt. Je afbeeldingen worden geblokkeerd. Als je ook Wordfence hebt gedeactiveerd, dan ga ik ervan uit dat er (Wordfence) code in je htaccess is achtergebleven, die dit veroorzaakt.

    Ligt het hier niet aan, kijk dan hier eens naar:
    Misschien gerelateerd, zie dit topic.
    Het kan ook liggen aan de eigenaar vd bestanden/mappen, of aan de lees/schrijfrechten ervan.

    Als je er zelf niet uitkomt, vraag je hosting provider eens.

    Los hiervan adviseer ik je om SSL/HTTPS (veilige verbinding) voor je domein te regelen.

    Guido

    • Deze reactie is gewijzigd 1 week, 5 dagen geleden door Guido. Reden: Heb mijn reactie bijgewerkt

    Dag Guido,

    Probleem opgelost. Het zat in de ‘Disable execute from uploads’ instelling in Wordfence. Deze heb ik uitgezet en nu worden alle foto’s weer getoond. Wat ik wel vreemd vind, is dat in eerste instantie de foto’s ook niet werden getoond met deze parameter op ‘yes’. Maar dat maakt me nu niet zoveel meer uit. Het functioneert!!

    T.a.v. SSL/HTTPS heb je gelijk. Maar eerst wilde ik dit probleem tackelen voordat ik me hieraan begeef.

    Groet,

    Jos

    Guido

    (@guido07111975)

    Hallo Jos,

    Normaal gesproken staan de settings van Wordfence zo ingesteld dat je er (vrijwel) nooit last van hebt. Maar goed, het kan dus soms toch problemen opleveren.
    Maar in ieder geval mooi dat het opgelost is. Bedankt voor de update!

    Guido

3 reacties aan het bekijken - 1 tot 3 (van in totaal 3)