Ondersteuning » Code oplossingen gezocht » Kritieke fout bij producten vertalen

  • kabodekens

    (@kabodekens)


    Hallo,

    Ik wil graag mijn producten in woocommerce vertalen naar het Engels en Duits, als ik het vlaggetje aanklik krijg ik de volgende foutmelding:

    Er heeft zich een kritieke fout voorgedaan op deze site. Controleer je site beheerder e-mail inbox voor instructies.

    Meer informatie over probleemoplossing in WordPress.

    Ik heb al geprobeerd om de plugins te deactiveren en daar ligt het niet aan.

    Ik weet niet hoe ik dit kan oplossen, Help!!

    Groet,

    Karin

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

11 reacties aan het bekijken - 1 tot 11 (van in totaal 11)
  • Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    De stap om dit te onderzoeken is de logbestanden in te duiken. Kijk dus in het controlepaneel van je webhost of je toegang hebt tot de logs, want daar zal de eigenlijke PHP fout staan met meer “uitleg” fan die kritieke fout.

    Daar zal ook een verwijzing staan waar in de code de fout komt, dan kan je al grotendeels weten welk thema of welke plugin er mogelijk de oorzaak is.

    Is verder alles up-to-date? Ik zie bv. dat je niet de laatste nieuwe Yoast plugin draait, dus kijk ook of updates installeren al helpt of niet.

    Thread starter kabodekens

    (@kabodekens)

    Ik heb dus totaal geen verstand van logbestanden, hoe kom ik daar?

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Log in bij Webreus en kijk of je toegang hebt tot de logs, ik ben niet vertrouwd met wat Webreus te bieden heeft, dus mogelijks moet je contact opnemen met hun om aan die informatie te komen.

    Je kan eventueel ook proberen om WP_DEBUG aan te zetten in het wp-config.php bestand om zo de fout te zien ipv van de “kritieke fouttekst” – meer info daarover kan je hier vinden: https://wordpress.org/support/article/debugging-in-wordpress/

    Thread starter kabodekens

    (@kabodekens)

    Okay, ga ik dat doen. Maar mag ik jou nog een andere vraag stellen? Ik wil nu net Yoast SEO installeren en hij geeft aan doelmap bestaat al. Waar kan ik dit ongedaan maken, zodat ik het opnieuw kan installeren. De pro versie heb ik net al verwijderd, dacht dat die misschien in de weg zou zitten.

    Alvast bedankt

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Er gaat wel vaak meer mis op Webreus, neem dat uit mijn ervaring hier en op een aantal Facebook WordPress groepen aan.

    Als Yoast SEO niet meer in je plugin lijst staat en je krijgt die fout, dan wil dat zeggen dat de map wordpress-seo in /wp-content/plugins/ nog bestaat, je zal via het controlepaneel van Webreus als dat een bestandsoplossing heeft, of via FTP die map moeten verwijderen en daarna kan je zonder problemen de plugin terug installeren.

    Thread starter kabodekens

    (@kabodekens)

    Ik kan nu eindelijk op mijn ftp site. Alleen nu heb ik nog steeds die kritieke fout bij het willen vertalen van mijn producten. Ik heb alleen totaal geen kaas gegeten van de ftp, waar ik de fout kan vinden en wat ik eraan moet doen. Ik hoop dat hier iemand is die mij hierin wegwijs zou willen maken.

    Deze fout is namelijk behoorlijk vervelend.

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    De fout is in de error logs en staat los van FTP – via FTP zie je gewoon de bestanden/mappen van je site. Tenzij je host ook logs beschikbaar maakt via FTP, maar meestal niet.

    Als je nog het installatie probleem hebt, dan zoek je de wp-content map en daarin zit /plugins/ (map) – zoek daar de map /wordpress-seo/ en verwijder die map met alle inhoud. Daarna kan je terug Yoast SEO installeren via het WordPress Dashboard.

    Wat de echte fout is bij het vertalen ga je moeten zoeken via het controlepaneel van webreus of waar zij dat aanbieden, indien dat nergens te vinden is – neem dan met hun contact op.

    Je kunt ook in het wp-config.php bestand WP_DEBUG op true zetten en dan zou je ipv de kritieke foutboodschap niet zien maar de eigenlijke PHP fout: https://wordpress.org/support/article/debugging-in-wordpress/

    Thread starter kabodekens

    (@kabodekens)

    Nu zie ik dat debug wel staan, maar ik kan niets wijzigen in de php. Enig idee hoe ik dat op true kan zetten.

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Je kan wp-config.php in notepad (kladblok) of een andere app als je niet op Windows zit zoals TextEdit op Mac, om die regel aan te passen en opnieuw te uploaden, weet niet wat je bedoelt met ik kan niets wijzigen?

    Misschien is het ook beter dat iemand je helpt bij technische zaken van je site.

    Thread starter kabodekens

    (@kabodekens)

    Hallo,

    Ik weet niet hoe ik een nieuw onderwerp moet starten. Ik heb nu uitgevonden dat de kritieke fout in polylang zit, maar is er eventueel een andere plugin die ik voor woocommerce kan gebruiken om de producten te kunnen vertalen?

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    En wat is de fout precies? Draai je de meest recente polylang? Polylang gebruik ik zelf ook voor meerdere sites in beheer, en dat werkt prima. Voor WooCommerce heb je wel hun betaalde addon nodig voor WooCommerce. Als je daar hulpt bij nodig hebt, neem je best contact op met Polylang.

    WPML & Polylang zijn de meest gebruikte, er is ook nog MultilingualPress, maar dat is icm een multisite omgeving.

11 reacties aan het bekijken - 1 tot 11 (van in totaal 11)