Ondersteuning » Thema en CSS/opmaak » Kleur aanpassen

  • Opgelost engelsman

    (@engelsman)


    Geachte lezer,

    Ik kan sinds de laatste update van WordPress de achtergrond kleur van mijn site of container niet meer veranderen.
    Telkens als ik de kleur wil aanpassen en dan op publiceren druk springt deze vanzelf weer terug op de oude kleuren.
    De nieuwe kleur word dus ook niet gepubliceerd.
    Is er misschien bij de laatste update iets fout gegaan?

    mvg Peter

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

15 reacties aan het bekijken - 1 tot 15 (van in totaal 16)
  • Hallo Peter,

    Ik zie dat je het thema Weaver Xtreme gebruikt en de meest recente versie, die volgens developer compatible zou moeten zijn met WordPress 5.9

    Ik heb zelden een thema gezien die zo veel opties in de Customizer toevoegt. Om kleuren te kunnen bewerken heb ik “Options Level: Full Interface: What” gekozen. De achtergrond kleur (Colors > Wrapping Areas > Site Background Color) werkt bij mij prima.

    Guido

    Thread starter engelsman

    (@engelsman)

    Hoi Guido,

    Ik maak zelf ook gebruik van de interface:”wat” > Kleuren > omsluitende gebieden > Achtergrondkleur site en toch lukt het mij niet om de kleur aan te passen.
    De kleur die ik nu in het blokje selecteer kleur heb staan verschild zelfs met de achtergrondkleur van de site. Zie afbeelding.
    Site Afbeelding

    Ik zou dan toch denken dat het ergens fout gaat, vraag is dan alleen “waar”?

    mvg Peter

    Guido

    (@guido07111975)

    Hoi Peter,

    Ik zie in de broncode van je site dit staan:

    
    <style type="text/css" id="custom-background-css">
    body.custom-background { background-color: #604035; }
    </style>
    

    Dit betreft de standaard achtergrond instelling van de Customizer. Ooit is daar een kleur ingesteld. Deze instelling is door jouw thema uitgeschakeld, maar hij overruled blijkbaar de kleur-instelling van het thema nog wel.

    Ik zie dat je thema een eigen forum heeft, stel anders de vraag daar eens even.

    Guido

    Guido

    (@guido07111975)

    Als het forum niets oplevert kun je de “verkeerde” CSS weer overschrijven door het onderstaande toe te voegen in de Customizer op pagina “Aangepaste CSS” > “Globaal aangepaste CSS” van de de Weaver Xtreme instellingen:

    
    body.custom-background {background-color: #506BE0;}
    

    Guido

    Thread starter engelsman

    (@engelsman)

    Hoi Guido,

    Ik ga de vraag op het forum van mijn thema stellen.
    Bedankt voor de moeite die je gedaan hebt om te helpen.

    mvg Peter

    Guido

    (@guido07111975)

    Hoi Peter,

    Ik zag je bericht al op het forum staan. Vergeet niet door te geven dat die “oude” CSS ook nog geladen wordt.

    
    <style type="text/css" id="custom-background-css">
    body.custom-background { background-color: #604035; }
    </style>
    

    Guido

    Thread starter engelsman

    (@engelsman)

    Hallo Guido,

    Even een kleine update vanuit Weaver Xtreme Support.
    Er schijnt in het verleden een bug geweest te zijn betreffende de kleuren
    Maar dit zou gerepareerd zijn.
    Het is dus nog even onbekend waarom de style regel bij mij nog op de site te vinden is

    Groet Peter

    Thread starter engelsman

    (@engelsman)

    P.s

    de regel: body.custom-background { background-color: #506BE0 !important;}
    is nu toegevoegd bij de aangepaste CSS en werkt.

    ik hoop natuurlijk wel dat er een oplossing word gevonden zodat ik de kleurenkiezer weer kan gebruiken

    Guido

    (@guido07111975)

    Bedankt voor je update.

    Desnoods moet het uit de database gehaald worden, staat in de wp_options tabel met de optienaam theme_mods_weaver-xtreme. Daarin staan alle instellingen van de Customizer.

    Guido

    Thread starter engelsman

    (@engelsman)

    Hallo Guido,

    Het laatste berichtje van Weaver:

    I don’t know how that rule gets added with the latest versions of Weaver Xtreme.

    I recall dealing with the issue, and I thought it went away. I can’t find where that version of a background can be added or removed. I guess your custom css solution might be the only option at this point.
    ___________

    Nu heb ik ook bovenstaande optie van jou gelezen en gevonden.
    Heb ik wel de vraag wat mag ik wissen uit dit bestand? Zal niet alles zijn.
    Theme_Mods

    mvg Peter

    Guido

    (@guido07111975)

    Hoi Peter,

    Ik zou voor de zekerheid alleen de kleur verwijderen, dus dit stukje: 604035
    Te veel verwijderen kan weer fouten veroorzaken.

    Laat maar even weten of dit het probleem oplost.

    Guido

    Guido

    (@guido07111975)

    Aanvulling, daarvoor staat aantal tekens s:6 en dat moet je veranderen naar s:0.

    Guido

    Thread starter engelsman

    (@engelsman)

    Hallo Guido,

    Heb de aanpassingen gemaakt zoals je hebt omschreven.
    Werkt perfect!!
    Kan nu weer via de kleurenkiezer de achtergrond van de site in alle kleuren aanpassen.

    Mijn dank voor je hulp..

    mvg Peter

    Thread starter engelsman

    (@engelsman)

    p.s.

    de regel: body.custom-background { background-color: #506BE0 !important;}
    heb ik uiteraard ook gewist.

    Guido

    (@guido07111975)

    Mooi zo!

    De volledige custom CSS die in de broncode stond is ook weg, dus nu is alles zoals het hoort.

    Als je verder geen vragen meer hebt, wil je de status van dit topic dan op “opgelost” zetten?

    Guido

15 reacties aan het bekijken - 1 tot 15 (van in totaal 16)