Support » Code oplossingen gezocht » Kan map wp-content/uploads/2014/07 niet aanmaken.

  • Hallo allemaal,

    Ik ben helemaal nieuw met WordPress en heb na veel proberen eindelijk WordPress lopend. Echter, wanneer ik een bestand wil uploaden naar mijn site krijg ik de volgend fout code:Kan map wp-content/uploads/2014/07 niet aanmaken. Is de bovenliggende map beschrijfbaar door de server?

    Omdat ik niet de kennis in huis heb begrijp ik dit niet.
    kan iemand in een voor mij begrijpelijke taal mij een beetje op weg helpen?

    bedankt alvast,
    Arnold

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)
  • Zoals de foutmelding al suggereert, is de map waar de afbeeldingen worden opgeslagen [nog] niet beschrijfbaar.

    1. gebruik FTP bijv. filezilla om je site te benaderen;[zie basisinfo onderaan]
    2. FTP: ga naar de [hoofd]map waar de afbeeldingen worden opgeslagen [bijv. wp-content/uploads
    3. FTP: re-klik en kies ‘bestandsrechten’
    4. ga naar veld ‘numerieke waarde’ > vul in ‘755’
    5. vink AAN ‘toepassen op alle submappen’ >> OK
    6. controleer het resultaat

    == == ==gebruik FTP
    Download, Installeer / gebruik een FTP-programma bv. filezilla[gratis]
    http://filezilla-project.org/download.php
    om deze bestanden op de server te beheren. De server is de plek waar de webhoster jouw site draait.
    [De beheerder heeft je vast een mail / bestand / papier gegeven met de nodige inlogggegevens.]

    3. In filezilla
    a. klik ‘nieuwe site’
    !!!voorbeelden!!! gebruik de gegevens van jouw webhost

    host: server888.host.nl — !!!voorbeelden!!!
    protocol: FTP -filetransfer protocol
    encryptie: gebruik gewone FTP
    inlogtype: normaal
    gebruiker: de inlognaam / gebruiker gegeven door de webhost
    wachtwoord: het wachtwoord gegeven door de webhost
    >klik verbinden

    Als je alles correct hebt ingevoerd, verschijnt nu een scherm met twee helften: [zo niet: probeer opnieuw / bel helpdesk webhost?]

    Li-helft: JOUW desktop met je bestanden en mappen
    Re-helft: de website.

    >>> in de settings van FTP kan je aangeven dat je NOTEPAD++ als editor gebruikt >> zo kan je [in FTP] vlot bestanden aanpassen, opslaan en weer uploaden

    Zie uitleg [engels] http://www.ixwebhosting.com/hosting-manual/ftp

    Hallo,

    Ik heb hetzelfde probleem als Arnold en heb geprobeerd de stappen te doorlopen zoals beschreven door W.P. Ginfo. Dit lukt echter niet helemaal. Bij stap 2 (2.FTP: ga naar de [hoofd]map waar de afbeeldingen worden opgeslagen [bijv. wp-content/uploads) wordt gerefereerd aan de map wp-content/uploads, deze bestaat bij mij (nog)niet. Ik heb verder ook geen idee waar de afbeeldingen dan wel standaard worden opgeslagen..

    Iemand een idee hoe ik dit kan oplossen? Alvast bedankt.

    Bij de code 755 werkt het niet, wel bij 777. Ik weet niet of dit gevolg heeft voor de veiligheid van de website maar ik kan nu in ieder geval afbeeldingen uploaden.

    Arnold

    @arnold: Dat kan idd een veiligheidsrisico opleveren. Probeer eens ‘765’ of ‘766’ en test. Ook: zorg dat je zelf over voldoende rechten beschikt om bestanden te mogen uploaden [bijv. beheerder / admin.]

    @flipscht: Ontbreekt de juiste map? >>re-klik en maak ‘m zelf aan, net als in de std-windows-verkenner.

    [BTW: het is gebruikelijk om een eigen thread / vraag aan te maken 😉 ]

    Ik heb hetzelfde probleem. Sinds twee dagen kan ik geen foto’s meer uploaden en krijg dezelfde foutmelding. De rechten staan bij mij op 775. Ik heb deze op 777 gezet zonder resultaat. Ik heb hiervoor overigens ook geen aanpassingen gedaan. Ook updates van plugins lukken niet. Eén pluging geeft deze melding:

    Warning! WP Super Cache caching was broken but has been fixed! The script advanced-cache.php could not load wp-cache-phase1.php.

    The file /………/weblog/wp-content/advanced-cache.php has been recreated and WPCACHEHOME fixed in your wp-config.php. Reload to hide this message.

    Heb ook al bij mijn provider gevraagd of er op de server problemen zijn, maar tot nu toe zonder resultaat.
    Wat kan ik nog meer onderzoeken?

    Groet,
    Berend Jan

    W.P.Ginfo,
    Ik heb je raad uitgeprobeerd maar dan ik niet meer op mijn site komen, wat zijn de gevolgen als ik hem op 777 laat staan? Daarmee kan ik namelijk er wel opkomen, trouwens, mijn site is toch beveiligd met inlog/wachtwoord?

    @arnold: hebben wij wellicht dezelfde hostingprovider? Ik zit bij Antagonist.nl.

    Inmiddels is mijn probleem opgelost door mijn provider. Het betrof kennelijk een rechten-kwestie die aan hun kant veroorzaakt was.

    @arnold

    Bij de rechte ‘777’ mag iedereen lezen, schrijven en uitvoeren naar die map. Dat kan dus ook door boeven.

    Probeer het eens met de volgende waarde: ’77x’
    Dat lijkt me iets veiliger…

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)
  • Het onderwerp ‘Kan map wp-content/uploads/2014/07 niet aanmaken.’ is gesloten voor nieuwe reacties.