Ondersteuning » Algemeen WordPress » Kan map wp-content/uploads/2013/04 niet aanmaken

  • Opgelost rcvaneck

    (@rcvaneck)


    Beste Forum leden,

    Ik heb me de afgelopen dagen hier helemaal suf om gegoogeld en gepiekerd.
    Omdat het bij mijn oude host niet helemaal lekker liep, ben ik overgestapt naar een eigen VPS met DirectAdmin.

    Nu heb ik dus mijn site verhuist en is hij online.

    Alleen als ik een aanpassing wil gaan doen (pagina plaatsen gaat prima, maar een foto uploaden of een plugin bijwerken gaat niet), krijg ik steeds problemen met mijn rechten. (deze heb ik gewoon default staan op: map 755 bestand 644)

    Zoals ik al zei, kom ik er helemaal niet uit.

    Nu heb ik dus ook een schone wordpress geinstalleerd op mijn VPS welke dezelfde problemen heeft…

    Het installeren opzich ging al anders dan ik gewend was. Normaal plaatse wordpress automatisch een wp-config file, maar nu moest ik dat handmatig doen bijvoorbeeld.

    Wie o wie kan mij uit de drek slepen?

2 reacties aan het bekijken - 1 tot 2 (van in totaal 2)
  • Thread starter rcvaneck

    (@rcvaneck)

    De error die ik krijg bij een schone install is:
    Uploaden van “back-home-2-220528.jpg” is niet gelukt als gevolg van een fout
    Kan map wp-content/uploads/2013/04 niet aanmaken. Is de bovenliggende map beschrijfbaar door de server?

    Mijn .htaccess is:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    EDIT#

    Ik krijg als ik naar wp-admin/options-permalink.php ga, de melding dat ik mijn .htaccess moet aanpassen naar:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    Nu ik dit heb gedaan, bestaat het probleem nog steeds:S
    Ook blijft deze melding bestaan…

    Mijn .htaccess zit gewoon ik de public_html map

    Thread starter rcvaneck

    (@rcvaneck)

    Probleem opgelost.

    Ik heb

    <FilesMatch “\.php$”>
    AddHandler x-httpd-php53 .php
    </FilesMatch>

    aan mijn .htaccess toegevoegd, en nu lijkt hij te werken.

2 reacties aan het bekijken - 1 tot 2 (van in totaal 2)
  • Het onderwerp ‘Kan map wp-content/uploads/2013/04 niet aanmaken’ is gesloten voor nieuwe reacties.