Ondersteuning » Installatie WordPress » Ik krijg mijn website niet op de juiste URL

  • hannekebeerens

    (@hannekebeerens)


    Hoi allemaal,

    Voor mijn werk probeer ik een website te maken, heb er alleen weinig verstand van! Via mijn flexwebhosting heb ik een domeinnaam + host geregeld. Bij hen kon ik als service gelijk wordpress gebruiken en hier mee aan de slag gaan (hoefde niets op mijn computer te zetten).

    Allemaal erg gemakkelijk, alleen 1 probleem: mijn website blijft steeds maar staan op: http://www.mijnwebsite.nl/wordpress.

    Ik zou graag dat ‘wordpress’ er achter uit krijgen! Ik heb omdat alles online is gegaan dus niets op mijn computer staan en dus geen FTP programma enzo gebruikt.

    Kan iemand mij helpen?

    Bedankt!

8 reacties aan het bekijken - 1 tot 8 (van in totaal 8)
  • Dag Hanneke,

    bovengenoemd probleem kun je oplossen door in het
    .htaccess bestand in hoofdmap van je site een wijziging toe te passenn

    het bovengenoemd .htaccess bestand zal er uitzien als: (zie regel 2 en 7)

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpresss/index.php [L]
    </IfModule>

    dat moet je dus wijzigen in bijvoorbeeld:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /cms/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /cms/index.php [L]
    </IfModule>

    (cms staat voor content management system)

    Wil je je site in de hoofdmap van je webserverruimte gebruiken, dus zoiets:

    http://www.jousite.nl

    dan moet je je .htaccess bestand aanpassen zoals onderstaand:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    als je het .htaccess bestand goed insteldt met het commando
    chmod 664
    dan worden de permalinks ook direct automatisch bijgewerkt.

    Succes,
    Marinus_

    http://www.hillenga.org

    Roy

    (@gangleri)

    Marinus, het gaat niet over permalinks, maar over het verplaatsen van WP van een submap naar de root. “Moving WordPress” dus:
    http://codex.wordpress.org/Moving_WordPress

    ik was trouwens nog vergeten te vermelden dat de bestanden + de submapjes uit het mapje wordpress (die je krijgt als het bestand wat je hebt gedownload en daarna hebt uitgepakt) rechtstreeks in je hoofdmap (root) moet uploaden en NIET het mapje wordpress in z’n geheel moet uploaden naar je webruimte. Sorry voor de onvolledigheid.

    Roy, de laatste zin geeft aan dat de permalinks ook direct worden bijgewerkt en niet dat het expleciet over permalinks gaat.

    Bedankt trouwens voor de link , die had ik nog niet eerder gezien.
    Op die pagina wordt duidelijk uitgelegt hoe je een site kunt verplaatsen. Wel handig, want dan je kun er mooi een testsite naast gebruiken waarop je eerst wat kun experimenteren met plugins / themes, Dit gaat me zeker nog een keer van pas komen.

    M.v.g.,
    Marinus

    kan iemand misschien mij vertellen waar ik het htaccess kan vinden?
    ben een leek hierin

    alvast bedankt
    mvg

    Glenn

    Tony Jansen

    (@tonyjansen_nl)

    @robbergl: in de root, voor sommige ftp clients is deze hidden omdat heb bestand met een punt begint: .htaccess.

    -T.

    Ik heb daar ook een vraag over.

    Het url-adres wil ik ook anders tonen. Zoals http://www.website.nl/blog. Dus moet ik dan de regel RewriteBase /wordpress/ in .htaccess aanpassen in RewriteBase /blog/ toch?

    En moet ik in mijn dassboard het “adres van deze site (url)” ook aanpassen? Of hoef dat niet?

    Graag jullie hulp, want ik snap dat niet helemaal (en echt niet blond hoor 😉 ).

    Groetjes,
    Ingrid

    Zelfs met ‘Tonen van verborgen bestanden forceren’ heb ik nooit een .htaccess bestand in de root kunnen vinden, dus ik heb zelf het bestand gemaakt (zoals hierboven beschreven staat) en geupload. Maar nog steeds krijg ik een foutmelding als ik na de general settings naar de nieuwe url wil gaan.

    Warning: require() [function.require]: Unable to access ./wp-blog-header.php in /public/sites/www.mike-rogids.nl/index.php on line 17

    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /public/sites/www.mike-rogids.nl/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required ‘./wp-blog-header.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /public/sites/www.mike-rogids.nl/index.php on line 17

    Weet iemand wat ik dan het beste kan doen?

    Ik heb steeds het probleem dat ik bestanden en mappen helemaal niet kan vinden.

    Zo ben ik de instructies op deze pagina aan het volgen: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory, maar ik ik kan de betreffende regel niet vinden in de index.php woordenbrij.

    Nog even voor alle duidelijkheid: ik neem aan dat ik de index uit de wp-admin map moet hebben? Dat is het eerste index-bestand dat ik tegenkom.

8 reacties aan het bekijken - 1 tot 8 (van in totaal 8)
  • Het onderwerp ‘Ik krijg mijn website niet op de juiste URL’ is gesloten voor nieuwe reacties.