Ondersteuning » Algemeen WordPress » Iframe werkt niet

  • Opgelost polleke1959

    (@polleke1959)


    Hi,
    Ik ben nog een beetje een newbe (ben nu aan mijn 2e week) op WordPress.
    So far it works ok.
    Nu heb ik een PHP programma wat ik m.b.v iframe wil inladen.
    Ik gebruik de gutenberg editor kies voor het blok HTML en vul daar de iframe code in : <iframe src …..
    (ik kan de code hier niet in kopieeren, wordt automatisch weggefilterd)
    ik heb ook shortcode en [embeded] geprobeerd, maar beide werken ook niet.
    Je kan het ook inzien op wp.broos.org onder genealogie -> converteer data
    Ik krijg alleen een vierkant (border iframe). Verder niets.
    Zijn er bepaalde regels waar het php programma moet voldoen. Mag PHP uberhaupt wel?
    programma werkt prima: http://wp.broos.org/JBDateConv
    groet Jan

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

11 reacties aan het bekijken - 1 tot 11 (van in totaal 11)
  • Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Als het script op de locatie http://wp.broos.org/JBDateConv/ ook faalt, is de syntax error in je script te zoeken, en niet in je iframe …

    Thread starter polleke1959

    (@polleke1959)

    Hi Jeroen,
    Het script faalt niet, althans bij mij niet. En het werkt ook in een iframe op mijn Joomla website.
    https://www.broos.org/info-en-contact/test

    Of heb jij iets anders gezien?

    gr Jan

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Ik zie overal het volgende:

    Parse error: syntax error, unexpected '2005' (T_LNUMBER), expecting ')' in /home/vhosts/broos.org/httpdocs/mijn-software/JBDateConv/language/en.com_jbdateconv.php on line 70

    Zowel op je WP site, rechtstreeks op de URL als op je Joomla site zie ik steeds deze syntax error?

    Thread starter polleke1959

    (@polleke1959)

    ik heb het gevonden. Ik heb de source verplaatst naar een deel onder https
    En toe die source gebruikt. Nu werkt het wel.

    gr Jan

    Thread starter polleke1959

    (@polleke1959)

    Hi Jeroen,

    ik ga ff errors aanzetten. Ik zag hem bij mij nml niet.

    bedankt voor het vinden.

    Thread starter polleke1959

    (@polleke1959)

    Hi Jeroen,
    foutje in het engelse taalbestand. Zou nu goed moeten werken.

    gr Jan

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Ik zie nu inderdaad geen syntax error meer, maar zowel Firefox en Chrome laden de iframe niet in – foutmelding is:

    Firefox Can’t Open This Page

    To protect your security, http://www.broos.org will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.

    Dat komt door een CSP policy – zie:

    The loading of “https://www.broos.org/mijn-software/JBDateConv/” in a frame is denied by “X-Frame-Options“ directive set to “sameorigin“.

    Thread starter polleke1959

    (@polleke1959)

    Laad jij de iframe-source in je eigen wordpress in ? want dan kan ik me deze foutmelding wel voorstellen.
    Maar bij mij loopt het wel, zowel op Joomla als op wordpress. Maar de source JBDateConv en de beide websites zitten op de SAMEORIGIN

    gr Jan

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Nee, ik keek enkel op jouw URLs. Op Joomla lijkt het nu wel goed te gaan, maar op je WP URL nog niet – zie screenshot: https://snipboard.io/PtqlBk.jpg – je hoofddomein en een subdomein zijn trouwens 2 aparte “sites” in het opzicht van CSP.

    Hoi Jan,

    Wat je ook kunt overwegen ipv een iframe is het volgende:

    1. Upload de map met je converter naar de /wp-content map van WordPress.
    2. Installeer de Code Snippets plugin.
    3. Maak een nieuw snippet (shortcode):
    function converter_shortcode() {
    	include 'wp-content/je-map-naam/je-index-bestand-naam.php';
    } 
    add_shortcode('converter', 'converter_shortcode');

    (pas de map-naam en index-bestand-naam aan)

    4. Sla snippet op.
    5. Voeg een shortcode blok toe in de pagina editor met deze shortcode: [converter].

    Nu wordt de code direct geladen op de pagina.

    Guido

    Thread starter polleke1959

    (@polleke1959)

    Hi Jeroen,

    ik zit al 20 jaar op Joomla. daar is dit gesneden koek. Op wordpress nog maar 6 dagen. Dit zijn de tips waar ik van hou.
    Super tof.
    (nog even wat programmeerwerk, daarna ga ik zeker deze tip uitproberen)

    Ik ben nu de joomla site aan het overzetten. Moet nog 2 PHP programma’s omzetten van het Joomlaframewerk naar straight PHP8. En mijn Kunena forum naar BBPress. daarna mag de wp site over naar het main domain.

    gr Jan

11 reacties aan het bekijken - 1 tot 11 (van in totaal 11)
  • Het onderwerp ‘Iframe werkt niet’ is gesloten voor nieuwe reacties.