Ondersteuning » Code oplossingen gezocht » grijs schildje rechts in de url

  • Hallo allemaal,
    sinds vanmorgen zie ik een grijs schildje in de url balk van mijn website
    met als melding als ik er op klik:’Deze pagina probeert scripts van niet-geverifieerde bronnen te laden’
    ik heb al van alles geprobeerd maar ik krijg het niet voor elkaar.
    Als iemand mij er misschien mee wil helpen zou fijn zijn.

    Mvg,
    michel1971

13 reacties aan het bekijken - 1 tot 13 (van in totaal 13)
  • Als ik je website bekijk dan zie ik dat je onlangs een SSL Certificaat heb toegevoegd of heb verlengt. Waarschijnlijk staat er nog een oude link naar je “vorige website” toen je gebruik maakte van de http.

    Ik weet niet of je Google Chrome gebruikt, maar bij rechts klikken en dan kijken bij “Inspecteren/Element inspecteren”, zie ik dat verschillende fonts (lettertype) gebruikt die nog op de http staan. Probeer die op https te zetten zodat deze fouten worden opgelost.

    Als je deze fouten oplost, dan moeten als het goed is het schild (rechtsboven in de url) verdwijnen.

    Thread starter michel1971

    (@michel1971)

    Hoi michael,

    dankjewel voor je reactie .
    Ja ik gebruik chrome dat klopt alleen zeg je dat ik bij rechts moet klikken en dan element inspecteren maar waar moet ik rechts klikken ?
    Voor jou zal dat piece of cake zijn maar kan wel wat nadere uitleg gebruiken ๐Ÿ™‚

    Sorry, natuurlijk geen probleem!

    Als je naar je website ga, moet je op de achtergrond foto (restaurant foto zeg maar) rechts klikken. Hier krijg je dan een klein menu met “vorige/volgende, opnieuw laden” en “afdrukken”. Onderaan zie je de opties “Paginabron weergeven” en “Inspecteren”. Je moet op inspecteren klikken en Google Chrome opent een nieuw scherm in je tabblad van jouw website. Standaard kom je dan terecht op het tabblad “Elements” (je ziet dan allemaal HTML code).

    Als je naar het tabblad “Console” gaat (rechts naast het tabblad Elements), dan krijg je een lijst van je fouten (alleen als er fouten zijn). Vervolgens moet je naar het schild toe (in de url) en klikken op “Onveilige scripts laden”. Wanneer je hierop heb geklikt krijg je in het tabblad van je console fouten te zien met de melding: “Mixed Content: The page at…”

    Wanneer je deze fouten oplost, dan krijg je als het goed is niet meer het schildje rechtsboven. Ik kan zo niet zien in welk onderdeel deze fouten zitten, maar misschien dat je iets heb aan deze plug-in? Vooraf natuurlijk wel even een back-up maken van je website, voor het geval iets mis gaat!

    Als je denkt dat alles is opgelost, dan kan je teruggaan naar het tabblad “Console” (via rechts klikken –> Inspecteren). Als het goed is krijg je dan geen melding meer te zien. Om zeker te zijn kan je naar het tabblad “Secure” gaan (zelfde tabbladen rij als Elements en Console). De moet dan op “this page is secure (valid https)” staan.

    Ik hoop dat dit je verder helpt. Als je vragen heb, laat het gerust weten =)

    Thread starter michel1971

    (@michel1971)

    Hoi michael,
    ik heb van alles lopen proberen maar het is me nog niet gelukt,grrr
    enige positieve is een pingdom score van 95 maar dat schildje blijft trouw staan.
    ik snap nu wel wat je bedoelde om een element te inspecteren alleen de fouten oplossen lukt niet ๐Ÿ™
    zou jij heel misschien willen kijken als je even tijd hebt vandaag of morgen?

    Hoi Michel,

    Als ik naar je website ga, zie ik keurig een veilige verbinding zonder foutmeldingen. Het kan zijn dat je op sommige pagina’s content vanaf een niet-beveiligde verbinding inlaadt (http://), dan krijg je het grijze slotje met de melding. Wat Michael zei, klopt helemaal. Je kunt echter ook online tools gebruiken om uit te vinden welke content onveilig wordt geladen, zoals https://www.whynopadlock.com/.

    Succes!

    Jelle

    Het eerste probleem kan je wel oplossen. Je moet dan gaan naar: Dashboard (indien nodig eerst inloggen) –> Weergave –> Editor –> Style.css (meestal onderste van de rechter lijst).

    Klik vervolgens in het style.css bewerkingsscherm (dat het streepje van je muis in het scherm staat). Druk vervolgens CTRL + F. Rechtboven opent Google Chrome een zoekschermpje. Vul hier fonts.googleapis.com in. Je krijgt de resultaten vanuit dit zoekscherm te zien uit het style.css bestand. Bij deze resultaten moet je de http vervangen door https.

    Ik kan zo niet zien waar de fonts.gstatic… fouten vandaan komen. Ik weet niet of een plug-in die je op je hoofdpagina heb gelijk wordt geladen? Die zouden daar vandaan kunnen komen.

    Thread starter michel1971

    (@michel1971)

    Hallo jelle en michael
    Dankjewel voor jullie snelle reacties ๐Ÿ™‚
    dit is de fout die hij vind gechecked door de link die je me gaf jelle:
    Total number of items: 35
    Number of insecure items: 1
    Insecure URL: http://fonts.googleapis.com/css?family=Old+Standard+TT:400,700,400italic
    Found in: https://bestdeal.in.nf/wp-content/themes/diginews/style.css
    en michael als ik naar weergave ga dan staat er geen editor optie,de keuzes die ik kan maken zijn : thema,s,customizer,widgets,menu en achtergrond,ik zie nergens iets staan om bij die style css te komen:(

    Mooi dat de link geholpen heeft. Heb je wel een administrator account?

    Jelle

    Thread starter michel1971

    (@michel1971)

    wat is een administrator account jelle?
    ben niet zo,n computerheld als jullie

    Thread starter michel1971

    (@michel1971)

    ik zit nu wel in de style css via ftp
    kan ik hier oplossen waar d fout zit?

    Ja, ik weet niet wat voor FTP je gebruikt? Als je het bestand offline hebt (op de computer), dan kan je recht klikken –> Open met –> Kladblok (of eventueel met een webdesign programma als je die heb geรฏnstalleerd).

    Hier kan je dan zoeken op fonts.googleapis.com in. Je krijgt dan de resultaten vanuit dit zoekscherm te zien uit het style.css bestand. Deze kan je dan bijwerken van http naar https.

    Sla deze vervolgens weer op (let erop dat het een style.css bestand is) en upload + overschijf de bestaande versie op de server (waar je live website staat).

    Thread starter michel1971

    (@michel1971)

    ok dankje michael,
    had net ff panne….als ik naar een andere pagina wilde gaan dan maakte hij een nieuw tablad aan ,bleek me shiftknop te blijven hangen ,grrrr
    was helemaal in rep en roer lol
    ga ff proberen wat je zei
    thanks

    Thread starter michel1971

    (@michel1971)

    Jihaaaaaaaaaa ๐Ÿ˜€
    tis gelukt gasten,nu ik weet wat je bedoelde michael lukt dit me in het vervolg ook wel.
    allebij heel erg bedankt en nog een fijne avond ๐Ÿ™‚

13 reacties aan het bekijken - 1 tot 13 (van in totaal 13)
  • Het onderwerp ‘grijs schildje rechts in de url’ is gesloten voor nieuwe reacties.