Ondersteuning » Installatie WordPress » Gemaakt in mamp, geen inhoud na uploaden

  • Opgelost Barrie89

    (@barrie89)


    Hoi allen,

    Ik zit met een irritant probleem. Ik heb in Mamp een wordpress site volledig in elkaar gezet, maar nu ik heb hem geupload is geen van de pagina’s ergens te vinden – net als enkele instellingen die ik via widgets heb gedaan (adres in de footer etc.). Ook de mediabibliotheek is helemaal leeg.

    Het enige punt dat ik kan verzinnen waarop het fout kan zijn gegaan is het feit dat ik als prefix ca_ heb ingesteld (helemaal aan het begin bij het invoeren van databasegegevens etc, ik ben niet naderhand met bestanden bezig gegaan). Ik heb echter in phpmyadmin de het options bestand nagekeken en daar staat overal keurig ca_ en niet wp-, ook nergens meer localhost. De mappen en index bestanden beginnen echter wel allemaal met wp, ik weet niet of dat iets uitmaakt?

    Ik krijg geen errors of wat dan ook, ik heb echter alleen maar de demopagina die bij elke wordpress site zit en het hello world blogbericht.

    Heeft iemand enig idee waar mijn pagina’s gebleven kunnen zijn en hoe ik ze online krijg?
    Ik gebruik Scalia als theme en heb de stappen uit dit artikel gebruikt om mijn site online te zetten.

    Groeten Barrie

6 reacties aan het bekijken - 16 tot 21 (van in totaal 21)
  • Thread starter Barrie89

    (@barrie89)

    Dat is raar! Ik zal meteen even een nieuwe zip in elkaar zetten. Bij het uploaden is niets fout gegaan, ik gebruik filezilla en heb extra gelet op mislukte overdrachten. Ik heb net voor de zekerheid nog even gekeken en alle mediabestanden staan er gewoon in

    Thread starter Barrie89

    (@barrie89)

    De dingen die jij opnoemt, zoals de wp-include map en de uploads, staan er bij mijn zip overigens gewoon in. Het lijkt me alleen sterk dat Wetransfer er random bestanden uit gaat halen?

    Eva

    (@eva_b)

    Bij deze zip zat wel alles bij, vreemd.

    De installatie gaf bij mij verder geen problemen dus ik vermoed dat je best eens test of een andere installatie methode het probleem verhelpt.

    Hieronder de stappen die ik normaal volg om een locale site live te zetten:

    1. Subdomein/map op server aanmaken, nieuwe database aanmaken
    2. Volledige WP installatie kopiëren vanuit mamp naar server map
    3. Open config.php en verander de database gegevens
    4. SQL database exporteren uit mamp
    5. SQL importeren via phpMyAdmin (of andere tool voor database management)
    Een kort overzicht voor phpmyadmin (ik vind helaas geen NL versie): http://www.inmotionhosting.com/support/website/phpmyadmin/import-database-using-phpmyadmin
    Als jouw webhosting een andere database tool gebruikt zal het process gelijkaardig zijn: inloggen op de tool > zoeken naar SQL import functie.
    6. Open de wp_options tabel en verander de twee records bovenaan, siteurl en home, naar je nieuwe site URL (zonder eind /)
    7. Open je nieuwe site URL, als alles goed is verlopen zou de site nu moeten werken
    (8. URL’s in de site nakijken/updaten met een plugin zoals bv: velvet update url’s)

    Mocht er iets niet duidelijk zijn, laat het me weten 🙂

    Thread starter Barrie89

    (@barrie89)

    Zo werkt het perfect!! Hartstikke bedankt, ik sla meteen je stappenplan op 🙂

    Toch blijf ik me afvragen hoe het komt dat in de eerste instantie mediaberichten niet meekomen, maar aangezien het bij jou perfect werkte zou dit dus aan Filezilla moeten liggen?

    Eva

    (@eva_b)

    Fijn om te horen dat ’t nu werkt!

    Ik heb echt geen idee waarom de mediabestanden niet meekomen. Filezilla lijkt me vrij safe te zijn, tot hiertoe nog nooit problemen mee gehad. Best elke keer goed nakijken dat alles correct is overgezet dus. Hopelijk verloopt alles bij de volgende site zonder problemen! 🙂

    Eva

    (@eva_b)

    (Oh, zet je de topic ook even op ‘resolved’? Bedankt!)

6 reacties aan het bekijken - 16 tot 21 (van in totaal 21)
  • Het onderwerp ‘Gemaakt in mamp, geen inhoud na uploaden’ is gesloten voor nieuwe reacties.