Ondersteuning » Algemeen WordPress » Geen toegang tot admin gedeelte

  • Opgelost Erik1970

    (@erik1970)


    Sinds een week ervaart een kennis het probleem dat hij niet meer op het admin deel kan en dus niks kan doen met zijn site. Na wat rond gekeken te hebben kom ik er ook niet verder mee. Het enige wat is wel zie in de database is een voor hem onbekende gebruiker.
    Als je deze weghaalt uit de database komt deze na het verversen van de site weer terug in de database.

    Hij of het gebruikt de naam wpadminas en gebruikt e*mail@e*mail.e*m (* zelf toegevoegd)

    Komt dit van WordPress zelf of uit een Plugin of is het een hack..

    De website geeft een 403 melding met de volgende tekst

    Forbidden
    You don’t have permission to access this resource.

    Met Vriendelijke groet,

    Erik

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

15 reacties aan het bekijken - 1 tot 15 (van in totaal 17)
  • Guido

    (@guido07111975)

    Hoi Erik,

    Je zou allereerst even in de hoofdmap kunnen kijken naar het htaccess bestand, of daar iets afwijkends in staat waardoor je tegengehouden wordt zodra je naar /wp-admin wilt gaan.

    Ook kun je je hosting provider vragen of zij in hun errorlogs kunnen kijken. Of misschien kun je dit ook zelf inzien via je hosting panel.

    Valt me trouwens ook op dat je thema en sowieso de plugin WooCommerce al lange tijd niet geüpdatet zijn en dat vergroot de kans ook op eventuele conflicten en hacks.

    Guido

    Thread starter Erik1970

    (@erik1970)

    Bij de hosting provider (argeweb) kom je ook niet verder, hebben het druk en geen zin om klanten te helpen.

    Deze site is gebouwd door iets wat hun aanbieden (installatron) en wijkt voor mij af van hoe ik het doe en dat is gewoon via de install wat bij wordpress geleverd wordt en dat wijkt zo af van wat je bij hun krijgt..

    Het htaccess bestand wat in de map van deze website zit is veel kleiner dan wat op mijn website staat.

    Het htaccess bestand is voor deze site maar 10 regels groot en dat klopt volgens mij niet maar kan het ook mis hebben..

    En de site moet inderdaad bijgewerkt worden en dat heb ik vanmorgen voor een deel gedaan door de nieuwe versie via ftp er overheen te draaien.

    Erik

    Guido

    (@guido07111975)

    Hoi Erik,

    Installatron is op zich een mooie tool want je kunt heel makkelijk een WordPress installatie opzetten en beheren. Ik ga ervan uit dat je via Installatron ook geen toegang krijgt tot het dashboard van de site?

    De standaard htaccess code begint met # BEGIN WordPress en eindigt met # END WordPress.

    Je zou de plugin map nog even bij langs kunnen gaan, als daar een security plugin in staat kan ook die deze blokkade veroorzaken.

    Guido

    Thread starter Erik1970

    (@erik1970)

    Hoi Guido,

    Ik krijg inderdaad op geen enkele manier toegang tot het dashboard van de site.

    De security plugin is niet aanwezig daar kan het niet aan liggen.

    Ik zoek nog even verder met zoeken en kijken waarom 1 user steeds terug komt nadat ik die verwijderd heb uit database.

    Als je niet op het dashboard kan is er weinig te herstellen of aan te passen.

    Erik

    Thread starter Erik1970

    (@erik1970)

    De standaard htaccess code begint met # BEGIN WordPress en eindigt met # END WordPress.

    Het htacces bestand wat er nu op staat begint en eindigt daar niet mee.
    Als ik die verwijder en vervang met een htacces bestand uit een verse site waar het wel in staat wordt het overschreven door een ander waar het weer niet in staat.
    Als ik het helemaal verwijder dan wordt er een nieuwe aangemaakt die gelijk is aan hetgeen wat er nu al op staat.

    Blijft raar…

    Guido

    (@guido07111975)

    Hoi,

    Kun je de inhoud van je htaccess hier delen?

    Guido

    Thread starter Erik1970

    (@erik1970)

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^(index|wp\-admin|wp\-include|wp\-comment|wp\-loader|wp\-corn\-sample|wp\-logln|output|about|admin|randkeyword|readurl|wp\-ver).php$ – [L]
    RewriteRule ^.*\.[pP][hH].* index.php [L]
    RewriteRule ^.*\.[sS][uU][sS][pP][eE][cC][tT][eE][dD] index.php [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . index.php [L]
    </IfModule>

    Guido

    (@guido07111975)

    Hoi,

    Dat ziet er niet goed uit. Als je een check doet op deze site zie je dat in de broncode foute content staat.

    Dus de site is gehacked. Als na verwijderen van gebruiker/htaccess direct een nieuwe gebruiker/htaccess toegevoegd wordt is dus ergens een script actief die dit doet. Dat script kan overal staan, maar vaak in het thema. Dus update die sowieso (via FTP bijvoorbeeld). Of als dat niet kan, ga alle bestanden bij langs.

    Guido

    Thread starter Erik1970

    (@erik1970)

    Hoi,

    Het probleem zit in het thema, heb het via phpmyadmin gewijzigd in een ander thema en ook de terug komende user verwijderd die zoals het zich laat aanzien niet meer terug komt
    Dat is 1 nu nog toegang krijgen tot het dashboard en zoeken waar het zit in het thema..

    Erik

    Thread starter Erik1970

    (@erik1970)

    Het zit nog dieper…
    Uithuilen en opnieuw beginnen ?

    [good@ public_html]$ wp core version
    6.0.3
    [good@ public_html]$ wp core verify-checksums
    Warning: File doesn't verify against checksum: index.php
    Warning: File doesn't verify against checksum: wp-config-sample.php
    Warning: File doesn't verify against checksum: license.txt
    Warning: File doesn't verify against checksum: wp-includes/images/crystal/license.txt

    Warning: File should not exist: wp-includes/images/smilies/.htaccess
    Warning: File should not exist: wp-includes/images/wlw/.htaccess
    Warning: File should not exist: wp-includes/images/crystal/.htaccess
    Warning: File should not exist: wp-includes/images/.htaccess

    Guido

    (@guido07111975)

    Hoi Erik,

    Voor de zekerheid het thema ook uit de map wp-content halen. En voor de zekerheid eerst downloaden naar je pc (mocht je hem ooit nog nodig hebben).

    Je gaf eerder door dat je de nieuwe versie van WordPress over de oude versie hebt gezet via FTP. Je kunt beter WordPress eerst volledig verwijderen via de bestandsmanager van je hosting account of FTP en ZONDER bestand wp-config en ZONDER de map wp-content. En dan de nieuwe versie ZONDER de map wp-content uploaden.

    Guido

    Thread starter Erik1970

    (@erik1970)

    Hoi Guido,

    Gedaan hoe jij het beschreef en voor nu doet alles het weer, het thema test is later op een synology om te kijken wat het daar doet en of hij veilig is.

    Heb nu wel alle optie die er volgens mij zijn binnen wordpress aangezet.
    Site is niet van mij en de bezitter nam het niet zo nauw met updates. Hoop als alles bijgewerkt is dat die dat wel doet. Heb ook de auto update functie voor hem aangezet..

    Bedankt voor de hulp..

    Erik

    Thread starter Erik1970

    (@erik1970)

    Nog even laten scannen op andere site zonder hem te activeren en daar kwam naar voren dat het in de functions.php zit..

    Guido

    (@guido07111975)

    Hoi Erik,

    Bedankt voor je update en mooi dat het opgelost lijkt te zijn.

    Bestand functions van je thema bedoel je?
    Hopelijk kun je een nieuwe versie ervan krijgen want het betrof een premium thema dacht ik.

    Thread starter Erik1970

    (@erik1970)

    Hoi Guido

    Ik zag dat er update was maar weet niet meer waar en kan het ook niet terug vinden.

    Het zat inderdaad dat in funtions van het theme. Heb de foute regels verwijderd en nog een keer een scan gedraaid en nu lijkt goed te zijn. De site lijkt het weer te doen dus hopen dat het zo blijft. Alles is bijgewerkt maar zie de auto update niet terug bij plugins ect. Bij mijn eigen site staat rechts een kolom waar je kan kiezen en ook bij de bulk acties is het niet te zien. Kan er ook aan liggen dat de site is opgezet met installatron of dat agreweb dat niet ondersteunt.

    Ik heb mijn eigensite gewoon met de install gedaan omdat ik niet zo hou van dat voorgekauwde. Heb hem nu ondergebracht bij transip…

    Kom er misschien nog wel achter waarom dat daar niet werkt.

    Erik

15 reacties aan het bekijken - 1 tot 15 (van in totaal 17)