Support » Installatie WordPress » Fout bij connecten Database

  • Hallo,

    Ik ben nieuw met het gebruik van WordPress. Ik ben bezig het te installeren en heb alles op m’n server gezet. Echter wanneer ik dan kijk in het admin gedeelte, wordt er geen connectie gemaakt met de database wordt aangegeven.
    http://wordpress.refreshonlinemarketing.nl/wp-admin/install.php

    Ik heb dit laten controleren door de provider (Byte in dit geval). Zij konden met dezelfde gegevens wel connecten. Wat gaat er dan fout?

    Ik heb ’t idee dat het aan deze instelling ligt:

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘localhost’, ‘localhost’);

    Bij het aanmaken van de database kreeg ik het volgende door als server(hostname): dbint039286, maar ook dit invullen op de positie van localhost blijkt niet voldoende.

    Kan iemand mij op het juiste pad zetten?

    Alvast bedankt! (en goede jaarwisseling!)

12 reacties aan het bekijken - 1 tot 12 (van in totaal 12)
  • Deze had je waarschijnlijk al gevonden?
    http://codex.wordpress.org/Editing_wp-config.php

    Dank voor je antwoord. Die pagina ken ik inderdaad. Mijn hositingprovider Byte geeft aan dat zij 2000 WP websites hosten, dus hoop dat iemand mij kan helpen die ook WP bij Byte heeft draaien.

    Localhost werkt bij hen idd niet. Maar ook het invullen van dbint039286 is niet de oplossing.

    Iemand een idee?

    Ik zou de helpdesk van Byte even contacten.

    Dat heb ik reeds gedaan. Zij kunnen mij ook niet verder helpen.

    Ze geven aan dat zij wel met de database contact kunnen maken en verwijzen naar dit forum, gezien zij achten dat het in mijn wp-config file zit.

    Moderator Remkus de Vries

    (@defries)

    Sleutelbeheer WordPress NL

    Kastje > Muur gedrag van Byte. Zij horen je te vertellen op welke lokatie hun databaseserver beschikbaar is. Theoretisch zou het ook ergens in je admin gegevens van je domeinregistratie – die je ongetwijfeld ook via hun hebt – staan.

    Ga het nog maar eens aan hen vragen. Behoorlijk kastje > muur effect dit ๐Ÿ™

    Ik zal hun reactie weer delen op dit forum.

    In mijn verwijzing worden wat database namen genoemd. Jouw host staat er toevallig niet tussen? Of iets anders wat er bekend uit ziet uit de stukken die je bij je aanmelding hebt gehad?

    De host in de lijst staat er niet tussen.

    Ik heb inmiddels antwoord van Byte:

    Natuurlijk weten we dat, dat staat ook onder instellingen > databases in het service panel. De hostname waarmee je vanuit ons netwerk kan verbinden met de databaseserver is dbint039286, vanuit thuis is het dbext039286.bytenet.nl.

    Bij ons is het geen localhost omdat localhost het zelfde betekent als “de machine waarmee ik nu verbonden ben”, bij veel hosts werkt dat omdat zij de webserver en de databases op 1 server hebben staan. Bij ons zijn het losse servers dus kan je niet met localhost verbinden (er is immers geen mysql op onze webservers geinstalleerd).

    Ik heb nu in wp-config.php diverse varianten geprobeerd met zowel dbint en dbext en het cijfer. Teven met de achtervoeging van bytenet.nl, maar ben nog niks opgeschoten ๐Ÿ™

    Gewoon even voor de zekerheid, maar je hebt DB_HOST gewoon laten staan hรจ? En je weet 100% zeker dat je een database hebt aangemaakt, een gebruiker toegekend en dat de gegevens die je in WP config hebt staan, kloppen?
    Ik vraag dit om te voorkomen dat je denkt dat WP je database aanmaakt. Dit moet allemaal al gebeurd zijn voor je kunt beginnen met installeren.

    Finally… Ik ben er uit. Volgens mij is ’t niet helemaal handig geweest van mezelf en had ik ’t kunnen weten.

    Wat er in de standaard wp-config.php staat zijn twee values die moeten worden ingevuld bij elk veld. Ik had ze beiden aangepast.
    Bijvoorbeeld:

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘db039286_wordpress’, ‘db039286_wordpress’ );

    Maar dit moest als volgt:

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘db039286_wordpress’ );

    Dus bij alle items die moesten worden ingevuld, moet de eerste ‘ ‘ de standaaardwaarde zijn en de tweede ‘ ‘ jouw gegevens vanuit de database.

    Roy heeft me toch wel op ’t goede spoor gezet door te vragen of ik DB_HOST had laten staan. Thanks!

    Is het normaal dat je deze pagina te zien krijgt:
    http://wordpress.refreshonlinemarketing.nl/wp-admin/install.php?step=2

    De eerste foutmelding ziet er als volgt uit:

    WordPress database error: [Unknown collation: ‘utf8’]
    CREATE TABLE pspwp_users ( ID bigint(20) unsigned NOT NULL auto_increment, user_login varchar(60) NOT NULL default ”, user_pass varchar(64) NOT NULL default ”, user_nicename varchar(50) NOT NULL default ”, user_email varchar(100) NOT NULL default ”, user_url varchar(100) NOT NULL default ”, user_registered datetime NOT NULL default ‘0000-00-00 00:00:00’, user_activation_key varchar(60) NOT NULL default ”, user_status int(11) NOT NULL default ‘0’, display_name varchar(250) NOT NULL default ”, PRIMARY KEY (ID), KEY user_login_key (user_login), KEY user_nicename (user_nicename) ) DEFAULT CHARACTER SET utf8 COLLATE utf8

    Wanneer ik al die foutmeldingen dan onderaan de pagina negeer en wil inloggen, krijg ik een inlog scherm. Ik vul mijn gegevens in, maar er gebeurt niks. Heeft dat te maken met deze waslijst aan foutmeldingen? (ik schrok ervan zoveel!)

    Het lijkt erop dat de Database tabellen niet aangemaakt zijn omdat de collation niet herkend wordt. Misschien moet het het UTF-8 zijn (spelling/hoofdletters) Check met dehelpdesk van Byte.

12 reacties aan het bekijken - 1 tot 12 (van in totaal 12)
  • Het onderwerp ‘Fout bij connecten Database’ is gesloten voor nieuwe reacties.