Support » Plugin vragen » Facebook scrape lukt niet

  • Beste,

    Mijn website is al geruime tijd klaar voor lancering, maar het lukt me maar niet om ervoor te zorgen dat de link goed te zien zijn op Facebook.
    Ik gebruik de plugin SEO by Yoast, maar ook dit blijkt niet te helpen.

    Als ik mijn website wil delen guidoleurs.org op facebook zie ik niet de correcte titel en er is geen plaatje bijgevoegd, terwijl ik dit wel zo ingesteld heb in Yoast SEO.
    Ook als ik de Facebook share buttons gebruik onder een blog post krijgt dit blog de titel ‘404 not found’ mee op FB terwijl de link wel werkt.

    Ik heb de FB debugger gebruikt en krijg hier twee meldingen:

    Critical Errors That Must Be Fixed
    Bad Response Code: URL returned a bad HTTP response code.

    Errors That Must Be Fixed
    Missing Required Property: The ‘og:type’ property is required, but not present.

    Weet iemand hoe ik dit het beste op kan lossen? Het is erg van belang dat deze website z.s.m. gelanceerd gaat worden.

    Groeten en alvast bedankt!
    Guido

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)
  • Als het nog niet opgelost is lees dan dit Stack Overflow draadje. Kan een url probleem zijn en wellicht moet de / aan het einde verwijderd worden. Een andere probleem kan zijn dat

    og:type' property

    inderdaad niet wordt toegevoegd en dan kan deze er met wat code alsnog geplaatst worden.

    Bedankt voor je antwoord. Helaas is het probleem er inderdaad nog steeds. Misschien een stomme vraag, maar hoe verwijder je de / aan het einde? Als ik naar guidoleurs.org ga komt deze er automatisch achter. In General Settings staat de website namelijk als: http://guidoleurs.org (dus zonder /). Dus dat lijkt goed te zijn.

    Als ik in de header.php van mijn theme kijk staan er inderdaad geen meta-tags in die met OG te maken hebben.. Dat zou Yoast SEO of the Accesspress Social Share (die standaard in de theme gebakken zit) moeten doen, maar ook als ik Yoast uitzet gebeurt dit niet.
    Enige oplossing hoe ik dit eventueel handmatig kan doen o.i.d.?

    Probeer ook nog met / en scrape dan nog een keer via de Facebook Debugger. Als ik nu scrape zie ik inderdaad dezelfde error en FB voegt na scrapen / aan de url toe. Dus de moeite van het proberen waard.

    En als ik opvraag wat Facebook ziet is dat dit:

    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
    <html>
    <head><meta http-equiv="content-type" content="text/html; charset=utf-8"></head>
    <body><p>Apache is functioning normally</p></body>
    </html>

    Dit zou de index.html kunnen zijn. Dit is namelijk een standaard index bestand wat vaak bij Apache erop wordt gezet. Hoe is de index hierarchie op de server opgezet? Wellicht index.html alleen of index.html eerst en dan index.php? Er moet een reden zijn dat dit bestand wordt gepakt en niet de daadwerkelijke index.php van WordPress. Maar zoals gezegd eerst met / proberen.

    Bedankt weer voor het nuttige antwoord! Helaas heeft de / toevoegen niet veel uitgehaald. Ik krijg overigens als ik een blog post in de FB debugger stop de volgende melding:
    Critical errors that must be fixed: URL returned a bad HTTP response code.

    Van de server heb ik helaas niet zo veel kennis. Hier is wat ik je kan vertellen over hoe ik het op een server zie staan:
    Er staan twee websites van me op die server in een gedeeld hosting pakket. Als ik mijn directory op de server bekijk zie ik de standaard mapjes waaronder: ‘domains’ en ‘public_html’. Mijn host gaf aan dat ik mijn guidoleurs.org in de directory domains –> guidoleurs.org moest zetten (hier is het domein ook aan gekoppeld). Als ik deze directory open zie je daar: ‘public_html’, ‘public_ftp’, ‘stats’ etc. In de public_html staat de wordpress documenten met o.a. ‘index.php’, alle submappen en ‘.htaccess’.

    Kun je hier iets uit halen wat voor problemen kan zorgen? Opvallende overigens is dat als ik mijn website deel op LinkedIn er wel een afbeelding etc. bij komt.

    Ik zou de server in moeten kunnen om in ieder geval de hele stuctuur te zien en wat zaken te testen. Wellicht ook met de hoster moeten overleggen.

    Maar hier een paar vragen:

    • is er een index.html in de root (public_html)? Stond daarin wat FB meldde?
    • wat staat er in de .htaccess?
    • Heb je de auteurs van het thema al om hulp gevraagd?
    • Heb je de hoster de problemen doorgegeven?

    Hmm geen idee hoe dat werkt, iemand toegang geven. Ik kan dit in ieder geval wel naar hem doorspelen.
    – In de root directory van mijn directory op de server staat een public_html map die, als ik erop klik, me meteen naar de public_html map van de andere website die ik in de ‘domains’ map heb staan. In die public HTML staat de volgende (tijdelijke) website: http://www.oceaware.org.
    In de domains map zit echter ook de website guidoleurs.org (waar het hier om gaat) met daarin een eigen public_html en daar zit naast de index.php van WordPress geen index.html.

    – in de .htaccess staat het volgende:

    # WordPress SEO - XML Sitemap Rewrite Fix
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^sitemap_index\.xml$ /index.php?sitemap=1 [L]
    RewriteRule ^([^/]+?)-sitemap([0-9]+)?\.xml$ /index.php?sitemap=$1&sitemap_n=$2 [L]
    </IfModule>
    # END WordPress SEO - XML Sitemap Rewrite Fix
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    – Ik heb de auteurs van de theme al om hulp gevraagd, maar zonder succes. Zij wijzen naar de server.. oid.
    – Hoster heb ik doorgegeven, maar ik zal hem even verwijzen naar dit forum.

    Het lijkt erop dat je

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    tig keer er hebt staan in die .htaccess. Een keer is voldoende en het zou kunnen dat meerdere keren dezelfde melding problemen veroorzaakt.

    En dat er in de map public_html een domains map zit met daarin weer een aparte map public_html is wel een aparte structuur.Ik zou de vhosts file moeten zien of dit wel goed werkt zo.

    Ik heb de .htaccess zojuist helemaal leeg gemaakt en de permalink settings aangepast, maar dat helpt ook niet. Helaas.

    Use .htaccess to solve the issue

    TodayCut

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)
  • Het onderwerp ‘Facebook scrape lukt niet’ is gesloten voor nieuwe reacties.