• Hallo,

    Ik heb de zoekfunctie gebruikt om te zoeken naar een oplossing voor mijn probleem, dat kon ik niet vinden. Mocht dat er toch wel staan, mijn excuses dan.

    Ik heb het WordPress LeesMij bestand gevolgd. Als ik mijn website open dan zie ik:
    ‘Error establishing a database connection’.

    Dit zijn mijn MySQL settings in wp-config.php:

    ——————–
    define(‘DB_NAME’, ‘21622blog’); // De naam van de database die je aangemaakt hebt voor WordPress
    define(‘DB_USER’, ‘21622admin’); // De gebruikersnaam die je aangemaakt hebt voor WordPress
    define(‘DB_PASSWORD’, ‘hier staat dan het wachtwoord wat hoort bij mijn username van de db’); // …en je wachtwoord
    define(‘DB_HOST’, ‘localhost’); // 99% kans dat je dit NIET hoeft te veranderen
    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);
    ——————–

    En als ik ga naar ‘/wp-admin/install.php’ dan krijg ik gewoon topics te zien en gebeurd er verder niets.

    Hopelijk kan iemand mij helpen.

5 reacties aan het bekijken - 1 tot 5 (van in totaal 5)
  • “define(‘DB_HOST’, ‘localhost’); // 99% kans dat je dit NIET hoeft te veranderen”

    Jij hoort vast bij die ene procent die het wel moet veranderen. Van je host heb je daar ook een opgave van gekregen.

    Thread starter davidleijstra

    (@davidleijstra)

    je hebt inderdaad helemaal gelijk. dom dat ik daar niet aan gedacht heb.
    het werkt nu!

    bedankt voor je reactie!!

    Graag gedaan. Suc6 er verder mee.

    Even aanhaken op dit probleem:

    Ik krijg namelijk dezelfde melding:

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can’t contact the database server at localhost. This could mean your host’s database server is down.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?

    If you’re unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums

    Ik heb MAMP geintstalleerd op een mac (10.4.11 PPC):
    Apache op poort 80
    MYSQL op poort 3306

    Ik de root van mijn sites verwezen naar de sites folder van mijn profiel: /Users/stijlgeit/Sites

    In mijn wp-config.php staat:

    <?php
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘WP_test’); // The name of the database
    define(‘DB_USER’, ‘mijnusername‘); // Your MySQL username
    define(‘DB_PASSWORD’, ‘mijnwachtwoord‘); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);

    // Change SECRET_KEY to a unique phrase. You won’t have to remember it later,
    // so make it long and complicated. You can visit https://www.grc.com/passwords.htm
    // to get a phrase generated for you, or just make something up.
    define(‘dit is mijn eerste cms avontuur’, ‘put your unique phrase here’); // Change this to a unique phrase.

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);

    /* That’s all, stop editing! Happy blogging. */

    define(‘ABSPATH’, dirname(__FILE__).’/’);
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    Bij mij dus ook de vraag, wat doe ik niet goed? Is het ook de het pad van de host of toch iets anders.

    Ps er wordt gesteld in het 3 stappenplan dat je een database én een MYSQL database moet aanmaken… hoe zit dat eigenlijk?

    alvast dank .. Stijlgeit

    ps ik heb inmiddels de poorten in MAMP op default gezet en het pad verwijst nog steeds naar:

    /Users/stijlgeit/Sites

    Poorten staan nu dus op:
    Apache op poort 8888
    MYSQL op poort 8889

    Ik heb dit teruggezet omdat ik anders niet in phpMyadmin kom via http://localhost:8888/MAMP/frame.php?src=%2FphpMyAdmin%2F

    … heeeelp dus 😉

5 reacties aan het bekijken - 1 tot 5 (van in totaal 5)
  • Het onderwerp ‘Error establishing a database connection’ is gesloten voor nieuwe reacties.