Ondersteuning » Algemeen WordPress » Er heeft zich een kritische fout voorgedaan op je site.

  • Hallo!

    Na update via Webreus van PHP 5.6 naar 7.4 kan ik niet meer op mijn site. Wat nu? Hoe kom ik aan logfiles? Tips en advies zeer welkom.

    Groet

    UPDATE: mail ontvangen; jammer genoeg werkt link voor hestelmodus niet; krijg lege pagina na inloggen.

    inds WordPress 5.2 is er een ingebouwde functie die herkent wanneer een plugin of thema een fatale fout veroorzaakt op je site en die je op de hoogte stelt met deze automatische e-mail.

    In dit geval heeft WordPress een probleem gevonden met één van je plugins: 1 Flash Gallery.

    Bezoek eerst je site (http://www.vernede.nl/) en kijk of er zichtbare problemen zijn. Bezoek daarna de pagina waar de fout was gevonden (http://www.vernede.nl/wp-admin/admin-ajax.php) en kijk of er zichtbare problemen zijn.

    Neem contact op met je host voor hulp bij het verder onderzoeken van dit probleem.

    In het geval dat je site kapot lijkt te zijn, en je het dashboard niet op de normale manier kunt benaderen, heeft WordPress nu een speciale “herstelmodus”. Deze laat je op een veilige manier op je dashboard inloggen om het probleem verder te onderzoeken.

    xxx

    Om je site veilig te houden verloopt deze link over 1 dag. Maak je daar maar niet druk om, er wordt een nieuwe link naar je gestuurd wanneer het probleem zich weer voordoet nadat de link is verlopen.

    Als je hulp nodig hebt met dit probleem, kan je gevraagd worden om de volgende informatie:
    WordPress versie 5.5.1
    Huidig thema: Twenty Seventeen (versie 2.4)
    Huidige plugin: 1 Flash Gallery (versie 1.7.9)
    PHP versie 7.4.9

    Foutdetails
    ===========
    Een fout van het type E_COMPILE_ERROR werd veroorzaakt op regelnummer 160 van het bestand /var/www/clients/client11018/web1439/web/wp-content/plugins/1-flash-gallery/includes/ajax/upload.php. Foutmelding: ‘continue’ not in the ‘loop’ or ‘switch’ context

    • Dit onderwerp is gewijzigd 1 jaar, 8 maanden geleden door RVernede.
    • Dit onderwerp is gewijzigd 1 jaar, 8 maanden geleden door RVernede.

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

8 reacties aan het bekijken - 1 tot 8 (van in totaal 8)
  • Op basis van die foutmelding lijkt de fout te komen vanuit de 1-flash-gallery plugin.
    Als je die via FTP of de filemanager van webreus een andere naam geeft zal de plugin zichzelf deactiveren en werkt de site waarschijnlijk weer

    Thread starter RVernede

    (@rvernede)

    Dank voor je feedback. Andere naam gegeven maar nog steeds witte pagina. Herstelmodus link nu ook dood. Op sommige pagina’s krijg ik nu Error thrown
    Call to undefined function mysql_query()

    Thread starter RVernede

    (@rvernede)

    Heb nog wel veel oude plugins in WP staan zie ik (als die data kloppen).
    Screenshot

    Zal ik de hele plugin map andere naam geven en kijken of dat helpt?

    Guido

    (@guido07111975)

    Hallo,

    Nee, want dan werken al die plugins niet meer en verlies je vast functionaliteiten van je site.
    Ik zie dat de site weer online is. Jouw site heeft wel heel veel plugins, ik raad je aan om eerst eens alle plugins die je niet persé nodig hebt te verwijderen (via het dashboard), want dat maakt eventueel troubleshooten een stukje makkelijker.

    Guido

    Thread starter RVernede

    (@rvernede)

    Had er een paar extra oude renamed en nu kan ik er weer in. Ben nu inderdaad aan het opschonen.

    Krijg nog wel bij widgets: Google_AuthException thrown

    Error refreshing the OAuth2 token, message: ‘{ “error”: “invalid_grant”, “error_description”: “Bad Request” }’

    Maar goed op de goede weg lijkt het. Thanks. Altijd even schrikken als het niet meer werkt. Is oude site met weinig/geen onderhoud er op.

    Guido

    (@guido07111975)

    Op pagina’s met een formulier (zoals hier) is nog wel sprake van een fout die veroorzaakt wordt door, volgens mij, een heel oude plugin die inmiddels ook verwijderd is van WP punt org: WP-reCAPTCHA. Als dit inderdaad de betreffende plugin is, kun je deze het best even vervangen door een alternatief.

    Guido

    (@guido07111975)

    Krijg nog wel bij widgets: Google_AuthException thrown

    Enige wat ik (aan de voorkant vd site) kan zien wat met Google te maken heeft, is de vertaalknop. Maar als ik erop klik werkt het (nog) wel gewoon.
    Of het heeft te maken met die oude captcha plugin.

    Thread starter RVernede

    (@rvernede)

    Dank je wel! Ik denk dat het tijd is voor een nieuwe site. Even kijken of er speciale themes zijn voor genealogie of plugins.

8 reacties aan het bekijken - 1 tot 8 (van in totaal 8)
  • Het onderwerp ‘Er heeft zich een kritische fout voorgedaan op je site.’ is gesloten voor nieuwe reacties.