Support » Installatie WordPress » De site ondervindt technische problemen

  • Goedemiddag iedereen

    Sinds gisterenmiddag is mijn site offline… Er komt op: De site ondervindt technische problemen.

    Ik weet niet hoe dit komt, kan iemand helpen?

    Bedankt!

    Groeten
    Nils

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

7 reacties aan het bekijken - 1 tot 7 (van in totaal 7)
  • Hoi Nils,

    Als het goed is zou je een email hebben gehad op het admin e-mailadres.
    Daarin staat de PHP foutcode en een link om in te kunnen loggen in de herstel modus.
    In die modus kan je de plugin/thema die de fout veroorzaakt deactiveren.

    Als je die e-mail niet hebt gehad dan moet je de debug modus aanzetten in de wp-config om via die weg de PHP foutcode te achterhalen.
    Vervolgens zou je dan via FTP of filemanager van de webhosting betreffende plugin/thema moeten deactiveren/verwijderen.

    Voor het aanzetten van de WP_Debug modus kan je dit artikel volgen

    Hey Richard

    Dat had ik al gedaan en krijg volgende melding:

    Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/goc/domains/goedkoopopcitytrip.be/public_html/wp-includes/wp-db.php:1645 Stack trace: #0 /home/goc/domains/goedkoopopcitytrip.be/public_html/wp-includes/wp-db.php(639): wpdb->db_connect() #1 /home/goc/domains/goedkoopopcitytrip.be/public_html/wp-includes/load.php(427): wpdb->__construct(”, ”, ”, ‘localhost’) #2 /home/goc/domains/goedkoopopcitytrip.be/public_html/wp-settings.php(120): require_wp_db() #3 /home/goc/domains/goedkoopopcitytrip.be/public_html/wp-config.php(89): require_once(‘/home/goc/domai…’) #4 /home/goc/domains/goedkoopopcitytrip.be/public_html/wp-load.php(37): require_once(‘/home/goc/domai…’) #5 /home/goc/domains/goedkoopopcitytrip.be/public_html/wp-blog-header.php(13): require_once(‘/home/goc/domai…’) #6 /home/goc/domains/goedkoopopcitytrip.be/public_html/index.php(17): require(‘/home/goc/domai…’) #7 {main} thrown in /home/goc/domains/goedkoopopcitytrip.be/public_html/wp-includes/wp-db.php on line 1645

    Ik zie dus niet welke plugin ik zou moeten verwijderen…

    Bedankt voor uw antwoord.

    Groeten
    Nils

    Btw: de mail ontvang ik niet…

    Staat er toevallig define('WP_USE_EXT_MYSQL', true);
    of iets dergelijks in je wp-config bestand?

    Het lijkt in dit geval op een probleem richting de database / webhosting configuratie

    Nee, dat staat niet in de wp-config

    Het is een risico en een gok maar wellicht kan je proberen om handmatig via FTP de bestanden van WordPress core opnieuw te installeren.
    https://wordpress.org/support/article/updating-wordpress/#manual-update
    Let er wel op dat je de wp-content map niet overschrijft/vervangt.

    Dan kan je in ieder geval uitsluiten dat een van de WordPress bestanden zelf ontbreekt of fouten bevat. Dit is niet iets wat zomaar vanzelf zou horen te gaan.

    Mocht het dan nog niet werken contact opnemen met de webhost en/of eventueel een specialist vragen die met je mee kan kijken in de achterkant bij de webhosting / bestanden van je installatie.

    Hi Richard

    Ik heb dit gedaan maar het resultaat blijft hetzelfde. De webhost wilt niet echt helpen, ze zijn geen webbouwers…

    Bedgrijp echt niet wat er verkeerd is gegaan, ik heb geen update gedaan of een nieuwe plugin geïnstalleerd.

    Zucht…

7 reacties aan het bekijken - 1 tot 7 (van in totaal 7)