Support » Algemene WordPress vragen » Database al up to date

  • Opgelost sjoerd89

    (@sjoerd89)


    Hallo allemaal,

    ik loop nu al een flinke tijd met een probleem en kom er niet uit. Mijn website krijgt het bericht :
    “Bijwerken niet nodig, Je WordPress-database is al up-to-date.” Dit is de site waar het om gaat website. Nu staat er op veel plekken op het web dat ik het bestand object-cache moet verwijderen maar die is niet aanwezig bij mij.
    Ook is het vreemd dat de website doorverwijst naar een andere website waar ik aan werk.

    Dit is wat informatie die ik kan geven:
    -htaccess van de site (gevonden in public_html/cgi-bin)

    Options -Indexes +ExecCGI
    AddHandler cgi-script .cgi .pl

    -htaccess van de site waar die naar word doorverwezen:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>
    
    # END WordPress

    -Als het goed is, is het geen multisite.
    -Het probleem is gekomen na een handmatige update via Filezilla.

    Dit is de informatie die ik U op dit moment kan geven als U meer nodig heeft kan ik dat proberen te geven.

    Nog een fijne dag,

    Sjoerd

15 reacties aan het bekijken - 1 tot 15 (van in totaal 18)
  • Bas

    (@basz85)

    Beste Sjoerd,

    Om de probleem te achterhalen, ga ik even wat vragen stellen aan u.

    Welke plugins gebruikt u op dit moment? Schakel even alle plugins uit.
    Gebruikt een Cache plugin op uw WordPress website? Total W3 Cache of andere caching plugins maken een object-cache.php in de wp-content folder aan.
    Gebruikt u een de meest recentste WordPress versie?

    Soms kan wel eens voorkomen dat er conflicten komen als WordPress geïnstalleerd wordt op deze manier (als test website): example.com/wordpress/.
    Ik zou echter kiezen voor een subdomein als test omgeving en hierdoor is de conflicten aanzienlijk kleiner: wordpress.example.com

    Het laatste redmiddel is helemaal opnieuw beginnen – in sommige gevallen.

    Vriendelijke groet,
    Bas

    Er staat letterlijk geen plugin of iets in aangezien ik een nieuwe wordpress erop gegooid heb.
    Alleen de file wp-config.php is aangepast.

    Sjoerd

    Helaas nog steeds vast, ook contact met mijn provider tot nu toe zonder succes

    Erwin van Amersfoort

    (@erwinvanamersfoort)

    Hoi Sjoerd, weet je zeker dat het wp-config.php bestand in de root van je WordPress installatie hebt staan? Als deze er daadwerkelijk staat, kun je dan eens kijken of hier de juiste database koppeling ingesteld staat?

    Ja die is aanwezig en met database instelling anders dan die van mijn andere site waar die naartoe linked. De SQL hostname ‘Localhost’ en database charset komen wel overeen van beide sites maar de database username en password zijn anders.

    Erwin van Amersfoort

    (@erwinvanamersfoort)

    Als je inlogt in WordPress, wat zie je dan bij Instellingen->Algemeen bij de opties: WordPress-adres en Siteadres? Kun je eens controleren of daar alles met kleine letter staat en of de url eindigt op /website ?

    Bij de site in kwestie kan ik hier niet komen want als ik naar de site wil word ik door verzonden naar die database pagina en daarna doorverwezen naar de andere site. Bij die site staan die website url’s gewoon goed.

    Erwin van Amersfoort

    (@erwinvanamersfoort)

    Als ik hier mijn gbr naam en ww invul schiet de site door naar het inlogscherm van mijn andere site. Ook al vul ik de juiste gegevens in geeft die een fout omdat die denkt dat ik probeer in te loggen bij de zilvertron site

    Erwin van Amersfoort

    (@erwinvanamersfoort)

    Wil je dan onderstaande in de wp-config.php toevoegen:
    define(‘WP_HOME’,’http://sjoerdjonker.nl/website/&#8217;);
    define(‘WP_SITEURL’,’http://sjoerdjonker.nl/website/&#8217;);

    <?php
    /**
    * The base configuration for WordPress
    *
    * The wp-config.php creation script uses this file during the
    * installation. You don’t have to use the web site, you can
    * copy this file to “wp-config.php” and fill in the values.
    *
    * This file contains the following configurations:
    *
    * * MySQL settings
    * * Secret keys
    * * Database table prefix
    * * ABSPATH
    *
    * @link https://codex.wordpress.org/Editing_wp-config.php
    *
    * @package WordPress
    */

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘NOTSHOWINGFOROBVREASON’);

    /** MySQL database username */
    define(‘DB_USER’, ‘NOTSHOWINGFOROBVREASON’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘NOTSHOWINGFOROBVREASON’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8′);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);

    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define(‘AUTH_KEY’, ‘l`
    ZKvi5:j5#ZjU3}:q>/7,&u)?7VBSr/ji],ss>acmsfn3 Nrx=yU+VnHV{FcvYR’);
    define(‘SECURE_AUTH_KEY’, ‘@pb7$`2V31zfS@Q%YMFT;rK;NhP(wNL06NOu;;W b+_+uLr8J3krP?maB#_oEX~e’);
    define(‘LOGGED_IN_KEY’, ‘|P{mxNOxY|/vq>nYP9tIYJ/-o%#G0_2+q}C)XV[?-ni4;c#)=/5:N1%UQ3(uMv!W’);
    define(‘NONCE_KEY’, ‘d&-YBC4nxy0n^Sa5mR~3%-f~#MYfv/!Ux174YkpJ7=!KOMXY7R0Jf.S$t/PAq^<D’);
    define(‘AUTH_SALT’, ‘TWw>xNW%wJ7&z]. oBBR5`8${hVN=.ZcdjRnZedXK&0zr,6 ><|<Ca],BO(zUY!>’);
    define(‘SECURE_AUTH_SALT’, ‘a38;W%aWF~x4cP.kZF7p^7t<?6[11)aB3-<af:c4DNXWKT1jsV/TV6Y];$r+h2′);
    define(‘LOGGED_IN_SALT’, ‘*#I[^o:Z?6,kD|0Ir6B]QZE*)jp?ek%<?U`AS?EBTVh(2=HVHjrlPn8H<)BJl>uf’);
    define(‘NONCE_SALT’, ‘;8rXTz;hOJEe0awk(/N?@?!ZX9Qadz0Qbmcl=Z!B]L6&[x9!#o.IMH&hFc23Fl,1’);
    define(‘WP_HOME’,’http://sjoerdjonker.nl/website/’);
    define(‘WP_SITEURL’,’http://sjoerdjonker.nl/website/’);

    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each
    * a unique prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = ‘wp_’;

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    *
    * For information on other constants that can be used for debugging,
    * visit the Codex.
    *
    * @link https://codex.wordpress.org/Debugging_in_WordPress
    */
    define(‘WP_DEBUG’, false);

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

    This will get me
    Parse error: syntax error, unexpected ‘:’ in /home/(DATABASENAME)/domains/sjoerdjonker.nl/public_html/website/wp-config.php on line 59

    • Deze reactie is gewijzigd 4 jaren geleden door sjoerd89.
    Erwin van Amersfoort

    (@erwinvanamersfoort)

    Check even de quotes in de aanpassing die je net gedaan hebt. Waarschijnlijk zit daar een conflict.

    Hier ga je even langs mij heen de quotes?

    Erwin van Amersfoort

    (@erwinvanamersfoort)

    De enkele quotes om de URL’s in onderstaande staan volgens mij niet helemaal goed.
    define(‘WP_HOME’,’http://sjoerdjonker.nl/website/’);
    define(‘WP_SITEURL’,’http://sjoerdjonker.nl/website/’);

    Probeer die enkele quotes even te wijzigen naar dubbele quotes, dus:
    define(“WP_HOME”,”http://sjoerdjonker.nl/website/&#8221;);
    define(“WP_SITEURL”,”http://sjoerdjonker.nl/website/&#8221;);

    Dit werkt maar zelfs nu nog word ik bij het inloggen doorverwezen naar de andere site.

15 reacties aan het bekijken - 1 tot 15 (van in totaal 18)
  • Het onderwerp ‘Database al up to date’ is gesloten voor nieuwe reacties.