Support » Plugin vragen » Contactform 7

  • Goedenavond,

    Ik maak sinds een jaar gebruik van contactform 7 en dat werkte tot de update van 5.4 prima.

    Hierna ontstond het probleem dat bij het drukken op de verzendknop (submit) in een formulier deze knop twee keer aangeklikt moet worden om het formulier daadwerkelijk te versturen.

    Na de eerste keer verschijnt een langwerpige rechthoek waarin normaliter een tekst komt te staan in de trend van ‘uw formulier is verzonden'(of iets dergelijks afhankelijk van wat men heeft ingesteld) terwijl dat dus al gelijk zou moeten gebeuren. Na de tweede keer klikken wordt het formulier wel verzonden en komt de boodschap wel in beeld zoals het de eerste keer zou moeten gebeuren. Inhoudelijk heb ik niets veranderd aan de inhoud van de formulieren en is het probleem gekomen na het updaten. Ook na de update van vandaag (5.5.1) is het resultaat hetzelfde.

    Wie kan mij helpen a.u.b.

    m.vr.gr.

    Leo

15 reacties aan het bekijken - 1 tot 15 (van in totaal 15)
  • Guido

    (@guido07111975)

    Hoi Leo,

    Bedoel je WordPress versie 5.5.1? Dat is een vrij oude versie inmiddels.

    Heb je ook een link naar je contactpagina?

    Guido

    Thread starter leolivenl

    (@leolivenl)

    Hoi Guido. Dank voor je bericht.

    Nee hoor. WordPress is geheel up-to-date.

    Ik bedoel versie 5.5.1 van Contactform 7

    Het gaat om de website van onze honk- en softbalvereniging maar daar is inhoudelijk aan de pagina niets aan te zien.

    Hier de link naar een contactformulier in dit geval voor een kennismaking.

    https://scvlaardingenholy.nl/algemeen/kennismaken/

    Zo zijn er nog een paar maar allemaal met hetzelfde probleem.

    Na alles te hebben ingevuld druk je op verzenden maar dan moet je het nog een keer doen om uiteindelijk te zien dat het verzonden is (en dat is dan ook zo, want dat komt dan bij mij binnen als webmaster.

    Als ik versie 5.3 van cf7 installeer dan werkt het dus wel.

    Dus er is iets inhoudelijk in de plug-in veranderd waardoor dit probleem is ontstaan.

    • Deze reactie is gewijzigd 1 week, 1 dag geleden door leolivenl.
    • Deze reactie is gewijzigd 1 week, 1 dag geleden door leolivenl.
    Guido

    (@guido07111975)

    Hoi,

    Ik zie dat er JavaScript / jQuery wordt gebruikt tijdens laden vd site, dus is mogelijk een conflict met je thema of een plugin.

    Je hebt een kopieerbeveiliging actief, kun je die eens uitschakelen zodat wij in de broncode van je site kunnen zoeken naar eventuele fouten?

    Guido

    Thread starter leolivenl

    (@leolivenl)

    Hij staat uit.

    Maar heb de plug-in waarmee het wel werkte 7.5.3 wel geïnstalleerd.

    • Deze reactie is gewijzigd 6 dagen, 18 uren geleden door leolivenl.
    Guido

    (@guido07111975)

    Hoi,

    Wat heb je teruggezet? Formulier werkt nu wel in 1 keer merk ik.

    Guido

    Thread starter leolivenl

    (@leolivenl)

    Ja dat klopt. Ik heb versie 7.5.3 van CF7 terug gezet want die werkt wel.

    Ik zal de nieuwe plug-in installeren en dan kan je zien wat er gebeurd.

    Ik zet deze wel graag uiterlijk zondag terug want anders hebben we kans dat er iets gemist wordt.

    Ik zal je mail in de gaten houden zodat ik kan zien wanneer je reageert.

    Dank je.

    gr.

    Leo

    Guido

    (@guido07111975)

    Hoi Leo,

    Net even nieuwe test gedaan, er komt geen notificatie in de gele balk te staan die onderaan verschijnt als je iets verkeerd invult. Ook wordt die gele balk ook getoond als je de eerste keer op verzenden drukt, maar ook als je het formulier volledig invult. Je zou de Captcha eens kunnen uitzetten, kijken of dat het probleem veroorzaakt.

    Guido

    Thread starter leolivenl

    (@leolivenl)

    Hoi Guido,

    Dat had ik al geprobeerd, maar dat loste het probleem niet op.

    gr.

    Leo

    Guido

    (@guido07111975)

    Hoi,

    Ik zie in de console van mijn browser wel een fout nadat ik op Verzenden klik:

    
    TypeError: Cannot read properties of null (reading 'classList')
    

    En als ik dan op zoek ga kom ik dit ticket tegen, die gaat over het handtekening veld. Dus is dat veld noodzakelijk voor jou?

    Guido

    Thread starter leolivenl

    (@leolivenl)

    Hoi. Ja. Die is zeker noodzakelijk. Het is vreemd dat met versie 7.5.3 van cf7 dat probleem er niet is. Dus er is gebeurd met de update van de plugin waardoor dit probleem er nu is

    Thread starter leolivenl

    (@leolivenl)

    Ik ga vanavond de update uit de ticket proberen. Je hoort nog van mij.

    Guido

    (@guido07111975)

    Of je vervangt dat handtekeningveld door een checkbox, met daarbij de tekst: hierbij verklaar ik het formulier naar waarheid te hebben ingevuld (oid).

    Guido

    Thread starter leolivenl

    (@leolivenl)

    Dat is niet rechtsgeldig. Bedankt voor je hulp zover. Ik ga nog kijken hoe het op te lossen. Nog geen tijd verder gehad.

    gr.

    Leo

    Hoi,

    Ik vraag mij af. Gebruik je voor de handtekening een ander plugin? Een kans is dat de plugin nog niet geoptimaliseerd met de nieuwe versie m.b.t. jQuery.

    Installeer deze plugin (tijdelijk tot dat er een fix is uitgebracht): https://nl.wordpress.org/plugins/enable-jquery-migrate-helper/

    Hoop dat het hiermee tijdelijk is opgelost.

    Groeten,
    Bas

    Thread starter leolivenl

    (@leolivenl)

    Beste Bas. Voor de handtekening gebruik ik een plugin van dezelfde ontwikkelaar als cf7. Ik ga dit na de vakantie uitproberen. Dank je voor je bericht. Ik hou jullie op de hoogte.
    Gr. Leo

15 reacties aan het bekijken - 1 tot 15 (van in totaal 15)